summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Squillace2016-04-28 22:42:36 +0100
committerFilippo Squillace2016-04-28 22:48:00 +0100
commit925fb1aa21df09bc11fa0fcb9567e533c5369e45 (patch)
tree65cd71e8e294b85a25639e0e954afc2ee0b7547a
downloadaur-925fb1aa21df09bc11fa0fcb9567e533c5369e45.tar.gz
First commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD59
-rw-r--r--pearl.install15
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94a87271068b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pearl-git
+ pkgdesc = Package manager for dotfiles, plugins, programs and any form of code accessible via git. Allow to easily share and sync packages across systems and have them ready to work out of the box.
+ pkgver = r71.2915577
+ pkgrel = 1
+ url = https://github.com/pearl-core/pearl
+ install = pearl.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = git
+ provides = pearl
+ conflicts = pearl
+ source = pearl::git+https://github.com/pearl-core/pearl.git#branch=master
+ md5sums = SKIP
+
+pkgname = pearl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..878b5cfa1031
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Filippo Squillace <feel dot sqoox at gmail dot com>
+# More details on how to change this file:
+# https://wiki.archlinux.org/index.php/PKGBUILD
+# https://wiki.archlinux.org/index.php/Creating_packages
+
+pkgname=pearl-git
+pkgver=r71.2915577
+pkgrel=1
+pkgdesc="Package manager for dotfiles, plugins, programs and any form of code accessible via git. Allow to easily share and sync packages across systems and have them ready to work out of the box."
+arch=('any')
+url="https://github.com/pearl-core/pearl"
+license=('GPL')
+groups=()
+depends=('git')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=${pkgname%-git}.install
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+source=('pearl::git+https://github.com/pearl-core/pearl.git#branch=master')
+noextract=()
+md5sums=('SKIP')
+
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+
+# The examples below are not absolute and need to be adapted to each repo. The
+# primary goal is to generate version numbers that will increase according to
+# pacman's version comparisons with later commits to the repo. The format
+# VERSION='VER_NUM.rREV_NUM.HASH', or a relevant subset in case VER_NUM or HASH
+# are not available, is recommended.
+
+# Git, tags available
+# printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+
+ mkdir -p "${pkgdir}/opt/"
+ cp -R "${srcdir}/${pkgname%-git}" "${pkgdir}/opt/${pkgname%-git}"
+
+ mkdir -p "${pkgdir}/etc/profile.d/"
+ echo "export PATH=\$PATH:/opt/${pkgname%-git}/bin" > "${pkgdir}/etc/profile.d/${pkgname%-git}"
+ chmod +x "${pkgdir}/etc/profile.d/${pkgname%-git}"
+ echo "set -x PATH \$PATH /opt/${pkgname%-git}/bin" > "${pkgdir}/etc/profile.d/${pkgname%-git}.fish"
+ chmod +x "${pkgdir}/etc/profile.d/${pkgname%-git}.fish"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/pearl.install b/pearl.install
new file mode 100644
index 000000000000..573c774d1b30
--- /dev/null
+++ b/pearl.install
@@ -0,0 +1,15 @@
+_msg(){
+ echo 'To configure the PEARL_HOME directory:'
+ echo ' /opt/pearl/bin/pearl init'
+}
+
+# arg 1: the new package version
+post_install() {
+ _msg
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ _msg
+}