summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrevel2018-05-17 04:26:37 +0200
committerrevel2018-05-17 04:26:37 +0200
commit92662277df7c2ef08acac8f970047ef550c96c0a (patch)
treea831a0c47f671c956006f3e691fdd8f6003f80a4
parentdc8dc773a2d07ce569e162b0eb2caae5f285f47e (diff)
downloadaur-92662277df7c2ef08acac8f970047ef550c96c0a.tar.gz
- updated to version 1.0.0
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD25
-rw-r--r--compile.patch12
-rw-r--r--edb.desktop10
-rw-r--r--edb.install32
-rw-r--r--plugin_path.patch10
6 files changed, 28 insertions, 85 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d16497eb742b..ac2596aee876 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,25 @@
# Generated by mksrcinfo v8
-# Mon Mar 13 11:59:03 UTC 2017
+# Thu May 17 02:05:42 UTC 2018
pkgbase = edb-debugger
- pkgdesc = EDB (Evan's Debugger) is a QT4 based binary mode debugger with the goal of having usability on par with OllyDbg.
- pkgver = 0.9.21
- pkgrel = 3
+ pkgdesc = EDB (Evan's Debugger) is a Qt5 based binary mode debugger with the goal of having usability on par with OllyDbg.
+ pkgver = 1.0.0
+ pkgrel = 1
url = http://www.codef00.com/projects#debugger
- install = edb.install
arch = i686
arch = x86_64
license = GPL2
makedepends = boost>=1.35.0
makedepends = cmake
depends = qt5-xmlpatterns
+ depends = qt5-svg
depends = capstone>=3.0
optdepends = graphviz>=2.38.0
- source = https://github.com/eteran/edb-debugger/releases/download/0.9.21/edb-debugger-0.9.21.tgz
+ source = https://github.com/eteran/edb-debugger/releases/download/1.0.0/edb-debugger-1.0.0.tgz
source = edb.desktop
source = plugin_path.patch
- source = compile.patch
- md5sums = 3754a96538b8f881153d26e4bb96e423
- md5sums = 8844cd95efef848f8f4a444259491961
- md5sums = 76f3b5f5b51301d3334a93bdf54f3819
- md5sums = bf3522695c8e00f1649f91ac3a64b064
- sha256sums = 2686619e1288152033d4c9c9a2568cb12841d3854bba8815c37ce77d3bd11706
- sha256sums = af1d0eae06544fbca7a9af2e2f55dc472324abf28402652e88d3b62c1882a132
- sha256sums = 7f28fd5f37bc4493a48c199074ec4393b971246e8d208c28f4348d526ac60dce
- sha256sums = dde1df3ab4c51513ff15c6eddbc63ff6fc8dddd8a51175b2f7911a2d0c8a237a
+ sha256sums = fab87541042df79ea63254e371d81b84d6b72f78141a6ab92512610ed2b7dfac
+ sha256sums = e10b1f8ad676fe2037d62bc8600d8564772ad5e603b10a387b7375b878f60ae4
+ sha256sums = 2b769b96d099036fcb606f32e52465ad6594c098d4060c9fb4d76e05d2f42cab
pkgname = edb-debugger
diff --git a/PKGBUILD b/PKGBUILD
index 874186fe7a0e..8c7608f7d66d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,27 @@
# Maintainer: revel <revelΘmuub·net>
# Contributor: shild <sxp@bk.ru>
+# Contributor: m4tx <m4tx@m4tx.p>
pkgname=edb-debugger
-pkgver=0.9.21
-pkgrel=3
-pkgdesc="EDB (Evan's Debugger) is a QT4 based binary mode debugger with the goal of having usability on par with OllyDbg."
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="EDB (Evan's Debugger) is a Qt5 based binary mode debugger with the goal of having usability on par with OllyDbg."
arch=('i686' 'x86_64')
url='http://www.codef00.com/projects#debugger'
license=('GPL2')
-depends=('qt5-xmlpatterns' 'capstone>=3.0')
+depends=('qt5-xmlpatterns' 'qt5-svg' 'capstone>=3.0')
makedepends=('boost>=1.35.0' 'cmake')
optdepends=('graphviz>=2.38.0')
-install=edb.install
source=("https://github.com/eteran/edb-debugger/releases/download/$pkgver/edb-debugger-$pkgver.tgz"
'edb.desktop'
- 'plugin_path.patch'
- 'compile.patch')
-md5sums=('3754a96538b8f881153d26e4bb96e423'
- '8844cd95efef848f8f4a444259491961'
- '76f3b5f5b51301d3334a93bdf54f3819'
- 'bf3522695c8e00f1649f91ac3a64b064')
-sha256sums=('2686619e1288152033d4c9c9a2568cb12841d3854bba8815c37ce77d3bd11706'
- 'af1d0eae06544fbca7a9af2e2f55dc472324abf28402652e88d3b62c1882a132'
- '7f28fd5f37bc4493a48c199074ec4393b971246e8d208c28f4348d526ac60dce'
- 'dde1df3ab4c51513ff15c6eddbc63ff6fc8dddd8a51175b2f7911a2d0c8a237a')
+ 'plugin_path.patch')
+sha256sums=('fab87541042df79ea63254e371d81b84d6b72f78141a6ab92512610ed2b7dfac'
+ 'e10b1f8ad676fe2037d62bc8600d8564772ad5e603b10a387b7375b878f60ae4'
+ '2b769b96d099036fcb606f32e52465ad6594c098d4060c9fb4d76e05d2f42cab')
prepare() {
cd "edb-debugger-$pkgver"
patch -p1 -i ../plugin_path.patch
- patch -p1 -i ../compile.patch
}
build() {
diff --git a/compile.patch b/compile.patch
deleted file mode 100644
index 25c6cd1adb49..000000000000
--- a/compile.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ruN 1/plugins/DebuggerCore/unix/linux/PlatformProcess.cpp 2/plugins/DebuggerCore/unix/linux/PlatformProcess.cpp
---- 1/plugins/DebuggerCore/unix/linux/PlatformProcess.cpp 2017-03-13 11:40:51.106413430 +0100
-+++ 2/plugins/DebuggerCore/unix/linux/PlatformProcess.cpp 2017-03-13 11:41:13.823536481 +0100
-@@ -364,7 +364,7 @@
-
- while(in.status() == QTextStream::Ok) {
- in >> ch;
-- if(ch == '\0') {
-+ if(ch.isNull()) {
- if(!s.isEmpty()) {
- ret << s;
- }
diff --git a/edb.desktop b/edb.desktop
index fdcc2a56a85a..0256ea9ee8e8 100644
--- a/edb.desktop
+++ b/edb.desktop
@@ -1,16 +1,16 @@
[Desktop Entry]
-Name=Evan's Debugger
-GenericName=Debugger
-Comment=QT4 based binary mode debugger
+Name=edb
+GenericName=edb debugger
+Comment=Qt5 based binary mode debugger
TryExec=edb
Exec=edb
+Icon=edb
Terminal=false
Type=Application
-Icon=edb
Categories=Application;Development;Qt;Debugger;
Actions=Debug
MimeType=application/x-executable
[Desktop Action Debug]
Exec=edb --run %f
-Name=Evan's Debugger (debug with)
+Name=edb (debug with)
diff --git a/edb.install b/edb.install
deleted file mode 100644
index 251231db5e93..000000000000
--- a/edb.install
+++ /dev/null
@@ -1,32 +0,0 @@
-post_install() {
-# echo "===="
-# echo "NOTE"
-# echo "===="
-# echo "* Since the tools that ./edb_make_symbolmap is dependant on are not uniform"
-# echo " across all the platforms that I intend to support. I have built symbol"
-# echo " file generation into edb directly. Running './edb --symbols <filename>' will"
-# echo " create a symbol file in the same format as the old script. For now, ELF is the"
-# echo " only supported format but more will be added as needed. This also means"
-# echo " that future versions of edb will be able to generate symbols as needed"
-# echo " if no symbol file is provided, making things \"just work\" more often."
-# echo "==="
-# echo " EBD's plugins are installed by default into /usr/lib/edb."
-# echo " If you have previously used EDB and have it set to look in a"
-# echo " different directory, then you will need to adjust this. Also"
-# echo " EDB looks for plugins in the current working directory as well"
-# echo " as the directory specified in the options, so that unpriviledged"
-# echo " users can use plugins not installed system wide."
-# echo ""
-
- update-desktop-database -q
- gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- update-desktop-database -q
- gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
-}
diff --git a/plugin_path.patch b/plugin_path.patch
index 295858dbdc2f..e9f980d89c38 100644
--- a/plugin_path.patch
+++ b/plugin_path.patch
@@ -1,12 +1,12 @@
diff -ruN 1/src/CMakeLists.txt 2/src/CMakeLists.txt
---- 1/src/CMakeLists.txt 2016-09-28 23:02:41.000000000 +0200
-+++ 2/src/CMakeLists.txt 2016-10-07 00:34:34.000000000 +0200
-@@ -45,7 +45,7 @@
+--- 1/src/CMakeLists.txt 2018-05-05 00:41:48.000000000 +0200
++++ 2/src/CMakeLists.txt 2018-05-17 01:02:06.731363180 +0200
+@@ -46,7 +46,7 @@
set(GIT_BRANCH "Unknown")
endif()
add_definitions(-DGIT_BRANCH=${GIT_BRANCH})
--add_definitions(-DDEFAULT_PLUGIN_PATH=${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/edb)
-+add_definitions(-DDEFAULT_PLUGIN_PATH=${DEFAULT_PLUGIN_PATH})
+-add_definitions(-DDEFAULT_PLUGIN_PATH=\"${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}/edb\")
++add_definitions(-DDEFAULT_PLUGIN_PATH=\"${DEFAULT_PLUGIN_PATH}\")
include_directories(
"capstone-edb"