summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-01-16 09:15:58 -0300
committerGonzalo Exequiel Pedone2024-01-16 09:15:58 -0300
commit9285c93b60dc5504fbf74838c3f910284a111cc5 (patch)
tree6a983e19a6a6294383df24553ac2a41a0dc88beb
parent562a472398c1fd4d70703699ae788b206b5de892 (diff)
downloadaur-9285c93b60dc5504fbf74838c3f910284a111cc5.tar.gz
Fixed missing symbols.
-rw-r--r--.SRCINFO6
-rw-r--r--0002-Fix-CC-definition.patch2
-rw-r--r--0003-Fix-missing-symbols.patch11
-rw-r--r--PKGBUILD9
-rw-r--r--android-x86-64-zlib-1.3-2-any.pkg.tar.zstbin0 -> 124584 bytes
5 files changed, 22 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3f79382fc3bc..f03bef9194e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = android-x86-64-zlib
pkgdesc = A compression/decompression Library (android)
pkgver = 1.3
- pkgrel = 1
+ pkgrel = 2
url = http://www.zlib.net/
arch = any
license = custom:zlib
@@ -16,8 +16,10 @@ pkgbase = android-x86-64-zlib
source = http://zlib.net/zlib-1.3.tar.gz
source = 0001-Disable-versioning.patch
source = 0002-Fix-CC-definition.patch
+ source = 0003-Fix-missing-symbols.patch
md5sums = 60373b133d630f74f4a1f94c1185a53f
md5sums = c2d3fe1aba79ec3e75758b2f6478c980
- md5sums = 2420be2579d725c1cf1e0aac7ae0a4fe
+ md5sums = 9426b0365165dfa868c905825c48ef8e
+ md5sums = 947d7215f8cfa3c579b4ba47bcd0a6d5
pkgname = android-x86-64-zlib
diff --git a/0002-Fix-CC-definition.patch b/0002-Fix-CC-definition.patch
index a005ad8b62ea..bf31f1b981fb 100644
--- a/0002-Fix-CC-definition.patch
+++ b/0002-Fix-CC-definition.patch
@@ -1,5 +1,5 @@
--- a/configure 2022-03-27 20:39:42.000000000 -0300
-+++ a/configure 2022-06-18 15:34:56.148397566 -0300
++++ b/configure 2022-06-18 15:34:56.148397566 -0300
@@ -174,6 +174,8 @@
else
cc=${CROSS_PREFIX}cc
diff --git a/0003-Fix-missing-symbols.patch b/0003-Fix-missing-symbols.patch
new file mode 100644
index 000000000000..e3c935514446
--- /dev/null
+++ b/0003-Fix-missing-symbols.patch
@@ -0,0 +1,11 @@
+--- a/configure 2024-01-15 17:51:11.925157599 -0300
++++ b/configure 2024-01-15 17:51:46.413390599 -0300
+@@ -231,7 +231,7 @@
+ *sparc*)
+ LDFLAGS="${LDFLAGS} -Wl,--no-warn-rwx-segments" ;;
+ esac
+- LDSHARED=${LDSHARED-"$cc -shared -Wl,-soname,libz.so,--version-script,${SRCDIR}zlib.map"} ;;
++ LDSHARED=${LDSHARED-"$cc -shared -Wl,-soname,libz.so,--version-script,${SRCDIR}zlib.map,--undefined-version"} ;;
+ *BSD | *bsd* | DragonFly)
+ LDSHARED=${LDSHARED-"$cc -shared -Wl,-soname,libz.so.1,--version-script,${SRCDIR}zlib.map"}
+ LDCONFIG="ldconfig -m" ;;
diff --git a/PKGBUILD b/PKGBUILD
index 672be0a151d7..17200ba12dc7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _android_arch=x86-64
pkgname=android-${_android_arch}-zlib
pkgver=1.3
-pkgrel=1
+pkgrel=2
pkgdesc="A compression/decompression Library (android)"
arch=('any')
url="http://www.zlib.net/"
@@ -14,10 +14,12 @@ options=(!strip !buildflags staticlibs !emptydirs)
makedepends=('android-environment' 'android-pkg-config' 'android-sdk-build-tools')
source=("http://zlib.net/zlib-${pkgver}.tar.gz"
"0001-Disable-versioning.patch"
- "0002-Fix-CC-definition.patch")
+ "0002-Fix-CC-definition.patch"
+ "0003-Fix-missing-symbols.patch")
md5sums=('60373b133d630f74f4a1f94c1185a53f'
'c2d3fe1aba79ec3e75758b2f6478c980'
- '2420be2579d725c1cf1e0aac7ae0a4fe')
+ '9426b0365165dfa868c905825c48ef8e'
+ '947d7215f8cfa3c579b4ba47bcd0a6d5')
prepare() {
cd "${srcdir}"/zlib-${pkgver}
@@ -25,6 +27,7 @@ prepare() {
patch -Np1 -i ../0001-Disable-versioning.patch
patch -Np1 -i ../0002-Fix-CC-definition.patch
+ patch -Np1 -i ../0003-Fix-missing-symbols.patch
}
build() {
diff --git a/android-x86-64-zlib-1.3-2-any.pkg.tar.zst b/android-x86-64-zlib-1.3-2-any.pkg.tar.zst
new file mode 100644
index 000000000000..786bd4f741e4
--- /dev/null
+++ b/android-x86-64-zlib-1.3-2-any.pkg.tar.zst
Binary files differ