summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-07-30 00:19:11 -0400
committeracxz2020-07-30 00:19:11 -0400
commit92b743ba0b0f2c1c62d825fbfe7f12405948528a (patch)
treecb43ed8baa102b8c12566b361a5db99022bd7328
parente9406c8e573a22f33cf13c611247f3431a234192 (diff)
downloadaur-92b743ba0b0f2c1c62d825fbfe7f12405948528a.tar.gz
updpkg 1.15.8
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD93
2 files changed, 45 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f7b5e9cb408..0370258986e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ros-noetic-roscpp
pkgdesc = ROS - roscpp is a C++ implementation of ROS.
- pkgver = 1.15.4
+ pkgver = 1.15.8
pkgrel = 1
url = https://github.com/ros/ros_comm
arch = i686
@@ -32,9 +32,8 @@ pkgbase = ros-noetic-roscpp
depends = ros-noetic-rosconsole
depends = ros-noetic-roscpp-serialization
depends = ros-noetic-message-runtime
- conflicts = ros-noetic-roscpp-git
- source = ros-noetic-roscpp-1.15.4.tar.gz::https://github.com/ros/ros_comm/archive/1.15.4.tar.gz
- sha256sums = d5c96a81e0c8554b77666bca5dcc68e03083a761a117038ff9b65f9643751c9e
+ source = ros-noetic-roscpp-1.15.8.tar.gz::https://github.com/ros/ros_comm/archive/1.15.8.tar.gz
+ sha256sums = 7a72219b236aef5f0327c3ce6eba6008980a24a986a5b970b17125890887b494
pkgname = ros-noetic-roscpp
diff --git a/PKGBUILD b/PKGBUILD
index 9cbad2a6ecbb..59d80731fd5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,81 +1,72 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - roscpp is a C++ implementation of ROS."
url='https://github.com/ros/ros_comm'
pkgname='ros-noetic-roscpp'
-pkgver='1.15.4'
+pkgver='1.15.8'
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
pkgrel=1
license=('BSD')
ros_makedepends=(
- ros-noetic-xmlrpcpp
- ros-noetic-roscpp-traits
- ros-noetic-catkin
- ros-noetic-rosgraph-msgs
- ros-noetic-message-generation
- ros-noetic-cpp-common
- ros-noetic-std-msgs
- ros-noetic-rosconsole
- ros-noetic-roscpp-serialization
- ros-noetic-rostime
- ros-noetic-roslang
+ ros-noetic-xmlrpcpp
+ ros-noetic-roscpp-traits
+ ros-noetic-catkin
+ ros-noetic-rosgraph-msgs
+ ros-noetic-message-generation
+ ros-noetic-cpp-common
+ ros-noetic-std-msgs
+ ros-noetic-rosconsole
+ ros-noetic-roscpp-serialization
+ ros-noetic-rostime
+ ros-noetic-roslang
)
makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
- pkg-config
+ cmake
+ ros-build-tools
+ ${ros_makedepends[@]}
+ pkg-config
)
ros_depends=(
- ros-noetic-rostime
- ros-noetic-xmlrpcpp
- ros-noetic-roscpp-traits
- ros-noetic-rosgraph-msgs
- ros-noetic-cpp-common
- ros-noetic-std-msgs
- ros-noetic-rosconsole
- ros-noetic-roscpp-serialization
- ros-noetic-message-runtime
+ ros-noetic-rostime
+ ros-noetic-xmlrpcpp
+ ros-noetic-roscpp-traits
+ ros-noetic-rosgraph-msgs
+ ros-noetic-cpp-common
+ ros-noetic-std-msgs
+ ros-noetic-rosconsole
+ ros-noetic-roscpp-serialization
+ ros-noetic-message-runtime
)
depends=(
- ${ros_depends[@]}
-)
-
-conflicts=(
- 'ros-noetic-roscpp-git'
+ ${ros_depends[@]}
)
_dir="ros_comm-${pkgver}/clients/roscpp"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros/ros_comm/archive/${pkgver}.tar.gz")
-sha256sums=('d5c96a81e0c8554b77666bca5dcc68e03083a761a117038ff9b65f9643751c9e')
+sha256sums=('7a72219b236aef5f0327c3ce6eba6008980a24a986a5b970b17125890887b494')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
-
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/noetic/setup.bash ] && source /opt/ros/noetic/setup.bash
- #Workaround for boost signals
- sed -i 's/signals//g' ${srcdir}/${_dir}/CMakeLists.txt
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
- -DPYTHON_EXECUTABLE=/usr/bin/python \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/noetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}