summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorg Schlisio2016-05-13 21:53:13 +0200
committerGeorg Schlisio2016-05-13 21:53:13 +0200
commit92bb7b0f2e7c39b592d604e95b765b6536d366ac (patch)
tree3fabf9329f8462145a3bd81df2d322b1df93ea11
downloadaur-92bb7b0f2e7c39b592d604e95b765b6536d366ac.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44f5edff8ce4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-free-tls-certificates-git
+ pkgdesc = A simple Python client library for ACME server that issues TLS (aka SSL) certificates
+ pkgver = r34.35e080f
+ pkgrel = 1
+ url = https://github.com/mail-in-a-box/free_tls_certificates
+ arch = any
+ license = CC0
+ source = git+https://github.com/mail-in-a-box/free_tls_certificates.git
+ md5sums = SKIP
+
+pkgname = python-free-tls-certificates-git
+ depends = python-acme
+
+pkgname = python2-free-tls-certificates-git
+ depends = python2-acme
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..835a67cee193
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: fordprefect <fordprefect@dukun.de>
+pkgbase="python-free-tls-certificates-git"
+pkgname=("python-free-tls-certificates-git" "python2-free-tls-certificates-git")
+pkgver=r34.35e080f
+pkgrel=1
+pkgdesc="A simple Python client library for ACME server that issues TLS (aka SSL) certificates"
+url="https://github.com/mail-in-a-box/free_tls_certificates"
+arch=('any')
+license=('CC0')
+source=("git+https://github.com/mail-in-a-box/free_tls_certificates.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/free_tls_certificates"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package_python-free-tls-certificates-git() {
+ depends=("python-acme")
+ cd "$srcdir/free_tls_certificates"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+package_python2-free-tls-certificates-git() {
+ depends=("python2-acme")
+ cd "$srcdir/free_tls_certificates"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+}