summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryugrotavele2015-06-13 17:22:29 -0500
committeryugrotavele2015-06-13 17:22:29 -0500
commit92ebbb62f44505e48a207abd5e863c463175057d (patch)
treed4201b618e874af35f81685544faf64c8d105330
downloadaur-92ebbb62f44505e48a207abd5e863c463175057d.tar.gz
Initial import
-rw-r--r--.AURINFO22
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD30
-rw-r--r--jbidwatcher2
-rw-r--r--jbidwatcher.desktop16
-rw-r--r--jbidwatcher.install11
6 files changed, 103 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..f8f79a6a0bf5
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,22 @@
+pkgbase = jbidwatcher
+ pkgdesc = Allows you to monitor eBay auctions, submit bids, and snipe.
+ pkgver = 2.5.6
+ pkgrel = 2
+ url = http://www.jbidwatcher.com/
+ install = jbidwatcher.install
+ arch = any
+ license = LGPL
+ depends = java-runtime
+ depends = desktop-file-utils
+ noextract = JBidwatcher-2.5.6.jar
+ source = http://www.jbidwatcher.com/download/JBidwatcher-2.5.6.jar
+ source = http://www.jbidwatcher.com/images/jay_noback.png
+ source = jbidwatcher
+ source = jbidwatcher.desktop
+ sha1sums = cd4233fd48fdb75267935d9114c7bf80666efc45
+ sha1sums = 255b09030ebfd9cd7a080164bc10b901e36204b0
+ sha1sums = 50e60c78344f8638977c0524fd72a93b30a1d1ab
+ sha1sums = 8c66182fe39a4a766f62c6f82130358ed21aa79e
+
+pkgname = jbidwatcher
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f8f79a6a0bf5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = jbidwatcher
+ pkgdesc = Allows you to monitor eBay auctions, submit bids, and snipe.
+ pkgver = 2.5.6
+ pkgrel = 2
+ url = http://www.jbidwatcher.com/
+ install = jbidwatcher.install
+ arch = any
+ license = LGPL
+ depends = java-runtime
+ depends = desktop-file-utils
+ noextract = JBidwatcher-2.5.6.jar
+ source = http://www.jbidwatcher.com/download/JBidwatcher-2.5.6.jar
+ source = http://www.jbidwatcher.com/images/jay_noback.png
+ source = jbidwatcher
+ source = jbidwatcher.desktop
+ sha1sums = cd4233fd48fdb75267935d9114c7bf80666efc45
+ sha1sums = 255b09030ebfd9cd7a080164bc10b901e36204b0
+ sha1sums = 50e60c78344f8638977c0524fd72a93b30a1d1ab
+ sha1sums = 8c66182fe39a4a766f62c6f82130358ed21aa79e
+
+pkgname = jbidwatcher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..beec2af62f43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: yugrotavele <yugrotavele at archlinux dot us>
+# Contributor: Max Nemeth <max.nemeth@gmail.com>
+# Contributor: Bob Finch <bfinch@qrparci.net>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+
+pkgname=jbidwatcher
+pkgver=2.5.6
+pkgrel=2
+pkgdesc='Allows you to monitor eBay auctions, submit bids, and snipe.'
+arch=('any')
+url="http://www.jbidwatcher.com/"
+license=('LGPL')
+depends=('java-runtime' 'desktop-file-utils')
+noextract=("JBidwatcher-${pkgver}.jar")
+install=jbidwatcher.install
+source=(http://www.jbidwatcher.com/download/JBidwatcher-${pkgver}.jar
+ http://www.jbidwatcher.com/images/jay_noback.png
+ jbidwatcher jbidwatcher.desktop)
+sha1sums=('cd4233fd48fdb75267935d9114c7bf80666efc45'
+ '255b09030ebfd9cd7a080164bc10b901e36204b0'
+ '50e60c78344f8638977c0524fd72a93b30a1d1ab'
+ '8c66182fe39a4a766f62c6f82130358ed21aa79e')
+
+package() {
+ cd "${srcdir}"
+ install -D -m755 jbidwatcher "${pkgdir}/usr/bin/jbidwatcher"
+ install -D -m644 JBidwatcher-${pkgver}.jar "${pkgdir}/usr/share/java/jbidwatcher/JBidwatcher.jar"
+ install -D -m644 jbidwatcher.desktop "${pkgdir}/usr/share/applications/jbidwatcher.desktop"
+ install -D -m644 jay_noback.png "${pkgdir}/usr/share/pixmaps/jay_noback.png"
+}
diff --git a/jbidwatcher b/jbidwatcher
new file mode 100644
index 000000000000..d7dc12b9010e
--- /dev/null
+++ b/jbidwatcher
@@ -0,0 +1,2 @@
+#!/bin/sh
+java -Xmx512m -jar /usr/share/java/jbidwatcher/JBidwatcher.jar
diff --git a/jbidwatcher.desktop b/jbidwatcher.desktop
new file mode 100644
index 000000000000..681d543e07c1
--- /dev/null
+++ b/jbidwatcher.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Name=JBidwatcher
+Name[en_US]=JBidwatcher
+Comment=EBay Auction Sniper
+Comment[en_US]=EBay Auction Sniper
+Encoding=UTF-8
+Exec=jbidwatcher
+Icon=jay_noback.png
+MimeType=text/plain
+StartupNotify=true
+Terminal=false
+TerminalOptions=
+Type=Application
+Categories=Application;Network;
+X-DCOP-ServiceType=none
+X-KDE-SubstituteUID=false
diff --git a/jbidwatcher.install b/jbidwatcher.install
new file mode 100644
index 000000000000..2eaa60550d51
--- /dev/null
+++ b/jbidwatcher.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}