summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2019-12-23 09:51:57 -0500
committerTed Alff2019-12-23 09:51:57 -0500
commit9318a0ddb019229ee2b96931d43791a85f5137ba (patch)
tree08521f91763255608f187a18f63982f61034a54f
parenta7682cf9baa9f1f72c051bd914d38f28705c5c01 (diff)
downloadaur-9318a0ddb019229ee2b96931d43791a85f5137ba.tar.gz
Update to latest git. The only AUR package that depends on this (superpaper) requires the unreleased 1.0.3 version
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD21
2 files changed, 20 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b759d52d77eb..3e40a68e1200 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = python-system_hotkey
pkgdesc = Python library for system wide hotkeys
- pkgver = 1.0.2
+ pkgver = 1.0.2+10+9541587
pkgrel = 1
url = https://github.com/timeyyy/system_hotkey
arch = any
license = BSD
makedepends = python-setuptools
+ makedepends = git
depends = python-xcffib
- source = python-system_hotkey-1.0.2.tar.gz::https://github.com/timeyyy/system_hotkey/archive/1.0.2.tar.gz
- sha256sums = 4d6e06bf359efecf4bea251e330c852f83b9150f503df28fd94239499f4ff606
+ source = python-system_hotkey::git+https://github.com/timeyyy/system_hotkey
+ sha256sums = SKIP
pkgname = python-system_hotkey
diff --git a/PKGBUILD b/PKGBUILD
index ab8589c41f18..f91fc64337a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,29 @@
# Contributor: twa022 <twa022 at gmail dot com>
pkgname=python-system_hotkey
-pkgver=1.0.2
+_pkgver=1.0.2
+pkgver=1.0.2+10+9541587
pkgrel=1
pkgdesc="Python library for system wide hotkeys"
arch=('any')
url="https://github.com/timeyyy/system_hotkey"
license=('BSD')
depends=('python-xcffib')
-makedepends=('python-setuptools')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/timeyyy/${pkgname/python-/}/archive/${pkgver}.tar.gz")
-sha256sums=('4d6e06bf359efecf4bea251e330c852f83b9150f503df28fd94239499f4ff606')
+makedepends=('python-setuptools' 'git')
+source=("${pkgname}::git+https://github.com/timeyyy/system_hotkey")
+sha256sums=('SKIP')
+_release_commit='f30711752d0d4510cda2a213e4ec9c665677e167'
+#source=("${pkgname}-${pkgver}.tar.gz::https://github.com/timeyyy/${pkgname/python-/}/archive/${pkgver}.tar.gz")
+#sha256sums=('4d6e06bf359efecf4bea251e330c852f83b9150f503df28fd94239499f4ff606')
+
+pkgver() {
+# cd "${srcdir}/${pkgname/python-/}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
+ printf "%s+%s+%s" "${_pkgver}" "$(( `git rev-list --count HEAD` - `git rev-list --count ${_release_commit}` ))" "$( git describe --always )"
+}
package() {
- cd "${srcdir}/${pkgname/python-/}-${pkgver}"
+# cd "${srcdir}/${pkgname/python-/}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
python setup.py install --root="${pkgdir}"
}