summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2018-08-30 04:58:52 +0430
committerMohammadreza Abdollahzadeh2018-08-30 04:58:52 +0430
commit9341e3729d5f368de0d249802e492214485f4482 (patch)
tree93e6b9f92cc92278d5311ccc004f90541f6da799
parent56246632eca14635ec9d57d163b6939fa2ed3cc8 (diff)
downloadaur-9341e3729d5f368de0d249802e492214485f4482.tar.gz
change upstream url
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD30
-rw-r--r--gnome-shell-extension.install13
3 files changed, 35 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 029622be3dd6..6712b2c9e75a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = gnome-shell-extension-panel-osd-git
pkgdesc = Place gnome-shell notifications under the panel instead of above the message-tray. (git version)
- pkgver = r113.c33034a
+ pkgver = 1.0.r45.geb0d3c2
pkgrel = 1
- url = https://github.com/jenslody/gnome-shell-extension-panel-osd
+ url = https://gitlab.com/jenslody/gnome-shell-extension-panel-osd
+ install = gnome-shell-extension.install
arch = any
license = GPL3
makedepends = gnome-common
@@ -13,7 +14,7 @@ pkgbase = gnome-shell-extension-panel-osd-git
depends = gnome-shell
provides = gnome-shell-extension-panel-osd
conflicts = gnome-shell-extension-panel-osd
- source = git+https://github.com/jenslody/gnome-shell-extension-panel-osd.git
+ source = git+https://gitlab.com/jenslody/gnome-shell-extension-panel-osd.git
sha256sums = SKIP
pkgname = gnome-shell-extension-panel-osd-git
diff --git a/PKGBUILD b/PKGBUILD
index 98f31d350925..9af4a9d0e39b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,42 @@
-# Maintainer: Edgard Castro <castro@edgard.org>
+# $Id$
+# Maintainer: Mohammadreza Abdollahzadeh < morealaz at gmail dot com >
+# Contributor: Edgard Castro <castro@edgard.org>
# Contributor: Carl George < arch at cgtx dot us >
# Contributor: Tamás Barta < barta dot tamas dot d at gmail dot com >
pkgname=gnome-shell-extension-panel-osd-git
-pkgver=r113.c33034a
+pkgver=1.0.r45.geb0d3c2
pkgrel=1
pkgdesc='Place gnome-shell notifications under the panel instead of above the message-tray. (git version)'
arch=(any)
_githubname=gnome-shell-extension-panel-osd
_githubowner=jenslody
-url="https://github.com/${_githubowner}/${_githubname}"
+url="https://gitlab.com/${_githubowner}/${_githubname}"
license=(GPL3)
depends=('gnome-shell')
makedepends=("gnome-common" "automake" "autoconf" "intltool" "pkg-config")
-source=("git+https://github.com/${_githubowner}/${_githubname}.git")
-sha256sums=('SKIP')
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
+install='gnome-shell-extension.install'
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
pkgver() {
- cd "${srcdir}/${_githubname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${srcdir}/${_githubname}"
+ #printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${_githubname}"
- ./autogen.sh --prefix=/usr
- make
+ cd "${srcdir}/${_githubname}"
+ ./autogen.sh --prefix=/usr
+ make
}
package() {
- cd "${srcdir}/${_githubname}"
- make DESTDIR="$pkgdir" install
+ cd "${srcdir}/${_githubname}"
+ make DESTDIR="$pkgdir" install
}
+# vim:set ts=2 sw=2 et:
diff --git a/gnome-shell-extension.install b/gnome-shell-extension.install
new file mode 100644
index 000000000000..484bc1b03f77
--- /dev/null
+++ b/gnome-shell-extension.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo "==> ****************************************************"
+ echo "==> Don't forget to Restart GNOME Shell ([Alt]+[F2], r)."
+ echo "==> ****************************************************"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}