summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartłomiej Piotrowski2018-01-06 20:16:34 +0100
committerBartłomiej Piotrowski2018-01-06 20:16:34 +0100
commit93583b7eb5ad23bb1281b4f84e2ff0ab1658869b (patch)
tree780db6dfc786c9dda6feece62fc5037a4d6ec215
downloadaur-93583b7eb5ad23bb1281b4f84e2ff0ab1658869b.tar.gz
Import from official repositories
-rw-r--r--.SRCINFO23
-rw-r--r--ChangeLog7
-rw-r--r--PKGBUILD59
-rw-r--r--gnump3d-proxy.patch175
-rw-r--r--gnump3d.install23
-rw-r--r--gnump3d.service11
6 files changed, 298 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86b7560f1e13
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gnump3d
+ pkgdesc = A streaming server for MP3s, OGG vorbis files, movies and other media formats.
+ pkgver = 3.0
+ pkgrel = 9
+ url = http://www.gnu.org/software/gnump3d/
+ install = gnump3d.install
+ arch = any
+ license = GPL
+ depends = sh
+ depends = perl
+ backup = etc/gnump3d/gnump3d.conf
+ source = https://savannah.gnu.org/download/gnump3d/gnump3d-3.0.tar.bz2
+ source = https://savannah.gnu.org/download/gnump3d/gnump3d-3.0.tar.bz2.sig
+ source = gnump3d.service
+ source = gnump3d-proxy.patch
+ validpgpkeys = DB1FF3FB1D08FC01ED222243C0CFC6B3CD4C0D9D
+ sha256sums = 1ac5bd0e850b0e18ccd9d19219f5108fa84b50d8ae3825a361e8b907eab7f19c
+ sha256sums = SKIP
+ sha256sums = a8fb63b0bb49e7fb4149a7f8c15e1a337bfa4787f630fa9fcd696a6bdf6418e8
+ sha256sums = 1a1829bf55f46fbfa249053732033b59f7ab1dc27a2f3c4e7ed71f03ac10a1ae
+
+pkgname = gnump3d
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..457d82628687
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,7 @@
+2008-01-20 JJDaNiMoTh <jjdanimoth@gmail.com>
+ * Changed place for manpage.
+
+2008-01-05 Douglas Soares de Andrade <dsa@aur.archlinux.org>
+
+ * Added for x86_64
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2940d1e2f2b5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# $Id: PKGBUILD 231762 2017-06-01 08:41:26Z felixonmars $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: Stefan Bergstrom <stefan.bergstrom@gmail.com>
+
+pkgname=gnump3d
+pkgver=3.0
+pkgrel=9
+url="http://www.gnu.org/software/gnump3d/"
+arch=(any)
+pkgdesc="A streaming server for MP3s, OGG vorbis files, movies and other media formats."
+license=("GPL")
+depends=('sh' 'perl')
+backup=('etc/gnump3d/gnump3d.conf')
+install=gnump3d.install
+validpgpkeys=('DB1FF3FB1D08FC01ED222243C0CFC6B3CD4C0D9D')
+source=("https://savannah.gnu.org/download/$pkgname/$pkgname-$pkgver.tar.bz2"{,.sig}
+ 'gnump3d.service'
+ 'gnump3d-proxy.patch')
+sha256sums=('1ac5bd0e850b0e18ccd9d19219f5108fa84b50d8ae3825a361e8b907eab7f19c'
+ 'SKIP'
+ 'a8fb63b0bb49e7fb4149a7f8c15e1a337bfa4787f630fa9fcd696a6bdf6418e8'
+ '1a1829bf55f46fbfa249053732033b59f7ab1dc27a2f3c4e7ed71f03ac10a1ae')
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ patch -p1 <"$srcdir"/gnump3d-proxy.patch
+
+ install -d "$pkgdir"/var/log/gnump3d
+ install -d "$pkgdir"/var/cache/gnump3d/serving
+
+ install -d "$pkgdir"/usr/share/perl5/vendor_perl/gnump3d/plugins
+ install -d "$pkgdir"/usr/share/perl5/vendor_perl/gnump3d/lang
+ install -m 644 lib/gnump3d/*.pm "$pkgdir"/usr/share/perl5/vendor_perl/gnump3d
+ install -m 644 lib/gnump3d/plugins/*.pm "$pkgdir"/usr/share/perl5/vendor_perl/gnump3d/plugins
+ install -m 644 lib/gnump3d/lang/*.pm "$pkgdir"/usr/share/perl5/vendor_perl/gnump3d/lang
+
+ install -d "$pkgdir"/usr/bin
+ install -m 755 bin/gnump3d2 "$pkgdir"/usr/bin/gnump3d
+ install -m 755 bin/gnump3d-top bin/gnump3d-index "$pkgdir"/usr/bin
+
+ install -d "$pkgdir"/usr/share/man/man1
+ install -m 644 man/gnump3d-top.1 man/gnump3d-index.1 man/gnump3d.1 man/gnump3d.conf.1 "$pkgdir"/usr/share/man/man1
+
+ install -d "$pkgdir"/usr/share/gnump3d
+ cp -R templates/* "$pkgdir"/usr/share/gnump3d
+ chmod -R a+r "$pkgdir"/usr/share/gnump3d
+ chmod +rx "$pkgdir"/usr/share/gnump3d/*/
+
+ sed -i "s|PLUGINDIR|/usr/share/perl5/vendor_perl|g" etc/gnump3d.conf
+ install -d "$pkgdir"/etc/gnump3d
+ install -m 644 etc/gnump3d.conf etc/mime.types "$pkgdir"/etc/gnump3d
+ install -m 644 etc/gnump3d.conf etc/file.types "$pkgdir"/etc/gnump3d
+
+ mkdir -p "$pkgdir"/srv/mp3
+ sed -i "s|/home/mp3|/srv/mp3|" "$pkgdir"/etc/gnump3d/gnump3d.conf
+
+ install -Dm0644 "$srcdir"/$pkgname.service "$pkgdir"/usr/lib/systemd/system/$pkgname.service
+}
diff --git a/gnump3d-proxy.patch b/gnump3d-proxy.patch
new file mode 100644
index 000000000000..e0e6023e8e04
--- /dev/null
+++ b/gnump3d-proxy.patch
@@ -0,0 +1,175 @@
+diff -wbBur gnump3d-3.0/bin/gnump3d2 gnump3d-3.0.my/bin/gnump3d2
+--- gnump3d-3.0/bin/gnump3d2 2007-10-18 17:34:02.000000000 +0000
++++ gnump3d-3.0.my/bin/gnump3d2 2010-07-21 16:30:13.000000000 +0000
+@@ -357,11 +357,9 @@
+ #
+ # Make sure our host is defined.
+ #
+-if ( ! $host_rewrite ) { $host .= ":$PORT"; }
++if ( ! $host_rewrite ) { $host = "http://".$host.":$PORT"; }
+ else { $host = $host_rewrite; }
+
+-
+-
+ #
+ # Print a little banner unless the user specified a quiet startup.
+ #
+@@ -738,12 +736,12 @@
+ if ( $chost =~ /(.*):([0-9]+)/ )
+ {
+ # Host already contains a port.
+- $host = $chost;
++ $host = "http://" . $chost;
+ }
+ else
+ {
+ # Host was missing a port number.
+- $host = $chost . ":" . $PORT;
++ $host = "http://" . $chost . ":" . $PORT;
+ }
+ }
+ }
+@@ -966,7 +964,7 @@
+ my $header = getHTTPHeader( 200, "audio/x-mpegurl" );
+ &sendData( $data, $header );
+
+- my $link = "http://" . $host . &urlEncode( $plainFile );
++ my $link = $host . &urlEncode( $plainFile );
+
+ #
+ # Get ready to add on any bitrate settings to the file
+@@ -1545,7 +1543,7 @@
+ #
+ # Escape the filename.
+ #
+- $file = "http://" . $host . urlEncode( $file ) . $quality;
++ $file = $host . urlEncode( $file ) . $quality;
+
+ #
+ # Add to the playlist
+@@ -1658,7 +1656,7 @@
+ #
+ # Line is fully qualified path.
+ #
+- $line = "http://" . $host . "/" . &urlEncode($1);
++ $line = $host . "/" . &urlEncode($1);
+ }
+ elsif ( $line =~ /^\// )
+ {
+@@ -1666,14 +1664,14 @@
+ # Line is fully qualified. Just prepend the
+ # server name to it.
+ #
+- $line = "http://" . $host . &urlEncode($line);
++ $line = $host . &urlEncode($line);
+ }
+ else
+ {
+ #
+ # Line is just a straight filename, it needs
+ # server:port + directory prepended to it.
+- $line = "http://" . $host . &urlEncode( $dir . "/" . $line );
++ $line = $host . &urlEncode( $dir . "/" . $line );
+ }
+
+ #
+@@ -2216,7 +2214,7 @@
+ $link = &urlEncode( $link );
+
+ my $name = $file;
+- my $rec = "<a href=\"${link}recurse.m3u\">$play_rec</a>";
++ my $rec = "<a href=\"${host}${link}recurse.m3u\">$play_rec</a>";
+ my $row;
+
+ if ( $totalSubdirs % 2 == 0 )
+@@ -2314,10 +2312,10 @@
+ #
+ # Do the interpolation.
+ #
+- $row =~ s/\$LINK/$link/g;
++ $row =~ s/\$LINK/$host$link/g;
+ $row =~ s/\$DIR_NAME/$name/g;
+ $row =~ s/\$RECURSE/$rec/g;
+- $row =~ s/\$LINK/$link/g;
++ $row =~ s/\$LINK/$host$link/g;
+
+ #
+ # Add to the text we're building up.
+@@ -2455,8 +2453,10 @@
+ {
+ $output = $file_format2;
+ }
+- $output =~ s/\$LINK/$link/g;
+- $output =~ s/\$PLAINLINK/$link/g;
++ $output =~ s/\$LINK/$host$link/g;
++ $output =~ s/\$PLAINLINK/$host$link/g;
++ $output =~ s/\$RELPATH/$link/g;
++ $output =~ s/\$HOST/$host/g;
+ $output =~ s/\$SONG_FORMAT/$display/g;
+
+ #
+@@ -2555,8 +2555,10 @@
+ $output = $file_format2;
+ }
+
+- $output =~ s/\$LINK/$link/g;
+- $output =~ s/\$PLAINLINK/$plink/g;
++ $output =~ s/\$LINK/$host$link/g;
++ $output =~ s/\$PLAINLINK/$host$plink/g;
++ $output =~ s/\$RELPATH/$plink/g;
++ $output =~ s/\$HOST/$host/g;
+ $output =~ s/\$SONG_FORMAT/$display/g;
+
+ #
+@@ -2677,8 +2679,10 @@
+ $output = $file_format2;
+ }
+
+- $output =~ s/\$LINK/$link/g;
+- $output =~ s/\$PLAINLINK/$plink/g;
++ $output =~ s/\$LINK/$host$link/g;
++ $output =~ s/\$PLAINLINK/$host$plink/g;
++ $output =~ s/\$RELPATH/$plink/g;
++ $output =~ s/\$HOST/$host/g;
+ $output =~ s/\$SONG_FORMAT/$display/g;
+
+ #
+@@ -2783,7 +2787,7 @@
+ my ( $dir ) = (@_);
+ my $prev = "";
+
+- my $banner = "[ <a href=\"/\">Home</a>";
++ my $banner = "[ <a href=\"${host}/\">Home</a>";
+
+ my @list = splitPath( $host, $dir );
+
+@@ -2800,7 +2804,7 @@
+ {
+ $component =~ s/$host//g;
+ $component = &urlEncode( $component );
+- $banner .= " &middot; <a href=\"http://$host$component\">$path</a>";
++ $banner .= " &middot; <a href=\"$host$component\">$path</a>";
+ }
+ }
+ }
+@@ -2811,7 +2815,7 @@
+ #
+ $dir =~ s/(.*)\/?/$1/;
+ $dir = &urlEncode( $dir );
+- $banner .= " | <a href=\"$dir/recurse.m3u\">$play_rec</a>";
++ $banner .= " | <a href=\"${host}${dir}/recurse.m3u\">$play_rec</a>";
+ }
+ $banner .= " ]";
+
+diff -wbBur gnump3d-3.0/etc/gnump3d.conf gnump3d-3.0.my/etc/gnump3d.conf
+--- gnump3d-3.0/etc/gnump3d.conf 2007-10-18 17:34:02.000000000 +0000
++++ gnump3d-3.0.my/etc/gnump3d.conf 2010-07-21 16:31:31.000000000 +0000
+@@ -490,7 +490,7 @@
+ # This is useful if you want to have alternating background colors for
+ # each entry in a table, for example.
+ #
+-file_format = <tr><td width="10%">&nbsp;</td><td><a href="$LINK">$SONG_FORMAT</a></td><td align="right">[<a href="/info$PLAINLINK">Info</a>] [<a href="$PLAINLINK">Download</a>]</td></tr>
++file_format = <tr><td width="10%">&nbsp;</td><td><a href="$LINK">$SONG_FORMAT</a></td><td align="right">[<a href="$HOST/info$RELPATH">Info</a>] [<a href="$PLAINLINK">Download</a>]</td></tr>
+
+
+
diff --git a/gnump3d.install b/gnump3d.install
new file mode 100644
index 000000000000..78d9104e0076
--- /dev/null
+++ b/gnump3d.install
@@ -0,0 +1,23 @@
+# arg 1: the new package version
+post_install() {
+ chown nobody:root /var/cache/gnump3d /var/cache/gnump3d/serving
+
+ echo
+ echo "----[ NOTE ]----------------------------------------------------------"
+ echo "| Before starting the server, edit /etc/gnump3d/gnump3d.conf to your |"
+ echo "| liking. For instance, you will probably want to change the \"root\" |"
+ echo "| variable so that it points to your music collection. |"
+ echo "| |"
+ echo "| When the \"root\" variable is properly set, run |"
+ echo "| /usr/bin/gnump3d-index |"
+ echo "| This will create a database in /var/cache/gnump3d/ for gnump3d. |"
+ echo "| |"
+ echo "| Per default, the server runs as \"nobody\", which is a Good Thing. |"
+ echo "| |"
+ echo "| To make the server start on boot, add \"gnump3d\" to the DAEMONS |"
+ echo "| array in /etc/rc.conf. |"
+ echo "----------------------------------------------------------------------"
+ echo
+}
+
+
diff --git a/gnump3d.service b/gnump3d.service
new file mode 100644
index 000000000000..7fc17d74ddc1
--- /dev/null
+++ b/gnump3d.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=A streaming server
+After=network.target remote-fs.target nss-lookup.target
+
+[Service]
+Type=simple
+PIDFile=/var/run/ajaxterm.pid
+ExecStart=/usr/bin/gnump3d --quiet
+
+[Install]
+WantedBy=multi-user.target