summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-08 09:39:21 +0800
committerzxp198210052024-03-08 09:39:21 +0800
commit935ac0ae1b79bbea8ad015446c2ed1be6e5e14d0 (patch)
treef727b0a3474724581cd46506e3fed82d07180663
parent3063435502f93eaca8323f5f1738f1eacc05a374 (diff)
downloadaur-935ac0ae1b79bbea8ad015446c2ed1be6e5e14d0.tar.gz
update to 6.0.3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--whalebird.sh3
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0165bf4e66fe..c09842dc5115 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = whalebird-bin
pkgdesc = An Electron based Mastodon, Pleroma, and Misskey client
- pkgver = 6.0.2
+ pkgver = 6.0.3
pkgrel = 1
url = https://whalebird.social/
arch = x86_64
license = GPL-3.0-only
depends = electron27
- provides = whalebird=6.0.2
+ provides = whalebird=6.0.3
conflicts = whalebird
- source = whalebird-6.0.2.deb::https://github.com/h3poteto/whalebird-desktop/releases/download/v6.0.2/Whalebird-6.0.2-linux-amd64.deb
+ source = whalebird-6.0.3.deb::https://github.com/h3poteto/whalebird-desktop/releases/download/v6.0.3/Whalebird-6.0.3-linux-amd64.deb
source = whalebird.sh
- sha256sums = f7072eef1d678b3184b1ea38856b8bcfc23cd67865d4f3ac0b0b3a584e0dc00c
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ sha256sums = 8867317a97ad98fc18af4a7859df76e8a91bfd5d0670e9a762485b922925ba7c
+ sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
pkgname = whalebird-bin
diff --git a/PKGBUILD b/PKGBUILD
index 672ac96419a8..290cc8cd506f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor : Mélanie Chauvel (ariasuni) <perso@hack-libre.org>
pkgname=whalebird-bin
_pkgname=Whalebird
-pkgver=6.0.2
+pkgver=6.0.3
_electronversion=27
pkgrel=1
pkgdesc="An Electron based Mastodon, Pleroma, and Misskey client"
@@ -21,8 +21,8 @@ source=(
"${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/v${pkgver}/${_pkgname}-${pkgver}-linux-amd64.deb"
"${pkgname%-bin}.sh"
)
-sha256sums=('f7072eef1d678b3184b1ea38856b8bcfc23cd67865d4f3ac0b0b3a584e0dc00c'
- '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
+sha256sums=('8867317a97ad98fc18af4a7859df76e8a91bfd5d0670e9a762485b922925ba7c'
+ '50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
diff --git a/whalebird.sh b/whalebird.sh
index f9ced1432cfc..86cb3dc6a9bf 100644
--- a/whalebird.sh
+++ b/whalebird.sh
@@ -1,10 +1,11 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then