summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXuanrui Qi2022-08-16 02:03:00 +0900
committerXuanrui Qi2022-08-16 02:03:00 +0900
commit937eb930bef5e37bc4d97c52d22f3be995c1f467 (patch)
tree6b812cda635b0c7c5e36a5b61c1e638b11fd82db
parentc4c75bcd269522ea10da3e6b283c2a026a1d6710 (diff)
downloadaur-937eb930bef5e37bc4d97c52d22f3be995c1f467.tar.gz
Version 20220210
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 582704163287..baca486b2bb0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = ocaml-menhir
pkgdesc = Menhir is a LR(1) parser generator for the OCaml.
- pkgver = 20211128
+ pkgver = 20220210
pkgrel = 1
url = http://cristal.inria.fr/~fpottier/menhir/
arch = x86_64
license = GPL
license = QPL
makedepends = dune>=2.0
+ makedepends = ocaml-findlib
depends = ocaml>=4.02.3
options = !strip
options = !makeflags
- source = https://gitlab.inria.fr/fpottier/menhir/-/archive/20211128/menhir-20211128.tar.gz
- sha256sums = 7f29f717b67ff31ad3dbabb17996f5171e6bba417f6fff1458dbdee71966c126
+ source = https://gitlab.inria.fr/fpottier/menhir/-/archive/20220210/menhir-20220210.tar.gz
+ sha256sums = 4e27165777d9466c26a129c1c4ed60eb06875cbf6fda9a9e971d234e5ef7a314
pkgname = ocaml-menhir
diff --git a/PKGBUILD b/PKGBUILD
index e5f9ff7db409..528dc8545351 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,17 +8,17 @@
# Contributor: Nicolas Pouillard <nicolas.pouillard@gmail.com>
pkgname=ocaml-menhir
-pkgver=20211128
+pkgver=20220210
pkgrel=1
pkgdesc="Menhir is a LR(1) parser generator for the OCaml."
arch=("x86_64")
url="http://cristal.inria.fr/~fpottier/menhir/"
license=('GPL' 'QPL')
depends=('ocaml>=4.02.3')
-makedepends=('dune>=2.0')
+makedepends=('dune>=2.0' 'ocaml-findlib')
options=(!strip !makeflags)
source=("https://gitlab.inria.fr/fpottier/menhir/-/archive/${pkgver}/menhir-${pkgver}.tar.gz")
-sha256sums=('7f29f717b67ff31ad3dbabb17996f5171e6bba417f6fff1458dbdee71966c126')
+sha256sums=('4e27165777d9466c26a129c1c4ed60eb06875cbf6fda9a9e971d234e5ef7a314')
build() {
cd "$srcdir/${pkgname/ocaml-/}-$pkgver"
@@ -27,7 +27,10 @@ build() {
package() {
cd "$srcdir/${pkgname/ocaml-/}-$pkgver"
- dune install --prefix "${pkgdir}/usr" \
- --libdir "lib/ocaml"
+ dune install --destdir="${pkgdir}" --prefix="/usr" \
+ --libdir="$(ocamlfind printconf destdir)"
+
+ install -dm755 "${pkgdir}/usr/share/"
+ mv "${pkgdir}/usr/doc" "${pkgdir}/usr/share/"
}