summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2016-02-23 03:23:34 +0100
committerDavid Runge2016-02-23 03:23:34 +0100
commit938c57cdec1e42ff5aa5790c47f40a027e3c5742 (patch)
tree419a9e3151b0c2cc1180acf0b84836ab976f19d3
downloadaur-938c57cdec1e42ff5aa5790c47f40a027e3c5742.tar.gz
.SRCINFO,PKGBUILD: First package version.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9189c762f361
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Feb 23 02:23:00 UTC 2016
+pkgbase = prosody-mod-admin-web-hg
+ pkgdesc = A basic web administration interface for prosody.
+ pkgver = r2051.cb0fc00a7086
+ pkgrel = 1
+ url = https://modules.prosody.im/mod_admin_web.html
+ arch = any
+ license = MIT
+ makedepends = mercurial,
+ makedepends = wget
+ depends = prosody
+ source = hg+https://hg.prosody.im/prosody-modules/
+ sha1sums = SKIP
+
+pkgname = prosody-mod-admin-web-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9793a8369d99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: David Runge <dave@sleepmap.de>
+pkgname=prosody-mod-admin-web-hg
+pkgver=r2051.cb0fc00a7086
+pkgrel=1
+pkgdesc="A basic web administration interface for prosody."
+arch=('any')
+url="https://modules.prosody.im/mod_admin_web.html"
+license=('MIT')
+depends=('prosody')
+makedepends=('mercurial', 'wget')
+source=("hg+https://hg.prosody.im/prosody-modules/")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/prosody-modules/"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+prepare() {
+ cd "${srcdir}/prosody-modules/mod_admin_web/admin_web"
+ ./get_deps.sh
+}
+
+package() {
+ cd "${srcdir}/prosody-modules/mod_admin_web/admin_web"
+ install -Dm 644 mod_admin_web.lua "${pkgdir}/usr/lib/prosody/modules/mod_admin_web.lua"
+ cp -r www_files "${pkgdir}/usr/lib/prosody/modules/"
+}