summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJameson Pugh2015-06-08 09:05:35 -0400
committerJameson Pugh2015-06-08 09:05:35 -0400
commit9396a0649562eca73ae271c4f9c1e4b345afdd06 (patch)
treea6228fec0cbae1fe650e6e8d492a6de74e8878c0
downloadaur-9396a0649562eca73ae271c4f9c1e4b345afdd06.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
-rw-r--r--direvent.install22
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..994e34cf6c21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = direvent
+ pkgdesc = Deamon that monitors events in the file system directories
+ pkgver = 5.0
+ pkgrel = 1
+ url = http://www.gnu.org.ua/software/direvent/
+ install = direvent.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ source = http://ftp.gnu.org/gnu/direvent/direvent-5.0.tar.gz
+ sha256sums = 1fbd26ce98a4e752e82c3b5a0ae85d3360f1fb273c5ef373dc1c55e3c30824c4
+
+pkgname = direvent
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b51a54c69a66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+# Contributor: Timothy Rice <t.rice@ms.unimelb.edu.au>
+
+pkgname=direvent
+pkgver=5.0
+pkgrel=1
+pkgdesc="Deamon that monitors events in the file system directories"
+arch=('i686' 'x86_64')
+url="http://www.gnu.org.ua/software/direvent/"
+license=("GPL")
+depends=('glibc')
+install=$pkgname.install
+source=("http://ftp.gnu.org/gnu/direvent/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('1fbd26ce98a4e752e82c3b5a0ae85d3360f1fb273c5ef373dc1c55e3c30824c4')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make check
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/direvent.install b/direvent.install
new file mode 100644
index 000000000000..08825a71dc9b
--- /dev/null
+++ b/direvent.install
@@ -0,0 +1,22 @@
+infodir=usr/share/info
+filelist=(direvent.info)
+
+post_install() {
+ [[ -x usr/bin/install-info ]] || return 0
+ for file in "${filelist[@]}"; do
+ install-info "$infodir/$file.gz" "$infodir/dir" 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+pre_remove() {
+ [[ -x usr/bin/install-info ]] || return 0
+ for file in "${filelist[@]}"; do
+ install-info --delete "$infodir/$file.gz" "$infodir/dir" 2> /dev/null
+ done
+}
+
+# vim:set ts=2 sw=2 et: