summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Jones2019-02-16 15:06:22 +0000
committerPhilip Jones2019-02-16 15:43:19 +0000
commit939c8ed82e8418cb1f1531f66df268ea15d0dd56 (patch)
tree98f02c04b30831fbb6211548c051b6b1837a6041
downloadaur-939c8ed82e8418cb1f1531f66df268ea15d0dd56.tar.gz
Initial package creation.
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD37
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4724cbb288a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gbcc-git
+ pkgdesc = A Game Boy Color emulator written in C
+ pkgver = r174.0b4b105
+ pkgrel = 1
+ url = https://github.com/philj56/GBCC
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = sdl2
+ depends = libpng
+ provides = gbcc
+ conflicts = gbcc
+ source = gbcc-git::git+https://github.com/philj56/GBCC
+ sha512sums = SKIP
+
+pkgname = gbcc-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d6a6231f7c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Philip Jones <philj56@gmail.com>
+pkgname='gbcc-git'
+pkgver=r174.0b4b105
+pkgrel=1
+pkgdesc="A Game Boy Color emulator written in C"
+arch=('x86_64')
+url="https://github.com/philj56/GBCC"
+license=('GPL')
+groups=()
+depends=('sdl2' 'libpng')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=("${pkgname}::git+${url}")
+noextract=()
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${pkgname}"
+ make clean
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ install -Dm755 gbcc "${pkgdir}/usr/bin/gbcc"
+ install -Dm644 tileset.png "${pkgdir}/usr/share/games/gbcc/tileset.png"
+}