summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPablo Lezaeta Reyes2017-08-20 02:51:37 -0300
committerPablo Lezaeta Reyes2017-08-20 02:51:37 -0300
commit93a875c51b5086f1c2f67117e8510ecab4a431fa (patch)
treea7a7f9d4330142679a1e2b9e360b8f4ff92857ba
downloadaur-93a875c51b5086f1c2f67117e8510ecab4a431fa.tar.gz
Added ubnutu-kylin theming, TODO split it
Signed-off-by: Pablo Lezaeta Reyes <prflr88@gmail.com>
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD47
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ed606e12ea6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ubuntu-kylin-theme
+ pkgdesc = The official theme for Ubuntu Kylin
+ pkgver = 1.7.0
+ pkgrel = 1
+ url = https://launchpad.net/ubuntukylin-theme
+ arch = any
+ license = custom:GPL3
+ depends = gnome-icon-theme
+ depends = hicolor-icon-theme
+ depends = ttf-droid
+ optdepends = plymouth: Contrain a theme for this login splash screen
+ optdepends = grub: Contain a theme for this bootloader manager
+ optdepends = lightdm-unity-greeter: Contain a theme for this lightdm greeter
+ optdepends = chinese-calendar: Official calendary for Ubuntu Kylin
+ source = https://launchpad.net/ubuntu/+archive/primary/+files/ubuntukylin-theme_1.7.0.tar.xz
+ sha256sums = d1f9087e67b0c39c55b7a63f013472f05d3228eba99db295494d392b4540e876
+
+pkgname = ubuntu-kylin-theme
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f27ed14313bd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src*
+pkg*
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..67c74022a47c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Pablo Lezaeta Reyes <prflr88 arro'a gmail puntocom>
+
+pkgname=ubuntu-kylin-theme
+pkgver=1.7.0
+pkgrel=1
+pkgdesc="The official theme for Ubuntu Kylin"
+arch=('any')
+url="https://launchpad.net/ubuntukylin-theme"
+license=('custom:GPL3')
+depends=('gnome-icon-theme' 'hicolor-icon-theme' 'ttf-droid') # 'ubuntu-mono')
+#makedepends=('')
+optdepends=('plymouth: Contrain a theme for this login splash screen'
+ 'grub: Contain a theme for this bootloader manager'
+ 'lightdm-unity-greeter: Contain a theme for this lightdm greeter'
+ 'chinese-calendar: Official calendary for Ubuntu Kylin')
+source=("https://launchpad.net/ubuntu/+archive/primary/+files/ubuntukylin-theme_$pkgver.tar.xz")
+sha256sums=('d1f9087e67b0c39c55b7a63f013472f05d3228eba99db295494d392b4540e876')
+
+package() {
+ cd "ubuntukylin-theme-${pkgver}"
+
+ mkdir -p "${pkgdir}/usr/share/"
+ cp -rv --no-preserve=ownership kylin-greeter "${pkgdir}/usr/share/"
+ cp -rv --no-preserve=ownership usr/share/fcitx-qimpanel "${pkgdir}/usr/share/"
+ cp -rv --no-preserve=ownership usr/share/plymouth "${pkgdir}/usr/share/"
+
+ mkdir -p "${pkgdir}/usr/share/icons/"
+ cp -rv --no-preserve=ownership ubuntukylin-icon-theme "${pkgdir}/usr/share/icons/"
+ cp -rv --no-preserve=ownership ukui-icon-theme "${pkgdir}/usr/share/icons/"
+
+ mkdir -p "${pkgdir}/usr/share/themes/"
+ cp -rv --no-preserve=ownership ubuntukylin-theme "${pkgdir}/usr/share/themes/"
+ cp -rv --no-preserve=ownership ukui-theme "${pkgdir}/usr/share/themes/"
+
+ mkdir -p "${pkgdir}/usr/share/grub/themes/"
+ cp -rv --no-preserve=ownership ubuntukylin-grub-theme "${pkgdir}/usr/share/grub/themes/"
+
+ mkdir -p "${pkgdir}/usr/share/glib-2.0/schemas/"
+ cp -rv --no-preserve=ownership debian/25_ubuntukylin-theme.gschema.override "${pkgdir}/usr/share/glib-2.0/schemas/"
+
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ cp -rv --no-preserve=ownership debian/copyright "${pkgdir}/usr/share/licenses/${pkgname}/"
+
+ mkdir -p "${pkgdir}/usr/share/unity-greeter/"
+ cp -rv --no-preserve=ownership ubuntukylin-unity-greeter/ubuntukylin-logo.png "${pkgdir}/usr/share/unity-greeter/"
+}
+