summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-06-07 12:40:54 +0800
committerUniversebenzene2023-06-07 12:40:54 +0800
commit93c146f92595d89eb397b473b8668a1f7e294cd0 (patch)
treeb28231fb3101de85bb9e022ca64d5c1e95b2114e
parent568e3dc4beb49a7475234092133338a191023c69 (diff)
downloadaur-93c146f92595d89eb397b473b8668a1f7e294cd0.tar.gz
Update to version 1.9.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 21 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36851e882069..7c4f8b374cbc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,28 @@
pkgbase = python-sphinx-astropy
pkgdesc = Sphinx extensions and configuration specific to the Astropy project
- pkgver = 1.8.0
- pkgrel = 2
+ pkgver = 1.9.0
+ pkgrel = 1
url = https://github.com/astropy/sphinx-astropy
arch = any
license = BSD
checkdepends = python-pytest-doctestplus
checkdepends = python-astropy-sphinx-theme
+ checkdepends = python-matplotlib
checkdepends = python-numpydoc
checkdepends = python-sphinxcontrib-jquery
checkdepends = python-sphinx-automodapi
+ checkdepends = python-pydata-sphinx-theme
+ checkdepends = python-sphinx-copybutton
makedepends = python-setuptools-scm
makedepends = python-wheel
makedepends = python-build
makedepends = python-installer
- source = https://files.pythonhosted.org/packages/source/s/sphinx-astropy/sphinx-astropy-1.8.0.tar.gz
- md5sums = 1080a54c73c327fe6511764110b09508
+ source = https://files.pythonhosted.org/packages/source/s/sphinx-astropy/sphinx-astropy-1.9.0.tar.gz
+ md5sums = 1f7bf94bda42a5b51f196c8efa5f66ea
pkgname = python-sphinx-astropy
depends = python-packaging
- depends = python-sphinx>=1.7
+ depends = python-sphinx>=3.0.0
depends = python-astropy-sphinx-theme
depends = python-sphinx-automodapi
depends = python-sphinx-gallery
@@ -27,3 +30,5 @@ pkgname = python-sphinx-astropy
depends = python-sphinxcontrib-jquery
depends = python-pillow
depends = python-pytest-doctestplus>=0.11
+ optdepends = python-pydata-sphinx-theme: To use the new pydata-sphinx-theme with sphinx_astropy.conf.v2
+ optdepends = python-sphinx-copybutton: To use the new pydata-sphinx-theme with sphinx_astropy.conf.v2
diff --git a/PKGBUILD b/PKGBUILD
index 6b5be7f49575..052c1b9a43cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-sphinx-astropy
_pyname=${pkgname#python-}
-pkgver=1.8.0
-pkgrel=2
+pkgver=1.9.0
+pkgrel=1
pkgdesc="Sphinx extensions and configuration specific to the Astropy project"
arch=('any')
url="https://github.com/astropy/sphinx-astropy"
@@ -13,12 +13,14 @@ makedepends=('python-setuptools-scm'
'python-installer')
checkdepends=('python-pytest-doctestplus'
'python-astropy-sphinx-theme'
+ 'python-matplotlib'
'python-numpydoc'
'python-sphinxcontrib-jquery'
'python-sphinx-automodapi'
- )
+ 'python-pydata-sphinx-theme'
+ 'python-sphinx-copybutton')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('1080a54c73c327fe6511764110b09508')
+md5sums=('1f7bf94bda42a5b51f196c8efa5f66ea')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -30,13 +32,13 @@ check() {
cd ${srcdir}/${_pyname}-${pkgver}
# skip tests that cost times through internet
- pytest -vv --color=yes \
- --deselect=sphinx_astropy/tests/test_conf.py::test_conf #|| warning "Tests failed" # -vv --color=yes
+ pytest || warning "Tests failed" #\
+# --deselect=sphinx_astropy/tests/test_conf.py::test_conf #|| warning "Tests failed" # -vv --color=yes
}
package() {
depends=('python-packaging'
- 'python-sphinx>=1.7'
+ 'python-sphinx>=3.0.0'
'python-astropy-sphinx-theme'
'python-sphinx-automodapi'
'python-sphinx-gallery'
@@ -44,6 +46,8 @@ package() {
'python-sphinxcontrib-jquery'
'python-pillow'
'python-pytest-doctestplus>=0.11')
+ optdepends=('python-pydata-sphinx-theme: To use the new pydata-sphinx-theme with sphinx_astropy.conf.v2'
+ 'python-sphinx-copybutton: To use the new pydata-sphinx-theme with sphinx_astropy.conf.v2')
cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 LICENSE.rst -t "${pkgdir}/usr/share/licenses/${pkgname}"