summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12019-12-30 23:58:31 +0800
committerChocobo12019-12-31 00:02:46 +0800
commit93d53740c1e26fb16957ee5ccc961899a0818b1f (patch)
tree84ef88e382465ff50f8c2e879740156644a45a19
parentc24be9f1bf651f21aa91eefce6933e6e50e1a808 (diff)
downloadaur-93d53740c1e26fb16957ee5ccc961899a0818b1f.tar.gz
upgpkg: libarchive-git 3.4.1.r1.gded60625-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD51
2 files changed, 39 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8be0307de576..3937f4d7267e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,28 @@
-# Generated by mksrcinfo v8
-# Mon Dec 26 14:35:59 UTC 2016
pkgbase = libarchive-git
- pkgdesc = library that can create and read several streaming archive formats - git version
- pkgver = v3.1.2.r1001.8c0c4fd7
+ pkgdesc = Multi-format archive and compression library
+ pkgver = 3.4.1.r1.gded60625
pkgrel = 1
- url = http://libarchive.org/
+ url = https://libarchive.org/
arch = i686
arch = x86_64
license = BSD
+ license = custom
makedepends = git
+ depends = glibc
depends = acl
depends = attr
depends = bzip2
depends = expat
depends = lz4
- depends = lzo
depends = openssl
depends = xz
depends = zlib
- provides = libarchive=v3.1.2.r1001.8c0c4fd7
+ depends = zstd
+ provides = libarchive
conflicts = libarchive
+ options = staticlibs
source = git+https://github.com/libarchive/libarchive.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = libarchive-git
diff --git a/PKGBUILD b/PKGBUILD
index 8368459bf022..c921173c5125 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,48 @@
-# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+# Previous maintainer: Jakob Gahde <j5lx@fmail.co.uk>
-_pkgname=libarchive
-pkgname=${_pkgname}-git
-pkgver=v3.1.2.r1001.8c0c4fd7
+pkgname=libarchive-git
+pkgver=3.4.1.r1.gded60625
pkgrel=1
-pkgdesc="library that can create and read several streaming archive formats - git version"
+pkgdesc="Multi-format archive and compression library"
arch=('i686' 'x86_64')
-url="http://libarchive.org/"
-license=('BSD')
-depends=('acl' 'attr' 'bzip2' 'expat' 'lz4' 'lzo' 'openssl' 'xz' 'zlib')
+url="https://libarchive.org/"
+license=('BSD' 'custom')
+depends=('glibc' 'acl' 'attr' 'bzip2' 'expat' 'lz4' 'openssl' 'xz' 'zlib' 'zstd')
makedepends=('git')
-provides=("${_pkgname}=${pkgver}")
-conflicts=("${_pkgname}")
-source=("git+https://github.com/libarchive/${_pkgname}.git")
-md5sums=('SKIP')
+provides=('libarchive')
+conflicts=('libarchive')
+options=('staticlibs')
+source=("git+https://github.com/libarchive/libarchive.git")
+sha256sums=('SKIP')
+
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd "libarchive"
- printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${_pkgname}"
+ cd "libarchive"
build/autogen.sh
- ./configure --prefix=/usr \
- --without-xml2 \
- --without-nettle
+ ./configure \
+ --prefix="/usr" \
+ --without-xml2 \
+ --without-nettle \
make
}
+check() {
+ cd "libarchive"
+
+ make check
+}
+
package() {
- cd "${srcdir}/${_pkgname}"
+ cd "libarchive"
- make install DESTDIR="${pkgdir}"
- install -Dm644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING" -t "$pkgdir/usr/share/licenses/libarchive"
}