summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraeme Gott2023-01-10 13:36:32 -0500
committerGraeme Gott2023-01-10 13:36:32 -0500
commit93ea76823eb43fcc9d3060b73d64a5993be914d7 (patch)
tree801ab4be384d083761a9d43b0a0b1409f4ebf1a3
parent2e66ca0a9f457ba93135f13978c75d8701b1ede2 (diff)
downloadaur-93ea76823eb43fcc9d3060b73d64a5993be914d7.tar.gz
Update to 1.3.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5f1be848d34..a9d67594baae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cutemaze
pkgdesc = Top-down maze game
- pkgver = 1.3.1
+ pkgver = 1.3.2
pkgrel = 1
url = https://gottcode.org/cutemaze/
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = cutemaze
makedepends = qt6-tools
depends = qt6-base
depends = qt6-svg
- source = https://gottcode.org/cutemaze/cutemaze-1.3.1-src.tar.bz2
- sha256sums = 6944931cd39e9ef202c11483b7b2b7409a068c52fa5fd4419ff938b1158c72ab
+ source = https://gottcode.org/cutemaze/cutemaze-1.3.2.tar.bz2
+ sha256sums = 8630e5635f0ef950c947af2fc2b219c2c4006b8d3153e5776c2000e061472444
pkgname = cutemaze
diff --git a/PKGBUILD b/PKGBUILD
index bb929a49cbeb..86281243a6b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: Graeme Gott <graeme@gottcode.org>
pkgname=cutemaze
-pkgver=1.3.1
+pkgver=1.3.2
pkgrel=1
pkgdesc='Top-down maze game'
arch=('x86_64')
-url="https://gottcode.org/$pkgname/"
+url="https://gottcode.org/${pkgname}/"
license=('GPL3')
depends=('qt6-base' 'qt6-svg')
makedepends=('cmake' 'qt6-tools')
-source=("https://gottcode.org/$pkgname/$pkgname-$pkgver-src.tar.bz2")
-sha256sums=('6944931cd39e9ef202c11483b7b2b7409a068c52fa5fd4419ff938b1158c72ab')
+source=("https://gottcode.org/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
+sha256sums=('8630e5635f0ef950c947af2fc2b219c2c4006b8d3153e5776c2000e061472444')
build() {
- cmake -B build -S $pkgbase-$pkgver \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr
+ cmake -B build -S "${pkgname}-${pkgver}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
cmake --build build
}