summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2015-06-15 23:19:32 +0300
committerDet2015-06-15 23:19:32 +0300
commit941a7804e3eb7f03b6bcc70e63522ea5f9ea8903 (patch)
treeff7f5d0369e99e05b667ef319cb7604413a43c40
downloadaur-941a7804e3eb7f03b6bcc70e63522ea5f9ea8903.tar.gz
Create: vuze-dev 5.6.1.3_B02-1
-rw-r--r--.SRCINFO41
-rw-r--r--PKGBUILD129
-rw-r--r--blue_128.pngbin0 -> 4934 bytes
-rw-r--r--blue_16.pngbin0 -> 2280 bytes
-rw-r--r--blue_32.pngbin0 -> 1198 bytes
-rw-r--r--blue_64.pngbin0 -> 2280 bytes
-rw-r--r--gray_128.pngbin0 -> 10953 bytes
-rw-r--r--gray_16.pngbin0 -> 4911 bytes
-rw-r--r--gray_32.pngbin0 -> 2028 bytes
-rw-r--r--gray_64.pngbin0 -> 4911 bytes
-rw-r--r--versions.json20
-rw-r--r--vuze-dev.install36
12 files changed, 226 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5002b10c05db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = vuze-dev
+ pkgdesc = An open source Java-based BitTorrent client (previously called 'Azureus') - Development Build
+ pkgver = 5.6.1.3_B02
+ pkgrel = 1
+ url = http://dev.vuze.com/
+ install = vuze-dev.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = desktop-file-utils
+ depends = gconf
+ depends = java-runtime
+ optdepends = vuze-plugin-countrylocator: Country flags for the "Peers" tab
+ optdepends = vuze-plugin-mldht: The alternative Distributed Hash Table implementation (DHT) used by µTorrent
+ optdepends = xulrunner192: Needed for the channels GUI
+ provides = vuze
+ noextract = Azureus5613-B02.jar
+ options = !strip
+ source = http://downloads.sourceforge.net/project/azureus/vuze/Vuze_5612/Vuze_5612_linux.tar.bz2
+ source = http://cf1.vuze.com/torrent/files/Azureus5613-B02.jar
+ source = blue_16.png
+ source = blue_32.png
+ source = blue_64.png
+ source = blue_128.png
+ source = gray_16.png
+ source = gray_32.png
+ source = gray_64.png
+ source = gray_128.png
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = 5eba696cfcc430504706f476e13b2ade
+ md5sums = a4cae0c46a6ac56322753f96f52b8f74
+ md5sums = 5eba696cfcc430504706f476e13b2ade
+ md5sums = 74fd7cf4d05e5c2111ec2dbf62b3c9d8
+ md5sums = 4374a188968bf9f09cab090ca7d33ce4
+ md5sums = 484182b170741132ffe2d78c6feaf230
+ md5sums = 4374a188968bf9f09cab090ca7d33ce4
+ md5sums = db19086ba7bd8eefee05538f4c65aa68
+
+pkgname = vuze-dev
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c706ac08d42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,129 @@
+# Maintainer: Det <nimetonmaili g-mail>
+
+# Choose, which icons to use for menus and system tray ("blue", "gray" or "default").
+_icon="default"
+pkgname=vuze-dev
+pkgver=5.6.1.3_B02
+pkgrel=1
+pkgdesc="An open source Java-based BitTorrent client (previously called 'Azureus') - Development Build"
+arch=('i686' 'x86_64')
+url="http://dev.vuze.com/"
+license=('GPL')
+depends=('desktop-file-utils' 'gconf' 'java-runtime')
+optdepends=('vuze-plugin-countrylocator: Country flags for the "Peers" tab'
+ 'vuze-plugin-mldht: The alternative Distributed Hash Table implementation (DHT) used by µTorrent'
+ 'xulrunner192: Needed for the channels GUI')
+provides=('vuze')
+options=('!strip')
+install=$pkgname.install
+
+# Fetch info
+_versions=$(curl -sLO http://dev.vuze.com/versions.json)
+
+# Variables
+_main_ver_flat=$(grep -Po 'version": "\K[^"]*' versions.json | tail -1) # 5612
+_dev_ver_flat=$(grep -Pom1 'version": "\K[^"]*' versions.json) # 5613
+_dev_ver=$(echo $_dev_ver_flat | sed -r 's/([0-9])/.\1/g' | cut -c 2-) # 5.6.1.3
+_dev_beta=$(grep -Pom1 'build": "\K[^"]*' versions.json) # 02
+
+source=("http://downloads.sourceforge.net/project/azureus/vuze/Vuze_${_main_ver_flat}/Vuze_${_main_ver_flat}_linux.tar.bz2"
+ "http://cf1.vuze.com/torrent/files/Azureus${_dev_ver_flat}-B${_dev_beta}.jar"
+ {blue,gray}_{16,32,64,128}.png)
+noextract=("Azureus${_dev_ver_flat}-B${_dev_beta}.jar")
+md5sums=('SKIP'
+ 'SKIP'
+ '5eba696cfcc430504706f476e13b2ade'
+ 'a4cae0c46a6ac56322753f96f52b8f74'
+ '5eba696cfcc430504706f476e13b2ade'
+ '74fd7cf4d05e5c2111ec2dbf62b3c9d8'
+ '4374a188968bf9f09cab090ca7d33ce4'
+ '484182b170741132ffe2d78c6feaf230'
+ '4374a188968bf9f09cab090ca7d33ce4'
+ 'db19086ba7bd8eefee05538f4c65aa68')
+
+pkgver() {
+ echo ${_dev_ver}_B${_dev_beta}
+}
+
+package() {
+ cd vuze
+
+ msg2 "Creating directory structure..."
+ install -d "$pkgdir"/opt/vuze-dev/
+ install -d "$pkgdir"/usr/bin/
+ install -d "$pkgdir"/usr/share/applications/
+ install -d "$pkgdir"/usr/share/gconf/schemas/
+ install -d "$pkgdir"/usr/share/licenses/vuze-dev/
+ install -d "$pkgdir"/usr/share/pixmaps/
+
+ msg2 "Moving stuff in place..."
+ # Launcher
+ mv vuze "$pkgdir"/usr/bin/vuze-dev
+
+ # swt.jar
+ case "$CARCH" in
+ i686) mv swt/swt32.jar "$pkgdir"/opt/vuze-dev/swt.jar ;;
+ x86_64) mv swt/swt64.jar "$pkgdir"/opt/vuze-dev/swt.jar ;;
+ esac
+
+ # Icon, desktop and schemas
+ mv vuze.png "$pkgdir"/usr/share/pixmaps/vuze-dev.png
+ mv vuze.desktop "$pkgdir"/usr/share/applications/vuze-dev.desktop
+ mv vuze.schemas "$pkgdir"/usr/share/gconf/schemas/vuze-dev.schemas
+
+ # Licenses
+ mv GPL.txt "$pkgdir"/usr/share/licenses/vuze-dev/
+ mv GPLv3.txt "$pkgdir"/usr/share/licenses/vuze-dev/
+ mv LICENSES.txt "$pkgdir"/usr/share/licenses/vuze-dev/
+ mv TOS.txt "$pkgdir"/usr/share/licenses/vuze-dev/
+
+ # Remove redundancies
+ rm -r swt/
+ rm azureus
+ rm installer.log
+ rm README.txt
+
+ # Move main stuff
+ mv * "$pkgdir"/opt/vuze-dev/
+
+ msg2 "Tweaking paths"
+ # Launcher
+ sed 's|#PROGRAM_DIR=.*|PROGRAM_DIR="/opt/vuze-dev"|' \
+ -i "$pkgdir"/usr/bin/vuze-dev
+
+ # Desktop
+ sed -r -e 's|Name=Vuze|Name=Vuze Development Build|' \
+ -e 's|Exec=vuze %f|Exec=vuze-dev %U|' \
+ -e 's|Icon=vuze.png|Icon=vuze-dev.png|' \
+ -e 's|(x-bittorrent)|\1;x-scheme-handler/magnet;|' \
+ -i "$pkgdir"/usr/share/applications/vuze-dev.desktop
+
+ msg2 "Updating to Development Build..."
+ install -m644 "$srcdir"/Azureus${_dev_ver_flat}-B${_dev_beta}.jar -C "$pkgdir"/opt/vuze-dev/Azureus2.jar
+
+ # Different icons for menus and systray
+ if [[ $_icon = blue ]] || [[ $_icon = gray ]]; then
+ msg2 "Using alternative $_icon icons..."
+
+ # Menus
+ cd "$srcdir"
+ install -m644 ${_icon}_128.png "$pkgdir"/usr/share/pixmaps/vuze-dev.png
+
+ ## Systray
+ # Extract Azureus${_dev_ver_flat}-B${_dev_beta}.jar
+ install -d tmp/
+ bsdtar -xf Azureus${_dev_ver_flat}-B${_dev_beta}.jar -C tmp/
+
+ # Place icons
+ for i in 16 32 64 128; do
+ install -m644 ${_icon}_${i}.png tmp/org/gudy/azureus2/ui/icons/a${i}.png
+ done
+
+ # Recreate Azureus2.jar
+ cd tmp
+ jar cf Azureus2.jar ./*/
+
+ # Install
+ install -m644 Azureus2.jar "$pkgdir"/opt/vuze-dev/
+ fi
+}
diff --git a/blue_128.png b/blue_128.png
new file mode 100644
index 000000000000..fd3623af408d
--- /dev/null
+++ b/blue_128.png
Binary files differ
diff --git a/blue_16.png b/blue_16.png
new file mode 100644
index 000000000000..d3ff6eeae80d
--- /dev/null
+++ b/blue_16.png
Binary files differ
diff --git a/blue_32.png b/blue_32.png
new file mode 100644
index 000000000000..e58413e0f7c7
--- /dev/null
+++ b/blue_32.png
Binary files differ
diff --git a/blue_64.png b/blue_64.png
new file mode 100644
index 000000000000..d3ff6eeae80d
--- /dev/null
+++ b/blue_64.png
Binary files differ
diff --git a/gray_128.png b/gray_128.png
new file mode 100644
index 000000000000..5dc5ddddbf6c
--- /dev/null
+++ b/gray_128.png
Binary files differ
diff --git a/gray_16.png b/gray_16.png
new file mode 100644
index 000000000000..215c4062ab50
--- /dev/null
+++ b/gray_16.png
Binary files differ
diff --git a/gray_32.png b/gray_32.png
new file mode 100644
index 000000000000..86332eb71dd7
--- /dev/null
+++ b/gray_32.png
Binary files differ
diff --git a/gray_64.png b/gray_64.png
new file mode 100644
index 000000000000..215c4062ab50
--- /dev/null
+++ b/gray_64.png
Binary files differ
diff --git a/versions.json b/versions.json
new file mode 100644
index 000000000000..0317dcdfc8c8
--- /dev/null
+++ b/versions.json
@@ -0,0 +1,20 @@
+{
+ "versions": {
+ "client-dev": {
+ "version": "5613",
+ "build": "02",
+ "timestamp": "12 Jun 2015 11:21:08 PM",
+ "name": "Vuze_5613-02",
+ "jar_url": "http://cf1.vuze.com/torrent/files/Azureus5613-B02.jar",
+ "torrent_url": "http://cf1.vuze.com/torrent/torrents/Azureus5613-B02.jar.torrent"
+ },
+ "client-release": {
+ "version": "5612",
+ "build": "",
+ "timestamp": "08 Jun 2015 01:01:01 AM",
+ "name": "Vuze_5612",
+ "jar_url": "http://downloads.sourceforge.net/project/azureus/vuze/Vuze_5612/Vuze_5612.jar?use_mirror=ovh",
+ "torrent_url": "http://downloads.sourceforge.net/project/azureus/vuze/Vuze_5612/Vuze_5612.jar.torrent?use_mirror=ovh"
+ }
+ }
+}
diff --git a/vuze-dev.install b/vuze-dev.install
new file mode 100644
index 000000000000..2628591887a6
--- /dev/null
+++ b/vuze-dev.install
@@ -0,0 +1,36 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}::${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}${yellow}::${bold} $1${all_off}\n"
+}
+
+pkgname=vuze-dev
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ msg_blue "Installing GConf Schemas..."
+ gconfpkg --install "$pkgname"
+
+ msg_blue "Updating desktop MIME database..."
+ update-desktop-database -q
+
+ note "The launcher is called: '$pkgname'"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ msg_blue "Uninstalling GConf Schemas..."
+ gconfpkg --uninstall "$pkgname"
+
+ msg_blue "Updating desktop MIME database..."
+ update-desktop-database -q
+}