summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2019-05-06 21:01:16 -0400
committeracxz2019-05-06 21:01:16 -0400
commit94249c65a4200619915554d4667a763ef5a134b8 (patch)
treed7c53dfa691850e623b1e44dd4b2c1617d276589
downloadaur-94249c65a4200619915554d4667a763ef5a134b8.tar.gz
Initial commit of the complx package based on releases
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD35
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ccb34a90fba7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = complx
+ pkgdesc = Complx: LC-3 Simulator used in GT:CS2110
+ pkgver = 4.18.0
+ pkgrel = 1
+ url = https://www.github.com/TricksterGuy/complx
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = gcc
+ depends = wxgtk
+ depends = boost
+ depends = glib2
+ depends = castxml
+ depends = pygccxml
+ depends = py++
+ source = https://github.com/TricksterGuy/complx/archive/4.18.0.tar.gz
+ md5sums = 6eced6c359145ba69e8508ce33d1254b
+
+pkgname = complx
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f8323ad26ab4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+# Exclude all files that are not relevant
+/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f161284d77a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+pkgname=complx
+pkgver=4.18.0
+pkgrel=1
+pkgdesc="Complx: LC-3 Simulator used in GT:CS2110"
+arch=('i686' 'x86_64')
+url="https://www.github.com/TricksterGuy/complx"
+license=('GPL')
+depends=('gcc' 'wxgtk' 'boost' 'glib2' 'castxml' 'pygccxml' 'py++')
+makedepends=('cmake')
+source=(https://github.com/TricksterGuy/${pkgname}/archive/${pkgver}.tar.gz)
+md5sums=('6eced6c359145ba69e8508ce33d1254b')
+
+build() {
+
+ msg "Starting Cmake"
+
+ # Create a build directory
+ mkdir -p "${srcdir}/${pkgname}-${pkgver}/build"
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ "${srcdir}/${pkgname}-${pkgver}"
+
+ msg "Building the project"
+ make -j4
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+
+ msg "Installing files"
+ make DESTDIR="${pkgdir}/" install
+}