aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelinae982020-10-16 18:53:31 +0800
committerfelinae982020-10-16 18:56:54 +0800
commit9432a0807d219c01b01b575c0c9028f92c7286bd (patch)
tree3c8e8ce4e513a5f576631ebe325b805fb7c68b32
parent750481d55d92f182d7fb7d562629c819c97db23a (diff)
downloadaur-9432a0807d219c01b01b575c0c9028f92c7286bd.tar.gz
fix quit when update mmdb fail
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rwxr-xr-xclashup4
3 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9509739811e9..361296b08c17 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = clashup
pkgdesc = auto update clash's config file
- pkgver = 0.2.4
+ pkgver = 0.2.5
pkgrel = 2
url = https://github.com/felinae98/clashup
arch = any
@@ -10,7 +10,7 @@ pkgbase = clashup
depends = python-requests
source = clashup
source = clashup.conf
- md5sums = 5e36f15996e69f68037964573b20dd64
+ md5sums = 01b044273790887a37d8052e99cbb930
md5sums = 177338346005e11d33e27edc1f8ab780
pkgname = clashup
diff --git a/PKGBUILD b/PKGBUILD
index 3fba1054ed5f..517bd230f443 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Tang Yuming <felinae225@qq.com>
pkgname=clashup
-pkgver=0.2.4
+pkgver=0.2.5
pkgrel=2
pkgdesc="auto update clash's config file"
license=('GPL')
@@ -14,5 +14,5 @@ package() {
install -Dm755 clashup ${pkgdir}/usr/bin/clashup
install -Dm644 clashup.conf ${pkgdir}/etc/systemd/user/clash.service.d/clashup.conf
}
-md5sums=('5e36f15996e69f68037964573b20dd64'
+md5sums=('01b044273790887a37d8052e99cbb930'
'177338346005e11d33e27edc1f8ab780')
diff --git a/clashup b/clashup
index d85002e7cb2d..1953ef07d152 100755
--- a/clashup
+++ b/clashup
@@ -112,9 +112,9 @@ class ClashUp:
f.write(resp.content)
with open(self.mmdb_version_file, 'w') as f:
f.write(current_version)
- logging.info('update mmdb')
+ logging.info('Update mmdb')
except requests.exceptions.RequestException:
- logging.warning('update mmdb failed')
+ logging.warning('Update mmdb failed')
def update_time_cache(self):
if not os.path.isfile(self.cache_file_path):