summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-09 12:08:52 +0200
committerMaxime Gauduin2015-06-09 12:08:52 +0200
commit944e6ef6c2467c2974fc6e501556c98b6e7bd37e (patch)
tree76c4f4b6864ac354ba4e88e0311ab8308e3c339d
downloadaur-944e6ef6c2467c2974fc6e501556c98b6e7bd37e.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--MKPKG6
-rw-r--r--PKGBUILD52
-rw-r--r--wingpanel.install14
4 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc7c167b5207
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = wingpanel-bzr
+ pkgdesc = The Pantheon Panel
+ pkgver = r218
+ pkgrel = 1
+ url = https://launchpad.net/wingpanel
+ install = wingpanel.install
+ arch = i686
+ arch = x86_64
+ groups = pantheon-unstable
+ license = GPL3
+ makedepends = bzr
+ makedepends = cmake
+ makedepends = vala
+ depends = granite-bzr
+ depends = ido
+ depends = libindicator-gtk3
+ depends = libwnck3
+ optdepends = indicator-datetime: Display date and time
+ optdepends = indicator-pantheon-session-bzr: Pantheon session indicator
+ optdepends = indicator-power: Battery idicator
+ provides = wingpanel
+ conflicts = wingpanel
+ source = bzr+lp:wingpanel
+ sha256sums = SKIP
+
+pkgname = wingpanel-bzr
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..bb0d812acc2f
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,6 @@
+pkgname=('wingpanel-bzr')
+builddeps=('granite-bzr' 'ido' 'libindicator-gtk3')
+
+check_bzr $packagedir/$pkgname/${pkgname%-*}
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..89030a1cfdb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Ner0 <darkelfdarkelf666@yahoo.co.uk>
+# Contributor: flamelab <panosfilip@gmail.com>
+
+pkgname=wingpanel-bzr
+pkgver=r218
+pkgrel=1
+pkgdesc='The Pantheon Panel'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/wingpanel'
+license=('GPL3')
+groups=('pantheon-unstable')
+depends=('granite-bzr' 'ido' 'libindicator-gtk3' 'libwnck3')
+optdepends=('indicator-datetime: Display date and time'
+ 'indicator-pantheon-session-bzr: Pantheon session indicator'
+ 'indicator-power: Battery idicator')
+makedepends=('bzr' 'cmake' 'vala')
+provides=('wingpanel')
+conflicts=('wingpanel')
+install='wingpanel.install'
+source=('bzr+lp:wingpanel')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd wingpanel
+
+ echo "r$(bzr revno)"
+}
+
+build() {
+ cd wingpanel
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DGSETTINGS_COMPILE='FALSE' \
+ -DNO_INDICATOR_NG='TRUE' \
+ -DOLD_LIB_IDO='TRUE'
+ make
+}
+
+package() {
+ cd wingpanel/build
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/wingpanel.install b/wingpanel.install
new file mode 100644
index 000000000000..0635cceb4eac
--- /dev/null
+++ b/wingpanel.install
@@ -0,0 +1,14 @@
+post_install() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim: ts=2 sw=2 et: