summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Lybin2020-05-10 20:59:32 +0700
committerLev Lybin2020-05-10 20:59:32 +0700
commit9450f69c78c6e3a9dec1f5fb0648bac03dd9505c (patch)
tree84e4f007744f3ed31068baf2836894821b7597bf
parentf337a70327d9348d7ad31bbbe7b715b3923ac6f2 (diff)
downloadaur-9450f69c78c6e3a9dec1f5fb0648bac03dd9505c.tar.gz
upgpkg: 2.5.0-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--burstcoin-wallet.install15
-rw-r--r--burstcoin-wallet.service2
4 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e71d749bf81..6c10c5b4bdf7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = burstcoin-wallet
pkgdesc = The world's first HDD-mined cryptocurrency using an energy efficient and fair Proof-of-Capacity (PoC) consensus algorithm
- pkgver = 2.4.2
- pkgrel = 2
+ pkgver = 2.5.0
+ pkgrel = 1
url = https://github.com/burst-apps-team/burstcoin
install = burstcoin-wallet.install
arch = x86_64
@@ -13,11 +13,11 @@ pkgbase = burstcoin-wallet
options = !emptydirs
backup = opt/burstcoin-wallet/conf/logging-default.properties
backup = opt/burstcoin-wallet/conf/brs-default.properties
- source = https://github.com/burst-apps-team/burstcoin/releases/download/v2.4.2/burstcoin-2.4.2.zip
+ source = https://github.com/burst-apps-team/burstcoin/releases/download/v2.5.0/burstcoin-2.5.0.zip
source = burstcoin-wallet.service
source = burstcoin-wallet.desktop
- sha256sums = a03cb6491b4fa870b7d3498f9449df822d5612ab167576b4408c5ba0bbcf1afc
- sha256sums = ffb9c5431f65485b2c08b4ca6c2b68b3c2001961b22ed4a66c528ed26bcb2dae
+ sha256sums = e480c09094df6fc0f56c85aa947e952fae3321e1b201b61cc77750d1a5f8bc84
+ sha256sums = c58fb9b5d7aea20f64ee5a15b5999dde626fd6d96d5771a0ca32879b6e9e7bd8
sha256sums = 648f64707713ec4dc6dbcb000d85a0bae43a2960667c029ad220155221718039
pkgname = burstcoin-wallet
diff --git a/PKGBUILD b/PKGBUILD
index 28bd4eea45cb..1f265e49af28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Lev Lybin <lev.lybin@gmail.com>
pkgname=burstcoin-wallet
-pkgver=2.4.2
-pkgrel=2
+pkgver=2.5.0
+pkgrel=1
pkgdesc="The world's first HDD-mined cryptocurrency using an energy efficient and fair Proof-of-Capacity (PoC) consensus algorithm"
arch=(x86_64)
url='https://github.com/burst-apps-team/burstcoin'
@@ -16,8 +16,8 @@ install=burstcoin-wallet.install
source=(https://github.com/burst-apps-team/burstcoin/releases/download/v${pkgver}/burstcoin-${pkgver}.zip
burstcoin-wallet.service
burstcoin-wallet.desktop)
-sha256sums=('a03cb6491b4fa870b7d3498f9449df822d5612ab167576b4408c5ba0bbcf1afc'
- 'ffb9c5431f65485b2c08b4ca6c2b68b3c2001961b22ed4a66c528ed26bcb2dae'
+sha256sums=('e480c09094df6fc0f56c85aa947e952fae3321e1b201b61cc77750d1a5f8bc84'
+ 'c58fb9b5d7aea20f64ee5a15b5999dde626fd6d96d5771a0ca32879b6e9e7bd8'
'648f64707713ec4dc6dbcb000d85a0bae43a2960667c029ad220155221718039')
package() {
@@ -25,8 +25,8 @@ package() {
# Lib directory
install -d $pkgdir/opt/$pkgname
- cp -a conf html burst.jar genscoop.cl init-mysql.sql $pkgdir/opt/$pkgname
- install -Dm755 burst.sh -t $pkgdir/opt/$pkgname
+ cp -a conf html burst.jar $pkgdir/opt/$pkgname
+ mkdir $pkgdir/opt/$pkgname/burst_db
# Daemon
install -Dm644 $pkgname.service $pkgdir/usr/lib/systemd/system/$pkgname.service
diff --git a/burstcoin-wallet.install b/burstcoin-wallet.install
index c544dcc5f87f..ea61b17f7f83 100644
--- a/burstcoin-wallet.install
+++ b/burstcoin-wallet.install
@@ -4,18 +4,17 @@ post_install() {
xdg-icon-resource forceupdate --theme hicolor
echo "+-------------------------------------------------------------------------------------+"
- echo "| Config: /opt/burstcoin-wallet/conf/brs-default.properties |"
- echo "| By default, burst wallet uses MySQL |"
+ echo "| Configuration: /opt/burstcoin-wallet/conf/brs-default.properties |"
+ echo "| By default, burst wallet uses H2 DB /opt/burstcoin-wallet/burst_db/burst.h2 |"
+ echo "| |"
+ echo "| If you need make changes, create new file configs: |"
+ echo "| /opt/burstcoin-wallet/conf/brs.properties |"
+ echo "| /opt/burstcoin-wallet/conf/logging.properties |"
+ echo "| It will overwrite default properties configs, and will not touched on upgrades |"
echo "| |"
echo "| If you want to use MySQL: pacman -S mariadb |"
echo "| and configure by instruction: https://github.com/burst-apps-team/burstcoin |"
echo "| |"
- echo "| If you want to use H2 DB, you do not need to install additional, |"
- echo "| change parameters in config, where DB.url is path to file where will storage DB: |"
- echo "| DB.Url=jdbc:h2:/home/USER/burst_db/burst;DB_CLOSE_ON_EXIT=FALSE |"
- echo "| DB.Username= |"
- echo "| DB.Password= |"
- echo "| |"
echo "| Run wallet: sudo systemctl start burstcoin-wallet.service |"
echo "| URL: http://127.0.0.1:8125/index.html |"
echo "+-------------------------------------------------------------------------------------+"
diff --git a/burstcoin-wallet.service b/burstcoin-wallet.service
index f3c914b1c867..685cccc095b9 100644
--- a/burstcoin-wallet.service
+++ b/burstcoin-wallet.service
@@ -5,7 +5,7 @@ After=network.target
[Service]
Type=simple
WorkingDirectory=/opt/burstcoin-wallet
-ExecStart=/opt/burstcoin-wallet/burst.sh
+ExecStart=java -XX:+UnlockExperimentalVMOptions -XX:+UseCGroupMemoryLimitForHeap -cp /opt/burstcoin-wallet/burst.jar:conf brs.Burst
Restart=on-abort
[Install]