summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-12-03 08:56:53 +1300
committercaltlgin2020-12-03 08:56:53 +1300
commit945795bfbc12884a256f14c9277d44220ece2807 (patch)
treecc33647eab8cc4cece10714e571f8284dbd70d59
parent75e7776eff6c4c3ab0debcd0f9c2a7506a545fce (diff)
downloadaur-945795bfbc12884a256f14c9277d44220ece2807.tar.gz
Python 3.9 rebuild
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD8
3 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5092114b46c9..080607be251f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = python-catalogue
pkgdesc = Super lightweight function registries for your library
pkgver = 2.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/explosion/catalogue
arch = any
license = MIT
makedepends = python-setuptools
depends = python
- provides = catalogue
source = https://files.pythonhosted.org/packages/source/c/catalogue/catalogue-2.0.1.tar.gz
sha256sums = 0d01077dbfca7aa53f3ef4adecccce636bce4f82e5b52237703ab2f56478e56e
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index abb13e6db4dd..a3be5bf91927 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
_pkgname='catalogue'
pkgname="python-${_pkgname}"
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
pkgdesc='Super lightweight function registries for your library'
arch=('any')
url='https://github.com/explosion/catalogue'
+_url_pypi='https://pypi.org/project/catalogue'
license=('MIT')
depends=('python')
makedepends=('python-setuptools')
-provides=("${_pkgname}")
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('0d01077dbfca7aa53f3ef4adecccce636bce4f82e5b52237703ab2f56478e56e')
@@ -23,8 +23,8 @@ build() {
package() {
cd "${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md'
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" 'LICENSE'
+ install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim: ts=2 sw=2 et: