summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGitlab CI Runner2020-03-06 14:21:05 +0000
committerGitlab CI Runner2020-03-06 14:21:05 +0000
commit9468b2a25e04640a0923611b92e7f2da155c2926 (patch)
tree01f3c3962633146aa72f65f0cfce8d756ac72809
parentab520924d96d36e3f4129a5fd65f439789578e1b (diff)
downloadaur-9468b2a25e04640a0923611b92e7f2da155c2926.tar.gz
Updated package to commit
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--rapidcheck.changelog18
3 files changed, 23 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 406e2b8c7bb2..c3006c135141 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rapidcheck
pkgdesc = QuickCheck clone for C++ with the goal of being simple to use with as little boilerplate as possible.
- pkgver = r997.4df0260
+ pkgver = r1002.258d907
pkgrel = 1
url = https://github.com/emil-e/rapidcheck
changelog = rapidcheck.changelog
@@ -12,8 +12,8 @@ pkgbase = rapidcheck
arch = aarch64
license = BSD
makedepends = cmake
- provides = rapidcheck=r997.4df0260
- source = rapidcheck::git+https://github.com/emil-e/rapidcheck.git#commit=4df02602aae74ff1711611b64630d3fd8ae40571
+ provides = rapidcheck=r1002.258d907
+ source = rapidcheck::git+https://github.com/emil-e/rapidcheck.git#commit=258d907da00a0855f92c963d8f76eef115531716
md5sums = SKIP
pkgname = rapidcheck
diff --git a/PKGBUILD b/PKGBUILD
index d527eed9ea54..35e134409e1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bart Verhagen <bart at verhagenconsultancy dot be>
pkgname=('rapidcheck')
pkgbase='rapidcheck'
-pkgver=r997.4df0260
+pkgver=r1002.258d907
pkgrel=1
epoch=
pkgdesc="QuickCheck clone for C++ with the goal of being simple to use with as little boilerplate as possible."
@@ -13,14 +13,14 @@ depends=()
makedepends=(cmake)
checkdepends=()
optdepends=()
-provides=('rapidcheck=r997.4df0260')
+provides=('rapidcheck=r1002.258d907')
conflicts=()
replaces=()
backup=()
options=()
install=
changelog=rapidcheck.changelog
-source=("rapidcheck::git+$url.git#commit=4df02602aae74ff1711611b64630d3fd8ae40571")
+source=("rapidcheck::git+$url.git#commit=258d907da00a0855f92c963d8f76eef115531716")
noextract=()
validpgpkeys=()
diff --git a/rapidcheck.changelog b/rapidcheck.changelog
index e1859a670b5a..3ea4047ee9a1 100644
--- a/rapidcheck.changelog
+++ b/rapidcheck.changelog
@@ -2,7 +2,7 @@ Changelog
=========
-r997.4df0260
+r1002.258d907
------------
Fix
@@ -17,6 +17,22 @@ Fix
Other
~~~~~
+- Merge pull request #233 from Cypher1/master. [emil-e]
+
+ Fix type error detected by GCC-9.1.0
+- Don't werror (temporary fix to ensure that builds succeed on GCC-9)
+ [Joshua Pratt]
+- Ignore build output. [Joshua Pratt]
+- Merge pull request #248 from arekfu/cmake-rtti. [emil-e]
+- CMake: use `target_compile_definitions()` for the `RC_USE_RTTI`
+ symbol. [Davide Mancusi]
+
+ The code that prints the type name lives in a header file, and therefore
+ it is separately included by each translation unit using Rapidcheck.
+ This commit make sure that any test suite linking with Rapidcheck will
+ use the same compile definitions. Otherwise, Rapidcheck will just print
+ `"[unknown type]"`, if the test suite has not been compiled with
+ `-DRC_USE_RTTI'`
- Merge pull request #241 from
hanst99/fix/missing_includes_and_signed_unsigned_comparison. [emil-e]