summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Cowdery Lack2023-07-18 11:25:56 +1000
committerOscar Cowdery Lack2023-07-18 11:25:56 +1000
commit949c4100913d343c28bd36e725c3bcfc38d232b5 (patch)
tree4732dc42928de3d4a2e13a990a9f3e168de91de9
parentf0f41828d1f15597f041a66845ea8fda30b6de9c (diff)
downloadaur-949c4100913d343c28bd36e725c3bcfc38d232b5.tar.gz
1.39.8
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 7 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8f13453495e..ad892ab27c4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = omnisharp-roslyn
pkgdesc = OmniSharp server (STDIO) based on Roslyn workspaces
- pkgver = 1.39.7
- pkgrel = 2
+ pkgver = 1.39.8
+ pkgrel = 1
url = https://github.com/OmniSharp/omnisharp-roslyn
arch = x86_64
license = MIT
depends = dotnet-sdk
- source = https://github.com/OmniSharp/omnisharp-roslyn/archive/refs/tags/v1.39.7.tar.gz
- source = https://github.com/OmniSharp/omnisharp-roslyn/commit/87b61078e86230cac3fca6e64d894ee092776a1c.patch
+ source = https://github.com/OmniSharp/omnisharp-roslyn/archive/refs/tags/v1.39.8.tar.gz
sha256sums = 1e5b73e393e62d75e789bae7a19bcdb57548f8966647c533fb8243a42fba0373
- sha256sums = da3730a4022c5c50cd8b3575f13603eac6cfd4b81c2591583c33ca6d29e673b8
pkgname = omnisharp-roslyn
diff --git a/PKGBUILD b/PKGBUILD
index 517a291bb18d..fbde175b9ea9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,19 @@
# Maintainer: oscarcl <oscar.cowderylack@gmail.com>
# Contributor: sixpindin <sixpindin@gmail.com>
pkgname=omnisharp-roslyn
-pkgver=1.39.7
-pkgrel=2
+pkgver=1.39.8
+pkgrel=1
pkgdesc="OmniSharp server (STDIO) based on Roslyn workspaces"
arch=('x86_64')
url="https://github.com/OmniSharp/omnisharp-roslyn"
license=('MIT')
depends=('dotnet-sdk')
-source=(
- "https://github.com/OmniSharp/$pkgname/archive/refs/tags/v$pkgver.tar.gz"
- "https://github.com/OmniSharp/$pkgname/commit/87b61078e86230cac3fca6e64d894ee092776a1c.patch"
-)
-sha256sums=('1e5b73e393e62d75e789bae7a19bcdb57548f8966647c533fb8243a42fba0373'
- 'da3730a4022c5c50cd8b3575f13603eac6cfd4b81c2591583c33ca6d29e673b8')
+source=("https://github.com/OmniSharp/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
+sha256sums=('e0eda0d39dcf62d3e3a6fd169c9453958696684f9826033a896c1caffa44dd38')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
- for f in ../*.patch
- do
- patch --forward --strip=1 --input "$f"
- done
-
# normally the build sets the version from git, we don't have a git repo so
# just override it manually
sed -i "s/0.0.1-local/$pkgver/" scripts/common.cake