summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin Lloyd2015-06-09 17:21:31 -0700
committerGavin Lloyd2015-06-09 17:21:31 -0700
commit94b51039fa61b28bde541389c9a2562055366267 (patch)
tree3710d31bcfd6c31f495eb26c7ef9ae3a4acbde1f
downloadaur-94b51039fa61b28bde541389c9a2562055366267.tar.gz
Init commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
-rw-r--r--otf-vegur.install18
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c523b89cca91
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = otf-vegur
+ pkgdesc = Humanist sans-serif font used for the LibreOffice logo
+ pkgver = 0.701
+ pkgrel = 1
+ url = http://www.dotcolon.net/font/?id=vegur
+ install = otf-vegur.install
+ arch = i686
+ arch = x86_64
+ license = custom:CC0
+ depends = fontconfig
+ depends = xorg-font-utils
+ source = http://www.dotcolon.net/DL/font/vegur.zip
+ md5sums = 230bd8b9e28aeadb1113cdd508b69c2b
+
+pkgname = otf-vegur
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62d1e5c2a68f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
+
+pkgname=otf-vegur
+pkgver=0.701
+pkgrel=1
+pkgdesc='Humanist sans-serif font used for the LibreOffice logo'
+arch=('i686' 'x86_64')
+license=('custom:CC0')
+url='http://www.dotcolon.net/font/?id=vegur'
+depends=('fontconfig' 'xorg-font-utils')
+source=('http://www.dotcolon.net/DL/font/vegur.zip')
+md5sums=('230bd8b9e28aeadb1113cdd508b69c2b')
+install=$pkgname.install
+
+package() {
+ install -d $pkgdir/usr/share/fonts/OTF/
+ install -m644 *.otf $pkgdir/usr/share/fonts/OTF/
+}
diff --git a/otf-vegur.install b/otf-vegur.install
new file mode 100644
index 000000000000..8de353a0501f
--- /dev/null
+++ b/otf-vegur.install
@@ -0,0 +1,18 @@
+post_install() {
+ fc-cache -f > /dev/null
+ mkfontscale /usr/share/fonts/OTF
+ mkfontdir /usr/share/fonts/OTF
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*