summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorReihar2020-07-12 10:51:24 +0200
committerReihar2020-07-12 10:51:24 +0200
commit94bcc310481bad7289a38f4f1688bf433baac3f0 (patch)
treef30611227566e9d249e6733271f528544219c5a5
parent036e13860a600ac617ee2ce324d8b3ff0c388c04 (diff)
downloadaur-94bcc310481bad7289a38f4f1688bf433baac3f0.tar.gz
Update PKGBUILD to reflect upstream project updates better
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD39
2 files changed, 8 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f921ff5ecbe..5773d378f957 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = cataclysm-dda-ncurses
pkgdesc = Cataclysm: Dark Days Ahead is an actively maintained roguelike set in a post-apocalyptic world, forked from the original. (ncurses only)
pkgver = 0.E.2
- pkgrel = 1
+ pkgrel = 3
url = http://www.cataclysmdda.com/
install = cataclysm-dda-ncurses.install
arch = i686
arch = x86_64
license = CCPL:by-sa
makedepends = gettext
+ makedepends = astyle
depends = ncurses
- depends = lua
depends = ncurses
- optdepends = lua51
conflicts = cataclysm-dda
conflicts = cataclysm-dda-git
conflicts = cataclysm-dda-ncurses-bin
diff --git a/PKGBUILD b/PKGBUILD
index 8383ba917bba..c71d7811e966 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,52 +4,30 @@
pkgname=cataclysm-dda-ncurses
pkgver=0.E.2
_pkgver=0.E-2
-pkgrel=1
+pkgrel=3
pkgdesc="Cataclysm: Dark Days Ahead is an actively maintained roguelike set in a post-apocalyptic world, forked from the original. (ncurses only)"
arch=('i686' 'x86_64')
url="http://www.cataclysmdda.com/"
license=('CCPL:by-sa')
-
-depends=('ncurses' 'lua' 'ncurses')
-makedepends=('gettext')
-optdepends=('lua51')
+depends=('ncurses' 'ncurses')
+makedepends=('gettext' 'astyle')
conflicts=('cataclysm-dda' 'cataclysm-dda-git' 'cataclysm-dda-ncurses-bin')
install='cataclysm-dda-ncurses.install'
source=("$pkgname-$_pkgver.tar.gz::https://github.com/CleverRaven/Cataclysm-DDA/archive/${_pkgver}.tar.gz")
sha256sums=('41546e877e2eee79c8492b3ec808ef53a4b9b208d788dac2b1a570ef143426e9')
-prepare() {
- cd "$srcdir/Cataclysm-DDA-${_pkgver}"
-
- #0.C cannot compile without warnings anymore
- sed -i s/-Werror// Makefile
-
- #Ncurses update yay
- sed -i s/ncursesw5-config/ncursesw6-config/ Makefile
-}
-
build() {
cd "$srcdir/Cataclysm-DDA-${_pkgver}"
- make USE_HOME_DIR=1 RELEASE=1 ZLEVELS=1 LUA=1 LOCALIZE=1
+ make PREFIX=/usr RELEASE=1 USE_XDG_DIR=1 ZLEVELS=1 LOCALIZE=1
}
package() {
cd "$srcdir/Cataclysm-DDA-${_pkgver}"
- local instdir=/usr/share/cataclysm-dda
-
- install -dm755 "$pkgdir/${instdir}/"{data,gfx}
- cp -r --no-preserve=ownership data gfx "$pkgdir/${instdir}/"
-
-
- local instdir="/usr/share/cataclysm-dda"
-
- install -dm755 "$pkgdir/${instdir}/"
- install -Dm755 cataclysm cataclysm-launcher "$pkgdir/${instdir}/"
- install -dm755 data "$pkgdir/${instdir}/"
-
+ make DESTDIR="$pkgdir" PREFIX="/usr" RELEASE=1 ZLEVELS=1 LANGUAGES="all" install
+
#The doc goes in /usr/share/doc
install -dm755 "$pkgdir/usr/share/doc/cataclysm-dda"
unlink doc/JSON_LOADING_ORDER.md
@@ -61,9 +39,4 @@ package() {
#Launcher symlinks
install -dm755 "$pkgdir/usr/bin/"
- ln -s "${instdir}/cataclysm-launcher" "$pkgdir/usr/bin/cataclysm"
-
- # Localization
- install -dm755 "$pkgdir/usr/share/locale"
- LOCALE_DIR="$pkgdir/usr/share/locale" lang/compile_mo.sh
}