summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRuben Bekaert2022-12-08 00:55:52 +0100
committerRuben Bekaert2022-12-08 00:55:52 +0100
commit94c74070d9bc40ed6cab2dff0239a113369fcca1 (patch)
treeb84b43e2eb59f4be773dd2e73889e6ccaea4ac3f
parent4ca209164ae86ff55185db4b1acffc00e5d6f5dd (diff)
downloadaur-94c74070d9bc40ed6cab2dff0239a113369fcca1.tar.gz
Updated to 2.3.0
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD80
-rw-r--r--boost-placeholders.patch75
-rw-r--r--no-ansi.patch12
4 files changed, 139 insertions, 77 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7bcbeae0264b..4c3e7e91d297 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,36 @@
pkgbase = gplates
- pkgdesc = Desktop software for the interactive visualisation of plate-tectonics
- pkgver = 2.1.0
- pkgrel = 2
- url = https://www.gplates.org/
+ pkgdesc = GPlates is a plate tectonics program. Manipulate reconstructions of geological and paleogeographic features through geological time. Interactively visualize vector, raster and volume data.
+ pkgver = 2.3.0
+ pkgrel = 1
+ url = https://www.gplates.org
arch = x86_64
- license = GPL
+ license = GPLv2
makedepends = cmake
- makedepends = glu
- makedepends = glew
- makedepends = python2
- makedepends = boost
- makedepends = mesa
- makedepends = cgal
- makedepends = proj
- depends = qt4
- depends = qwt-qt4
+ makedepends = doxygen
+ depends = libgl
+ depends = glu
+ depends = glew
+ depends = qt5-base
+ depends = qwt
+ depends = qt5-svg
+ depends = qt5-xmlpatterns
+ depends = boost
depends = gdal
- source = https://downloads.sourceforge.net/project/gplates/gplates/2.1/gplates-2.1.0-unixsrc.tar.bz2
- source = no-ansi.patch
+ depends = gmp
+ depends = cgal
+ depends = proj
+ depends = zlib
+ depends = arrow
+ depends = graphviz
+ optdepends = python
+ optdepends = python-numpy
+ source = gplates_2.3.0_src.zip::https://www.earthbyte.org/download/8426
+ source = boost-placeholders.patch
source = icon.png
source = gplates.desktop
- md5sums = 770758823ac480e40213a5b284d273fc
- md5sums = 57f9fb5b981456bdc874094d35488763
- md5sums = 938ef5a002905872a633665637a45d77
- md5sums = 1127c6a17abfa7500280fd09ce475a15
+ sha256sums = 7d4be9d524d1fcbb6a81de29bd1d4b13133082db23f0808965c5efe30e9538ab
+ sha256sums = 3f65493ff661f36cdc1cff9f672a529a922783b481bbd4dd9d997701d7e7b6ec
+ sha256sums = 9335fb98b21bc03c1cbec21ca945bded6ac60f66bb14997654b1829c1bd7265b
+ sha256sums = 466488f831b56826be3b642cc7e72f2b34ddd5fa887b53d6a9e779e9e8f9c289
pkgname = gplates
-
diff --git a/PKGBUILD b/PKGBUILD
index e698485b2666..1da93d7ae57f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,48 @@
-# Maintainer: Timmy Yao <timmy.yao@outlook.com.au>
+# Maintainer: Ruben Bekaert <bekaertruben@gmail.com>
+# Contributor: Timmy Yao <timmy.yao@outlook.com.au>
+
pkgname=gplates
-pkgver=2.1.0
-pkgrel=2
-pkgdesc="Desktop software for the interactive visualisation of plate-tectonics"
+
+pkgdesc="GPlates is a plate tectonics program. Manipulate reconstructions of geological and paleogeographic features through geological time. Interactively visualize vector, raster and volume data."
+url="https://www.gplates.org"
+license=(GPLv2)
+
arch=(x86_64)
-url="https://www.gplates.org/"
-license=('GPL')
-depends=(qt4 qwt-qt4 gdal)
-makedepends=(cmake glu glew python2 boost mesa cgal proj)
-source=("https://downloads.sourceforge.net/project/gplates/gplates/2.1/gplates-$pkgver-unixsrc.tar.bz2"
- "no-ansi.patch"
- "icon.png"
- "gplates.desktop")
-md5sums=('770758823ac480e40213a5b284d273fc'
- '57f9fb5b981456bdc874094d35488763'
- '938ef5a002905872a633665637a45d77'
- '1127c6a17abfa7500280fd09ce475a15')
+pkgver=2.3.0
+pkgrel=1
+
+depends=(libgl glu glew qt5-base qwt qt5-svg qt5-xmlpatterns boost gdal gmp cgal proj zlib arrow graphviz)
+optdepends=(python python-numpy)
+makedepends=(cmake doxygen)
+
+source=(
+ "${pkgname}_${pkgver}_src.zip::https://www.earthbyte.org/download/8426"
+ "boost-placeholders.patch"
+ "icon.png"
+ "gplates.desktop"
+)
+sha256sums=(
+ "7d4be9d524d1fcbb6a81de29bd1d4b13133082db23f0808965c5efe30e9538ab"
+ "3f65493ff661f36cdc1cff9f672a529a922783b481bbd4dd9d997701d7e7b6ec"
+ "9335fb98b21bc03c1cbec21ca945bded6ac60f66bb14997654b1829c1bd7265b"
+ "466488f831b56826be3b642cc7e72f2b34ddd5fa887b53d6a9e779e9e8f9c289"
+ )
prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- patch -Np2 -i "$srcdir/no-ansi.patch"
+ cd "{srcdir}/${pkgname}_${pkgver}_src"
+ patch --forward --strip=0 --input="${srcdir}/boost-placeholders.patch"
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
- QTDIR=/usr/lib/qt4 cmake \
- -DQT_QMAKE_EXECUTABLE=/usr/lib/qt4/bin/qmake \
- -DQT_UIC_EXECUTABLE=/usr/lib/qt4/bin/uic \
- -DQT_MOC_EXECUTABLE=/usr/lib/qt4/bin/moc \
- -DQT_HEADERS_DIR=/usr/include/qt4 \
- -DQT_QTCORE_INCLUDE_DIR:PATH=/usr/include/qt4/QtCore \
- -DQT_QTGUI_INCLUDE_DIR:PATH=/usr/include/qt4/QtGui \
- -DQT_QTNETWORK_INCLUDE_DIR:PATH=/usr/include/qt4/QtNetwork \
- -DQT_QTOPENGL_INCLUDE_DIR:PATH=/usr/include/qt4/QtOpenGL \
- -DQT_QTSQL_INCLUDE_DIR:PATH=/usr/include/qt4/QtSql \
- -DQT_QTSVG_INCLUDE_DIR:PATH=/usr/include/qt4/QtSvg \
- -DQT_QTTEST_INCLUDE_DIR:PATH=/usr/include/qt4/QtTest \
- -DQT_QTXMLPATTERNS_INCLUDE_DIR:PATH=/usr/include/qt4/QtXmlPatterns \
- -DQT_QTXML_INCLUDE_DIR:PATH=/usr/include/qt4/QtXml \
- -DQWT_INCLUDE_DIR:PATH=/usr/include/qwt-qt4 \
- -DQWT_LIBRARY:PATH=/usr/lib/libqwt-qt4.so \
- -DCMAKE_INSTALL_PREFIX="/usr/" \
- -DCMAKE_BUILD_TYPE=Release \
- .
- make
+ cd "{srcdir}/${pkgname}_${pkgver}_src"
+ cmake -DCMAKE_INSTALL_PREFIX="/usr/" -DCMAKE_BUILD_TYPE=Release .
+ make
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ cd "{srcdir}/${pkgname}_${pkgver}_src"
+ make DESTDIR="${pkgdir}/" install
- install "${srcdir}/icon.png" -t "${pkgdir}/usr/share/${pkgname}"
- install -Dm644 "${srcdir}/gplates.desktop" -t "${pkgdir}/usr/share/applications"
+ install "${srcdir}/icon.png" -t "${pkgdir}/usr/share/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
}
-
diff --git a/boost-placeholders.patch b/boost-placeholders.patch
new file mode 100644
index 000000000000..a41ebf1bdfb8
--- /dev/null
+++ b/boost-placeholders.patch
@@ -0,0 +1,75 @@
+diff --unified --recursive src/gui/TopologyTools.cc src/gui/TopologyTools.cc
+--- src/gui/TopologyTools.cc 2021-07-05 05:11:47.000000000 +0200
++++ src/gui/TopologyTools.cc 2022-12-07 22:35:20.444054124 +0100
+@@ -3448,7 +3448,7 @@
+ std::find_if(
+ d_visible_boundary_section_seq.begin(),
+ d_visible_boundary_section_seq.end(),
+- boost::bind(&VisibleSection::d_section_info_index, _1) ==
++ boost::bind(&VisibleSection::d_section_info_index, boost::placeholders::_1) ==
+ boost::cref(section_index));
+
+ if (visible_section_iter == d_visible_boundary_section_seq.end())
+@@ -3467,7 +3467,7 @@
+ std::find_if(
+ d_visible_interior_section_seq.begin(),
+ d_visible_interior_section_seq.end(),
+- boost::bind(&VisibleSection::d_section_info_index, _1) ==
++ boost::bind(&VisibleSection::d_section_info_index, boost::placeholders::_1) ==
+ boost::cref(section_index));
+
+ if (visible_section_iter == d_visible_interior_section_seq.end())
+diff --unified --recursive src/presentation/ReconstructionGeometryRenderer.cc src/presentation/ReconstructionGeometryRenderer.cc
+--- src/presentation/ReconstructionGeometryRenderer.cc 2021-07-05 05:11:50.000000000 +0200
++++ src/presentation/ReconstructionGeometryRenderer.cc 2022-12-07 22:36:11.117884262 +0100
+@@ -274,7 +274,7 @@
+ GPlatesPresentation::ReconstructionGeometryRenderer::RenderParamsPopulator::visit_reconstruct_visual_layer_params(
+ const ReconstructVisualLayerParams &params)
+ {
+- d_render_params.show_vgp = boost::bind(&ReconstructVisualLayerParams::show_vgp, &params, _1, _2);
++ d_render_params.show_vgp = boost::bind(&ReconstructVisualLayerParams::show_vgp, &params, boost::placeholders::_1, boost::placeholders::_2);
+ d_render_params.vgp_draw_circular_error = params.get_vgp_draw_circular_error();
+ d_render_params.fill_polygons = params.get_fill_polygons();
+ d_render_params.fill_polylines = params.get_fill_polylines();
+diff --unified --recursive src/presentation/VisualLayerRegistry.cc src/presentation/VisualLayerRegistry.cc
+--- src/presentation/VisualLayerRegistry.cc 2021-07-05 05:11:50.000000000 +0200
++++ src/presentation/VisualLayerRegistry.cc 2022-12-07 22:38:12.950877614 +0100
+@@ -448,7 +448,7 @@
+ &GPlatesQtWidgets::ReconstructScalarCoverageLayerOptionsWidget::create,
+ boost::bind(
+ &ReconstructScalarCoverageVisualLayerParams::create,
+- _1),
++ boost::placeholders::_1),
+ true);
+
+ registry.register_visual_layer_type(
+@@ -498,7 +498,7 @@
+ // NOTE: We pass in ViewState and not the GlobeAndMapWidget, obtained from
+ // ViewportWindow, because ViewportWindow is not yet available (a reference to
+ // it not yet been initialised inside ViewState) so accessing it would crash...
+- _1, boost::ref(view_state)),
++ boost::placeholders::_1, boost::ref(view_state)),
+ true);
+
+ // DERIVED_DATA group.
+@@ -549,7 +549,7 @@
+ &GPlatesQtWidgets::VelocityFieldCalculatorLayerOptionsWidget::create,
+ boost::bind(
+ &VelocityFieldCalculatorVisualLayerParams::create,
+- _1, boost::cref(view_state.get_rendered_geometry_parameters())),
++ boost::placeholders::_1, boost::cref(view_state.get_rendered_geometry_parameters())),
+ true);
+
+ using namespace GPlatesUtils;
+diff --unified --recursive src/qt-widgets/ViewportWindow.cc src/qt-widgets/ViewportWindow.cc
+--- src/qt-widgets/ViewportWindow.cc 2021-08-05 05:44:01.000000000 +0200
++++ src/qt-widgets/ViewportWindow.cc 2022-12-07 22:39:20.487981302 +0100
+@@ -326,7 +326,7 @@
+ *d_geometry_operation_state_ptr,
+ *d_modify_geometry_state,
+ *d_measure_distance_state_ptr,
+- boost::bind(&canvas_tool_status_message, boost::ref(*this), _1),
++ boost::bind(&canvas_tool_status_message, boost::ref(*this), boost::placeholders::_1),
+ get_view_state(),
+ *this);
+
diff --git a/no-ansi.patch b/no-ansi.patch
deleted file mode 100644
index 7bd6964771fd..000000000000
--- a/no-ansi.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff '--color=auto' -ura --color src.orig/gplates-2.1.0/cmake/modules/CompileOptionsCPlusPlus.cmake src/gplates-2.1.0/cmake/modules/CompileOptionsCPlusPlus.cmake
---- src.orig/gplates-2.1.0/cmake/modules/CompileOptionsCPlusPlus.cmake 2019-01-28 01:17:02.994296282 +1100
-+++ src/gplates-2.1.0/cmake/modules/CompileOptionsCPlusPlus.cmake 2019-01-28 01:20:15.254774332 +1100
-@@ -123,7 +123,7 @@
- set(warnings_flags "${warnings_flags} ${warning}")
- endforeach(warning ${warnings_flags_list})
-
-- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -ansi -fno-strict-aliasing")
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fno-strict-aliasing")
-
- # Flags common to all build types.
- if (GPLATES_PUBLIC_RELEASE)