summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Perez de Castro2020-04-14 12:12:28 +0300
committerAdrian Perez de Castro2020-04-14 12:12:28 +0300
commit94ceb09274fa75f2649398e1b5de319514080989 (patch)
tree685bdf2c810167209cfcc6c86446e38379e70a0e
parentbae785c0e75da5a39406544af50fdab790613b98 (diff)
downloadaur-94ceb09274fa75f2649398e1b5de319514080989.tar.gz
Use system re2, capstone, and protobuf libraries
Use system packages re2, capstone, and protobuf, instead of letting CMake anebld the corresponding bundled libraries.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 10240a790309..9fb1ceeacac7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bloaty-git
pkgdesc = A size profiler for binaries
- pkgver = 1.0.r2.gfeaca23
+ pkgver = 1.0.r62.g7cf6c58
pkgrel = 1
url = https://github.com/google/bloaty
arch = x86_64
@@ -8,7 +8,9 @@ pkgbase = bloaty-git
license = Apache
makedepends = git
makedepends = cmake
- depends = gcc-libs
+ depends = re2
+ depends = capstone
+ depends = protobuf
conflicts = bloaty
source = bloaty-git::git+https://github.com/google/bloaty
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 91eb3a0b3943..fe38bceb10be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Adrian Perez de Castro <aperez@igalia.com>
# Contributor: Yamakaky <yamakaky@yamaworld.fr>
pkgname=bloaty-git
-pkgver=1.0.r2.gfeaca23
+pkgver=1.0.r62.g7cf6c58
pkgrel=1
pkgdesc='A size profiler for binaries'
arch=(x86_64 i686)
url=https://github.com/google/bloaty
license=(Apache)
-depends=(gcc-libs)
+depends=(re2 capstone protobuf)
makedepends=(git cmake)
conflicts=(bloaty)
source=("${pkgname}::git+${url}")
@@ -28,6 +28,7 @@ build() {
cd "${srcdir}/build"
cmake -G 'Unix Makefiles' \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DBLOATY_ENABLE_CMAKETARGETS=OFF \
"${srcdir}/${pkgname}"
make
}