summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuilhem Saurel2020-04-28 10:15:57 +0200
committerGuilhem Saurel2020-04-28 10:15:57 +0200
commit9509ce79e8ace0b546ede76638db7a9234275089 (patch)
tree6cdce16dadf736713c5a16b011f5c6e8829690ab
parent24ffc915d74fddaa92abbf2a0626899f65052a0d (diff)
downloadaur-9509ce79e8ace0b546ede76638db7a9234275089.tar.gz
patch for new hdf5 version
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD13
3 files changed, 14 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55a83e500aad..070c0d2e2b29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = med
pkgdesc = Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - code-aster exchange module linked to hdf5. Without openmpi.
pkgver = 4.0.0
- pkgrel = 5
+ pkgrel = 6
url = https://www.salome-platform.org/downloads
arch = x86_64
license = LGPL
@@ -12,7 +12,9 @@ pkgbase = med
depends = tk
depends = python
source = http://files.salome-platform.org/Salome/other/med-4.0.0.tar.gz
+ source = https://gist.githubusercontent.com/jedbrown/527ef81ff59a0dccf833da40fdd15a47/raw/7482f9a42fdd277f5f9cf0167ea7a3381032ca7a/hdf5-1.12.patch
sha256sums = a474e90b5882ce69c5e9f66f6359c53b8b73eb448c5f631fa96e8cd2c14df004
+ sha256sums = 82d28b6ae2ee6ceb3c6de9acb861a49741e2e759c7c556217f7d284216788206
pkgname = med
diff --git a/.gitignore b/.gitignore
index f34a96c51ab9..18fdfacfc5ba 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,2 +1,3 @@
pkg
src
+hdf5-1.12.patch
diff --git a/PKGBUILD b/PKGBUILD
index c11daba566e3..c5675de38e79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=('med' 'med-docs')
pkgver=4.0.0
-pkgrel=5
+pkgrel=6
pkgdesc="Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - code-aster exchange module linked to hdf5. Without openmpi."
url="https://www.salome-platform.org/downloads"
license=('LGPL')
@@ -8,8 +8,15 @@ depends=('hdf5' 'tk' 'python')
makedepends=('gcc-fortran' 'swig' 'cmake')
optdepends=()
arch=('x86_64')
-source=("http://files.salome-platform.org/Salome/other/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('a474e90b5882ce69c5e9f66f6359c53b8b73eb448c5f631fa96e8cd2c14df004')
+source=("http://files.salome-platform.org/Salome/other/${pkgname}-${pkgver}.tar.gz"
+ "https://gist.githubusercontent.com/jedbrown/527ef81ff59a0dccf833da40fdd15a47/raw/7482f9a42fdd277f5f9cf0167ea7a3381032ca7a/hdf5-1.12.patch")
+sha256sums=('a474e90b5882ce69c5e9f66f6359c53b8b73eb448c5f631fa96e8cd2c14df004'
+ '82d28b6ae2ee6ceb3c6de9acb861a49741e2e759c7c556217f7d284216788206')
+
+prepare() {
+ cd ${pkgbase}-${pkgver}
+ patch -p1 -i "$srcdir/hdf5-1.12.patch"
+}
build() {
cd ${pkgname}-${pkgver}