summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-07-31 12:46:23 +0300
committerCaleb Maclennan2021-07-31 12:46:23 +0300
commit9521e7df66eea3190bac485e0b37840b91ce5b73 (patch)
treefa6be0317c1c8c0225dfd237776d1d1a79668ccd
parent86d59334dc3f1d9a7de0bb4c7183e3594dddce45 (diff)
downloadaur-9521e7df66eea3190bac485e0b37840b91ce5b73.tar.gz
upgpkg: teal 0.13.2-2
Only require dependency for Lua versions that need it
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df6181cefcd2..f0c4f2863822 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = teal
pkgdesc = The compiler for Teal, a typed dialect of Lua
pkgver = 0.13.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/teal-language/tl
arch = any
license = MIT
@@ -21,23 +21,19 @@ pkgname = teal
pkgname = lua-tl
depends = lua
depends = lua-argparse
- depends = lua-compat53
depends = lua-filesystem
pkgname = lua53-tl
depends = lua53
depends = lua53-argparse
- depends = lua53-compat53
depends = lua53-filesystem
pkgname = lua52-tl
depends = lua52
depends = lua52-argparse
- depends = lua52-compat53
depends = lua52-filesystem
pkgname = lua51-tl
depends = lua51
depends = lua51-argparse
- depends = lua51-compat53
depends = lua51-filesystem
diff --git a/PKGBUILD b/PKGBUILD
index 07cf5cea7a87..eb1a8c34d60d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,12 @@ pkgbase=teal
_rockname=tl
pkgname=(teal "lua-$_rockname" "lua53-$_rockname" "lua52-$_rockname" "lua51-$_rockname")
pkgver=0.13.2
-pkgrel=1
+pkgrel=2
pkgdesc="The compiler for Teal, a typed dialect of Lua"
arch=(any)
url=https://github.com/teal-language/tl
license=(MIT)
_lua_deps=(argparse
- compat53
filesystem)
makedepends=(lua lua53 lua52 lua51 luarocks)
source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
@@ -45,11 +44,13 @@ package_lua53-tl() {
}
package_lua52-tl() {
+ _lua_deps+=(compat53)
depends+=(lua52 "${_lua_deps[@]/#/lua52-}")
_package_helper 5.2
}
package_lua51-tl() {
+ _lua_deps+=(compat53)
depends+=(lua51 "${_lua_deps[@]/#/lua51-}")
_package_helper 5.1
}