summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Sferrazza2019-04-25 10:51:53 -0400
committerKyle Sferrazza2019-04-25 10:51:53 -0400
commit952d80cb00eaca90e57eee084b521e1d393c1cd2 (patch)
tree4273ebe3d81303175ac3227ca2d056bf44b639b0
parent1c5073eb652df40ddb6d0ff8b0456bb340f26007 (diff)
downloadaur-952d80cb00eaca90e57eee084b521e1d393c1cd2.tar.gz
add dependencies, update build process
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD35
-rw-r--r--setup.patch13
4 files changed, 54 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab7831074633..51a541a81a42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wifiphisher
pkgdesc = Fast automated phishing attacks against WPA networks.
pkgver = 1.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sophron/wifiphisher
arch = any
groups = blackarch
@@ -9,18 +9,24 @@ pkgbase = wifiphisher
groups = blackarch-social
license = MIT
makedepends = git
+ makedepends = python2-setuptools
depends = python2
- depends = python2-blessings
+ depends = python2-httplib2
+ depends = python2-scapy
+ depends = aircrack-ng
+ depends = python2-pyopenssl
depends = python2-pyric
+ depends = python2-blessings
+ depends = python2-pbkdf2
depends = python2-tornado
- depends = scapy
- depends = dnsmasq
depends = hostapd
- depends = net-tools
+ depends = dnsmasq
+ depends = python2-dbus
+ depends = roguehostapd-git
source = https://github.com/sophron/wifiphisher/archive/v1.4.tar.gz
- source = wifiphisher.sh
- md5sums = bd4357b8a97cdcfb36624245c4f963da
- md5sums = 20fc8c517c5e85c8a47e2372beecd83c
+ source = setup.patch
+ sha512sums = 93629b0d9c88ebcb6c069c84eb9518a4382bc27e28ce7b8b83fc5d1d06ad3c479df2bb52b8da3c20e9abcffa4500b54733f4e872ea8b1e149ee0423f197ed810
+ sha512sums = 60a25cde29493753f2ca973c5b35682f2f2af9a9aeac0673bf9e6cf841b7d127000483f9ce1813d2c3420883e71d10e9e710efb4b6630d7bdf9c6558048d0512
pkgname = wifiphisher
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c58b98705b35
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.tar.gz
+*.pkg*
diff --git a/PKGBUILD b/PKGBUILD
index f86383438f54..1504c07dc9d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,39 @@
-# Maintainer: robertfoster
+# Maintainer: Kyle Sferrazza <kyle.sferrazza@gmail.com>
+# Contributor: robertfoster
+
# This file is part of BlackArch Linux ( http://blackarch.org ).
# See COPYING for license details.
-pkgname='wifiphisher'
+pkgname=wifiphisher
pkgver=1.4
-pkgrel=1
+pkgrel=2
groups=('blackarch' 'blackarch-wireless' 'blackarch-social')
pkgdesc='Fast automated phishing attacks against WPA networks.'
arch=('any')
url='https://github.com/sophron/wifiphisher'
license=('MIT')
-depends=('python2' 'python2-blessings' 'python2-pyric' 'python2-tornado' 'scapy' 'dnsmasq' 'hostapd' 'net-tools')
-makedepends=('git')
+depends=('python2' 'python2-httplib2' 'python2-scapy' 'aircrack-ng'
+ 'python2-pyopenssl' 'python2-pyric' 'python2-blessings'
+ 'python2-pbkdf2' 'python2-tornado' 'hostapd' 'dnsmasq'
+ 'python2-dbus' 'roguehostapd-git')
+makedepends=('git' 'python2-setuptools')
source=("https://github.com/sophron/wifiphisher/archive/v$pkgver.tar.gz"
-$pkgname.sh)
+ 'setup.patch')
+sha512sums=('93629b0d9c88ebcb6c069c84eb9518a4382bc27e28ce7b8b83fc5d1d06ad3c479df2bb52b8da3c20e9abcffa4500b54733f4e872ea8b1e149ee0423f197ed810'
+ '60a25cde29493753f2ca973c5b35682f2f2af9a9aeac0673bf9e6cf841b7d127000483f9ce1813d2c3420883e71d10e9e710efb4b6630d7bdf9c6558048d0512')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ cat "$srcdir/setup.patch" | patch -p1
+}
package() {
cd "$srcdir/$pkgname-$pkgver"
- python2 setup.py install --root=$pkgdir
-}
+ install -dm 755 "$pkgdir/usr/bin"
+ install -dm 755 "$pkgdir/usr/share/$_pkgname"
+
+ python2 setup.py install --root="$pkgdir"
-md5sums=('bd4357b8a97cdcfb36624245c4f963da'
-'20fc8c517c5e85c8a47e2372beecd83c')
+ install -Dm 644 -t "$pkgdir/usr/share/doc/$_pkgname/" *.md
+ install -Dm 644 LICENSE.txt "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}
diff --git a/setup.patch b/setup.patch
new file mode 100644
index 000000000000..220da5f1e1b4
--- /dev/null
+++ b/setup.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index c60d885..643fafb 100644
+--- a/setup.py
++++ b/setup.py
+@@ -116,7 +116,7 @@ CLASSIFIERS = ["Development Status :: 5 - Production/Stable",
+ "Intended Audience :: System Administrators",
+ "Intended Audience :: Information Technology"]
+ ENTRY_POINTS = {"console_scripts": ["wifiphisher = wifiphisher.pywifiphisher:run"]}
+-INSTALL_REQUIRES = ["PyRIC", "tornado", "dbus-python",
++INSTALL_REQUIRES = ["PyRIC", "tornado",
+ "pbkdf2", "roguehostapd", "scapy"]
+ CMDCLASS = {"clean": CleanCommand,}
+