summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian2021-01-12 22:05:18 +0100
committerAdrian2021-01-12 22:05:18 +0100
commit9538a2232bab72a97d94616f4f5b4cdb3b71583b (patch)
treefea16a3ae4ba780b42db86e792e8127ebfd17753
downloadaur-9538a2232bab72a97d94616f4f5b4cdb3b71583b.tar.gz
Initial upload
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
-rw-r--r--fixed-jsons.diff578
-rw-r--r--irony-mod-manager-bin.README.md20
-rw-r--r--irony-mod-manager-bin.desktop9
-rwxr-xr-xirony-mod-manager-bin.sh2
7 files changed, 684 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a33eda14b9f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = irony-mod-manager-bin
+ pkgdesc = A mod manager and launcher for paradox interactive games
+ pkgver = 1.10.65
+ pkgrel = 1
+ url = https://github.com/bcssov/IronyModManager
+ arch = x86_64
+ license = MIT
+ depends = fontconfig
+ depends = bash
+ depends = zlib
+ depends = krb5
+ depends = lttng-ust
+ noextract = irony-mod-manager-bin-1.10.65.zip
+ source = irony-mod-manager-bin-1.10.65.zip::https://github.com/bcssov/IronyModManager/releases/download/v1.10.65/linux-x64.zip
+ source = irony-mod-manager-bin.png::https://raw.githubusercontent.com/bcssov/IronyModManager/v1.10.65/src/IronyModManager/Assets/logo.png
+ source = irony-mod-manager-bin.desktop
+ source = irony-mod-manager-bin.sh
+ source = irony-mod-manager-bin.README.md
+ source = fixed-jsons.diff
+ md5sums = bda33c8e0a4cd6aaf09edc2d4b30d6bf
+ md5sums = 190d6d8e852bbe000af5dac87a5b921c
+ md5sums = 937b6e3a2add4fa832d13d3af7737308
+ md5sums = 020c05854432b6e877de520a967fccee
+ md5sums = 40e27fea8c512d1b6d10ad3bb794eb2e
+ md5sums = 953d00c6442dec40d998f97dfd53ffe4
+
+pkgname = irony-mod-manager-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c1cf5c30813e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+src/*
+pkg
+pkg/* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..afe94593f56f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Adrian Schmitz <zetabite.horzion@gmail.com>
+pkgname=irony-mod-manager-bin
+pkgver=1.10.65
+pkgrel=1
+pkgdesc="A mod manager and launcher for paradox interactive games"
+arch=('x86_64')
+url="https://github.com/bcssov/IronyModManager"
+license=('MIT')
+depends=("fontconfig" "bash" "zlib" "krb5" "lttng-ust")
+source=("$pkgname-$pkgver.zip::https://github.com/bcssov/IronyModManager/releases/download/v$pkgver/linux-x64.zip"
+ "$pkgname.png::https://raw.githubusercontent.com/bcssov/IronyModManager/v$pkgver/src/IronyModManager/Assets/logo.png"
+ "$pkgname.desktop"
+ "$pkgname.sh"
+ "$pkgname.README.md"
+ "fixed-jsons.diff")
+md5sums=('bda33c8e0a4cd6aaf09edc2d4b30d6bf'
+ '190d6d8e852bbe000af5dac87a5b921c'
+ '937b6e3a2add4fa832d13d3af7737308'
+ '020c05854432b6e877de520a967fccee'
+ '40e27fea8c512d1b6d10ad3bb794eb2e'
+ '953d00c6442dec40d998f97dfd53ffe4')
+noextract=("$pkgname-$pkgver.zip")
+
+prepare() {
+ mkdir -p $pkgname-$pkgver && bsdtar -xf $pkgname-$pkgver.zip -C $pkgname-$pkgver
+}
+
+package() {
+ mkdir -p "$pkgdir/opt/$pkgname"
+ mkdir -p "$pkgdir/usr/bin"
+
+ cd "$srcdir/$pkgname-$pkgver/"
+ patch -p1 -i "$srcdir/fixed-jsons.diff"
+
+ cp -R "$srcdir/$pkgname-$pkgver" -T "$pkgdir/opt/$pkgname/"
+
+ install -m644 -D "$srcdir/$pkgname.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -m644 -D "$srcdir/$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -m644 -D "$srcdir/$pkgname.README.md" "$pkgdir/opt/$pkgname/README.md"
+ install -m644 -D "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -m755 -D "$srcdir/$pkgname-$pkgver/IronyModManager" "$pkgdir/opt/$pkgname/IronyModManager"
+ install -m755 -D "$srcdir/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+}
diff --git a/fixed-jsons.diff b/fixed-jsons.diff
new file mode 100644
index 000000000000..5732b4e1166e
--- /dev/null
+++ b/fixed-jsons.diff
@@ -0,0 +1,578 @@
+diff -Naur original/IronyModManager.Common.deps.json fixed/IronyModManager.Common.deps.json
+--- original/IronyModManager.Common.deps.json 2020-12-31 19:17:08.000000000 +0100
++++ fixed/IronyModManager.Common.deps.json 2021-01-12 14:04:08.000000000 +0100
+@@ -689,30 +689,6 @@
+ "createdump": {
+ "fileVersion": "0.0.0.0"
+ },
+- "libSystem.IO.Compression.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.IO.Compression.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.so": {
+- "fileVersion": "0.0.0.0"
+- },
+ "libclrjit.so": {
+ "fileVersion": "0.0.0.0"
+ },
+diff -Naur original/IronyModManager.deps.json fixed/IronyModManager.deps.json
+--- original/IronyModManager.deps.json 2020-12-31 19:17:24.000000000 +0100
++++ fixed/IronyModManager.deps.json 2021-01-12 14:01:16.000000000 +0100
+@@ -707,30 +707,6 @@
+ "createdump": {
+ "fileVersion": "0.0.0.0"
+ },
+- "libSystem.IO.Compression.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.IO.Compression.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.so": {
+- "fileVersion": "0.0.0.0"
+- },
+ "libclrjit.so": {
+ "fileVersion": "0.0.0.0"
+ },
+diff -Naur original/IronyModManager.DI.deps.json fixed/IronyModManager.DI.deps.json
+--- original/IronyModManager.DI.deps.json 2020-12-31 19:15:52.000000000 +0100
++++ fixed/IronyModManager.DI.deps.json 2021-01-12 14:04:55.000000000 +0100
+@@ -688,30 +688,6 @@
+ "createdump": {
+ "fileVersion": "0.0.0.0"
+ },
+- "libSystem.IO.Compression.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.IO.Compression.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.so": {
+- "fileVersion": "0.0.0.0"
+- },
+ "libclrjit.so": {
+ "fileVersion": "0.0.0.0"
+ },
+diff -Naur original/IronyModManager.IO.Common.deps.json fixed/IronyModManager.IO.Common.deps.json
+--- original/IronyModManager.IO.Common.deps.json 2020-12-31 19:16:08.000000000 +0100
++++ fixed/IronyModManager.IO.Common.deps.json 2021-01-12 14:07:20.000000000 +0100
+@@ -686,30 +686,6 @@
+ "createdump": {
+ "fileVersion": "0.0.0.0"
+ },
+- "libSystem.IO.Compression.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.IO.Compression.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.so": {
+- "fileVersion": "0.0.0.0"
+- },
+ "libclrjit.so": {
+ "fileVersion": "0.0.0.0"
+ },
+diff -Naur original/IronyModManager.IO.deps.json fixed/IronyModManager.IO.deps.json
+--- original/IronyModManager.IO.deps.json 2020-12-31 19:16:36.000000000 +0100
++++ fixed/IronyModManager.IO.deps.json 2021-01-12 14:07:07.000000000 +0100
+@@ -694,30 +694,6 @@
+ "createdump": {
+ "fileVersion": "0.0.0.0"
+ },
+- "libSystem.IO.Compression.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.IO.Compression.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.so": {
+- "fileVersion": "0.0.0.0"
+- },
+ "libclrjit.so": {
+ "fileVersion": "0.0.0.0"
+ },
+diff -Naur original/IronyModManager.Localization.deps.json fixed/IronyModManager.Localization.deps.json
+--- original/IronyModManager.Localization.deps.json 2020-12-31 19:15:52.000000000 +0100
++++ fixed/IronyModManager.Localization.deps.json 2021-01-12 14:07:00.000000000 +0100
+@@ -688,30 +688,6 @@
+ "createdump": {
+ "fileVersion": "0.0.0.0"
+ },
+- "libSystem.IO.Compression.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.IO.Compression.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.so": {
+- "fileVersion": "0.0.0.0"
+- },
+ "libclrjit.so": {
+ "fileVersion": "0.0.0.0"
+ },
+diff -Naur original/IronyModManager.Models.Common.deps.json fixed/IronyModManager.Models.Common.deps.json
+--- original/IronyModManager.Models.Common.deps.json 2020-12-31 19:15:52.000000000 +0100
++++ fixed/IronyModManager.Models.Common.deps.json 2021-01-12 14:06:49.000000000 +0100
+@@ -685,30 +685,6 @@
+ "createdump": {
+ "fileVersion": "0.0.0.0"
+ },
+- "libSystem.IO.Compression.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.IO.Compression.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.so": {
+- "fileVersion": "0.0.0.0"
+- },
+ "libclrjit.so": {
+ "fileVersion": "0.0.0.0"
+ },
+diff -Naur original/IronyModManager.Models.deps.json fixed/IronyModManager.Models.deps.json
+--- original/IronyModManager.Models.deps.json 2020-12-31 19:16:40.000000000 +0100
++++ fixed/IronyModManager.Models.deps.json 2021-01-12 14:06:42.000000000 +0100
+@@ -688,30 +688,6 @@
+ "createdump": {
+ "fileVersion": "0.0.0.0"
+ },
+- "libSystem.IO.Compression.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.IO.Compression.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.so": {
+- "fileVersion": "0.0.0.0"
+- },
+ "libclrjit.so": {
+ "fileVersion": "0.0.0.0"
+ },
+diff -Naur original/IronyModManager.Parser.Common.deps.json fixed/IronyModManager.Parser.Common.deps.json
+--- original/IronyModManager.Parser.Common.deps.json 2020-12-31 19:16:16.000000000 +0100
++++ fixed/IronyModManager.Parser.Common.deps.json 2021-01-12 14:06:33.000000000 +0100
+@@ -685,30 +685,6 @@
+ "createdump": {
+ "fileVersion": "0.0.0.0"
+ },
+- "libSystem.IO.Compression.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.IO.Compression.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.so": {
+- "fileVersion": "0.0.0.0"
+- },
+ "libclrjit.so": {
+ "fileVersion": "0.0.0.0"
+ },
+diff -Naur original/IronyModManager.Parser.deps.json fixed/IronyModManager.Parser.deps.json
+--- original/IronyModManager.Parser.deps.json 2020-12-31 19:16:46.000000000 +0100
++++ fixed/IronyModManager.Parser.deps.json 2021-01-12 14:06:24.000000000 +0100
+@@ -687,30 +687,6 @@
+ "createdump": {
+ "fileVersion": "0.0.0.0"
+ },
+- "libSystem.IO.Compression.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.IO.Compression.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.so": {
+- "fileVersion": "0.0.0.0"
+- },
+ "libclrjit.so": {
+ "fileVersion": "0.0.0.0"
+ },
+diff -Naur original/IronyModManager.Platform.deps.json fixed/IronyModManager.Platform.deps.json
+--- original/IronyModManager.Platform.deps.json 2020-12-31 19:17:02.000000000 +0100
++++ fixed/IronyModManager.Platform.deps.json 2021-01-12 14:06:14.000000000 +0100
+@@ -681,30 +681,6 @@
+ "createdump": {
+ "fileVersion": "0.0.0.0"
+ },
+- "libSystem.IO.Compression.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.IO.Compression.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.so": {
+- "fileVersion": "0.0.0.0"
+- },
+ "libclrjit.so": {
+ "fileVersion": "0.0.0.0"
+ },
+diff -Naur original/IronyModManager.Services.Common.deps.json fixed/IronyModManager.Services.Common.deps.json
+--- original/IronyModManager.Services.Common.deps.json 2020-12-31 19:16:22.000000000 +0100
++++ fixed/IronyModManager.Services.Common.deps.json 2021-01-12 14:06:02.000000000 +0100
+@@ -686,30 +686,6 @@
+ "createdump": {
+ "fileVersion": "0.0.0.0"
+ },
+- "libSystem.IO.Compression.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.IO.Compression.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.so": {
+- "fileVersion": "0.0.0.0"
+- },
+ "libclrjit.so": {
+ "fileVersion": "0.0.0.0"
+ },
+diff -Naur original/IronyModManager.Services.deps.json fixed/IronyModManager.Services.deps.json
+--- original/IronyModManager.Services.deps.json 2020-12-31 19:16:54.000000000 +0100
++++ fixed/IronyModManager.Services.deps.json 2021-01-12 14:05:53.000000000 +0100
+@@ -693,30 +693,6 @@
+ "createdump": {
+ "fileVersion": "0.0.0.0"
+ },
+- "libSystem.IO.Compression.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.IO.Compression.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.so": {
+- "fileVersion": "0.0.0.0"
+- },
+ "libclrjit.so": {
+ "fileVersion": "0.0.0.0"
+ },
+diff -Naur original/IronyModManager.Shared.deps.json fixed/IronyModManager.Shared.deps.json
+--- original/IronyModManager.Shared.deps.json 2020-12-31 19:15:48.000000000 +0100
++++ fixed/IronyModManager.Shared.deps.json 2021-01-12 14:05:42.000000000 +0100
+@@ -690,30 +690,6 @@
+ "createdump": {
+ "fileVersion": "0.0.0.0"
+ },
+- "libSystem.IO.Compression.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.IO.Compression.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.so": {
+- "fileVersion": "0.0.0.0"
+- },
+ "libclrjit.so": {
+ "fileVersion": "0.0.0.0"
+ },
+diff -Naur original/IronyModManager.Storage.Common.deps.json fixed/IronyModManager.Storage.Common.deps.json
+--- original/IronyModManager.Storage.Common.deps.json 2020-12-31 19:15:54.000000000 +0100
++++ fixed/IronyModManager.Storage.Common.deps.json 2021-01-12 14:05:33.000000000 +0100
+@@ -686,30 +686,6 @@
+ "createdump": {
+ "fileVersion": "0.0.0.0"
+ },
+- "libSystem.IO.Compression.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.IO.Compression.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.so": {
+- "fileVersion": "0.0.0.0"
+- },
+ "libclrjit.so": {
+ "fileVersion": "0.0.0.0"
+ },
+diff -Naur original/IronyModManager.Storage.deps.json fixed/IronyModManager.Storage.deps.json
+--- original/IronyModManager.Storage.deps.json 2020-12-31 19:16:26.000000000 +0100
++++ fixed/IronyModManager.Storage.deps.json 2021-01-12 14:05:23.000000000 +0100
+@@ -690,30 +690,6 @@
+ "createdump": {
+ "fileVersion": "0.0.0.0"
+ },
+- "libSystem.IO.Compression.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.IO.Compression.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.so": {
+- "fileVersion": "0.0.0.0"
+- },
+ "libclrjit.so": {
+ "fileVersion": "0.0.0.0"
+ },
+diff -Naur original/IronyModManager.Updater.deps.json fixed/IronyModManager.Updater.deps.json
+--- original/IronyModManager.Updater.deps.json 2020-12-31 19:17:12.000000000 +0100
++++ fixed/IronyModManager.Updater.deps.json 2021-01-12 14:05:11.000000000 +0100
+@@ -681,30 +681,6 @@
+ "createdump": {
+ "fileVersion": "0.0.0.0"
+ },
+- "libSystem.IO.Compression.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.IO.Compression.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Net.Security.Native.so": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.a": {
+- "fileVersion": "0.0.0.0"
+- },
+- "libSystem.Security.Cryptography.Native.OpenSsl.so": {
+- "fileVersion": "0.0.0.0"
+- },
+ "libclrjit.so": {
+ "fileVersion": "0.0.0.0"
+ },
diff --git a/irony-mod-manager-bin.README.md b/irony-mod-manager-bin.README.md
new file mode 100644
index 000000000000..c79fdc4d8cdd
--- /dev/null
+++ b/irony-mod-manager-bin.README.md
@@ -0,0 +1,20 @@
+# Moving from Paradox Launcher to Irony Mod Mananger
+1. Quit Stellaris and Stellaris (Paradox) Launcher
+2. Unsubscribe from all mods. Stellaris Workshop -> Your files (under your avatar) -> Subscribed items - > Unsubscribe From All
+3. Quit Steam
+4. Go to `~/.steam/steam/steamapps/workshop/content/281990/` and delete everything
+5. Go to `~/.local/share/Paradox Interactive/Stellaris/` and delete the following files:
+ + dlc_load.json
+ + game_data.json
+ + launcher-v2.sqlite
+ + mods_registry.json
+ + everything inside last_mods={ } in settings.txt
+6. Restart Steam
+7. Open Paradox launcher
+8. Close Paradox launcher
+9. Resubscribe to your mods
+10. Wait until all downloads are done. Only then continue with step 11.
+11. Start Paradox Launcher
+12. Close Paradox launcher
+
+You can now use Irony Mod Mananger
diff --git a/irony-mod-manager-bin.desktop b/irony-mod-manager-bin.desktop
new file mode 100644
index 000000000000..07273217fb14
--- /dev/null
+++ b/irony-mod-manager-bin.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Irony Mod Mananger
+Comment=A mod manager and launcher for paradox interactive games
+Exec=/usr/bin/irony-mod-manager-bin %U
+Icon=irony-mod-manager
+Terminal=false
+Type=Application
+Categories=Network;FileTransfer;Game;
+
diff --git a/irony-mod-manager-bin.sh b/irony-mod-manager-bin.sh
new file mode 100755
index 000000000000..4a110b3fa96d
--- /dev/null
+++ b/irony-mod-manager-bin.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+/opt/irony-mod-manager-bin/IronyModManager \ No newline at end of file