summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonidas P2023-05-01 02:57:04 +0300
committerLeonidas P2023-05-01 02:57:04 +0300
commit953f35827ad1e5255125032b3a66611da3dfbdb4 (patch)
tree9d23dff274723dddd4e7d6559ac0476cc0d6527b
parente8625527fef34422078387aff8cee9aa9d2996ee (diff)
downloadaur-953f35827ad1e5255125032b3a66611da3dfbdb4.tar.gz
added patch for CFLAGS in newer version
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
-rw-r--r--append-CFLAGS.patch13
3 files changed, 32 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f134bd37bfa7..1a69047631dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mmc-utils-git
pkgdesc = Userspace tools for MMC/SD devices
- pkgver = r98.d7b343f
+ pkgver = r109.145c74a
pkgrel = 1
epoch = 1
url = https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git
@@ -14,6 +14,8 @@ pkgbase = mmc-utils-git
provides = mmc-utils
conflicts = mmc-utils
source = git+https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git
+ source = append-CFLAGS.patch
sha256sums = SKIP
+ sha256sums = 0ec2d5ed066dd0797b9d32fadea8c64e4fe509f3585cdbeeb3640c3a1cda9dfc
pkgname = mmc-utils-git
diff --git a/PKGBUILD b/PKGBUILD
index 1f8d20064892..3e38a4c38bc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=mmc-utils
pkgname=${_pkgname}-git
-pkgver=r98.d7b343f
+pkgver=r109.145c74a
pkgrel=1
epoch=1
pkgdesc="Userspace tools for MMC/SD devices"
@@ -13,16 +13,28 @@ license=('GPL')
makedepends=('git')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=('git+https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git')
-sha256sums=('SKIP')
+source=(
+ 'git+https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git'
+ 'append-CFLAGS.patch'
+)
+sha256sums=(
+ 'SKIP'
+ '0ec2d5ed066dd0797b9d32fadea8c64e4fe509f3585cdbeeb3640c3a1cda9dfc'
+)
pkgver() {
cd "${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "${_pkgname}"
+ patch --forward --strip=1 --input="${srcdir}/append-CFLAGS.patch"
+}
+
build() {
- make -C "${_pkgname}"
+ cd "${_pkgname}"
+ make
}
package() {
diff --git a/append-CFLAGS.patch b/append-CFLAGS.patch
new file mode 100644
index 000000000000..e7903f168b41
--- /dev/null
+++ b/append-CFLAGS.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index d8d59a4..9b413f9 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ CC ?= gcc
+ GIT_VERSION := "$(shell git describe --abbrev=6 --always --tags)"
+ AM_CFLAGS = -D_FILE_OFFSET_BITS=64 -D_FORTIFY_SOURCE=2
+-CFLAGS ?= -g -O2 -DVERSION=\"$(GIT_VERSION)\"
++CFLAGS += -g -O2 -DVERSION=\"$(GIT_VERSION)\"
+ objects = \
+ mmc.o \
+ mmc_cmds.o \