summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathon Fernyhough2019-03-06 20:13:40 +0000
committerJonathon Fernyhough2019-03-06 20:13:40 +0000
commit954c7e60d3e665b7069d89637d17e4f233f0e764 (patch)
tree2d4ec857ed4cb5627cc56425d69764bdf227dd25
downloadaur-954c7e60d3e665b7069d89637d17e4f233f0e764.tar.gz
Initial commit. Upstream 0.2.0.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD50
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40381b436c1c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = julia-customunitranges
+ pkgdesc = Package-specific AbstractUnitRange types for julia
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://github.com/JuliaArrays/CatIndices.jl
+ arch = any
+ license = MIT
+ makedepends = julia-distrohelper
+ depends = julia
+ depends = julia-compat
+ depends = julia-loadpath
+ source = julia-customunitranges-0.2.0.tar.gz::https://github.com/JuliaArrays/CustomUnitRanges.jl/archive/v0.2.0.tar.gz
+ source = julia-customunitranges-0.2.0-Deps.toml::https://raw.githubusercontent.com/JuliaRegistries/General/fbfeb69a2884a8188446ede9713b4a6fab54ac9d/C/CustomUnitRanges/Deps.toml
+ source = julia-customunitranges-0.2.0-Package.toml::https://raw.githubusercontent.com/JuliaRegistries/General/fbfeb69a2884a8188446ede9713b4a6fab54ac9d/C/CustomUnitRanges/Package.toml
+ source = julia-customunitranges-0.2.0-Versions.toml::https://raw.githubusercontent.com/JuliaRegistries/General/fbfeb69a2884a8188446ede9713b4a6fab54ac9d/C/CustomUnitRanges/Versions.toml
+ sha256sums = 3757f4c85012d817b567fc28af1ca8208fb1833b72215139602cbe87fbb1361b
+ sha256sums = 96b76859a5ab36fbca8bbace268741f9268741766570777b19774d70569a120c
+ sha256sums = e436d208193283b7915203743069133c5969a9cd4fc3485e2c0cd50e82bbf178
+ sha256sums = 74f0ecfd0f8e8e5dc416b2bea064188f51d66eac43c8dcae2151eb64769301f4
+
+pkgname = julia-customunitranges
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fe30f7f7f0a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Jonathon Fernyhough <jonathon_at_manjaro dot_org>
+
+pkgname=julia-customunitranges
+_pkgname=CustomUnitRanges
+pkgver=0.2.0
+pkgrel=1
+pkgdesc='Package-specific AbstractUnitRange types for julia'
+arch=(any)
+url=https://github.com/JuliaArrays/CatIndices.jl
+license=(MIT)
+depends=(julia julia-compat julia-loadpath)
+makedepends=(julia-distrohelper)
+
+_commit=fbfeb69a2884a8188446ede9713b4a6fab54ac9d
+source=($pkgname-$pkgver.tar.gz::https://github.com/JuliaArrays/$_pkgname.jl/archive/v$pkgver.tar.gz
+ $pkgname-$pkgver-Deps.toml::https://raw.githubusercontent.com/JuliaRegistries/General/$_commit/${_pkgname:0:1}/$_pkgname/Deps.toml
+ $pkgname-$pkgver-Package.toml::https://raw.githubusercontent.com/JuliaRegistries/General/$_commit/${_pkgname:0:1}/$_pkgname/Package.toml
+ $pkgname-$pkgver-Versions.toml::https://raw.githubusercontent.com/JuliaRegistries/General/$_commit/${_pkgname:0:1}/$_pkgname/Versions.toml)
+sha256sums=('3757f4c85012d817b567fc28af1ca8208fb1833b72215139602cbe87fbb1361b'
+ '96b76859a5ab36fbca8bbace268741f9268741766570777b19774d70569a120c'
+ 'e436d208193283b7915203743069133c5969a9cd4fc3485e2c0cd50e82bbf178'
+ '74f0ecfd0f8e8e5dc416b2bea064188f51d66eac43c8dcae2151eb64769301f4')
+
+_slug() {
+ dh_julia slug "$srcdir"/"$pkgname"-$pkgver-{Package,Versions}.toml
+}
+
+_project() {
+ dh_julia distro_project_ "$srcdir"/"$pkgname"-$pkgver-{Package,Versions,Deps}.toml
+}
+
+prepare() {
+ # Generate a Project.toml from Registry metadata
+ rm -f Project.toml && _project
+}
+
+package() {
+ install -d "$pkgdir"/usr/share/julia/{vendor,packages/$_pkgname}
+
+ cp -r $_pkgname.jl-$pkgver "$pkgdir"/usr/share/julia/vendor/$_pkgname
+ install -m644 Project.toml "$pkgdir"/usr/share/julia/vendor/$_pkgname/Project.toml
+ ln -s ../../vendor/$_pkgname "$pkgdir"/usr/share/julia/packages/$_pkgname/$(_slug)
+
+ install -Dm644 $_pkgname.jl-$pkgver/LICENSE.md "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+check() {
+ cd $_pkgname.jl-$pkgver
+ HOME="$srcdir" JULIA_LOAD_PATH=src:$JULIA_LOAD_PATH julia test/runtests.jl
+}