summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302021-12-10 23:57:27 +0100
committerM0Rf302021-12-10 23:57:27 +0100
commit95553405854059fb44c8624ac8caa80a579a2a0a (patch)
treede74f0b3868f390242ea02784dde603a93ecacb5
parentfb5e3f6ed05830ddb91d9b24109e10e6cb7dc4df (diff)
downloadaur-95553405854059fb44c8624ac8caa80a579a2a0a.tar.gz
rpi-eeprom-git: update
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD37
-rw-r--r--rpi-eeprom-update.patch8
3 files changed, 39 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 152fdbd1ce44..7900245c0430 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,17 +3,18 @@ pkgbase = rpi-eeprom-git
pkgver = r436.a4c259a
pkgrel = 1
url = http://github.com/raspberrypi/rpi-eeprom
- arch = armv6h
- arch = armv7h
- arch = aarch64
+ arch = any
license = custom
depends = python
- depends = raspberrypi-firmware
+ optdepends = raspberrypi-firmware: Use this on an armv7h (32bit) system.
+ optdepends = raspberrypi-userland-aarch64: Use this on an aarch64 (64bit) system.
provides = rpi-eeprom
conflicts = rpi-eeprom
options = !strip
backup = etc/default/rpi-eeprom-update
source = git+https://github.com/raspberrypi/rpi-eeprom.git
+ source = rpi-eeprom-update.patch
md5sums = SKIP
+ md5sums = 9036901f8345f0e0cbf25f4440529213
pkgname = rpi-eeprom-git
diff --git a/PKGBUILD b/PKGBUILD
index 9b9d634bf10a..327fd0a7abac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,15 +7,23 @@ pkgname=rpi-eeprom-git
pkgver=r436.a4c259a
pkgrel=1
pkgdesc='Raspberry Pi4 boot EEPROM updater, latest git version'
-arch=('armv6h' 'armv7h' 'aarch64')
+arch=('any')
url='http://github.com/raspberrypi/rpi-eeprom'
license=('custom')
-depends=('python' 'raspberrypi-firmware')
+depends=(
+ 'python'
+)
+optdepends=(
+ 'raspberrypi-firmware: Use this on an armv7h (32bit) system.'
+ 'raspberrypi-userland-aarch64: Use this on an aarch64 (64bit) system.'
+)
provides=('rpi-eeprom')
conflicts=('rpi-eeprom')
backup=('etc/default/rpi-eeprom-update')
-source=("git+https://github.com/raspberrypi/rpi-eeprom.git")
-md5sums=('SKIP')
+source=("git+https://github.com/raspberrypi/rpi-eeprom.git"
+ 'rpi-eeprom-update.patch')
+md5sums=('SKIP'
+ '9036901f8345f0e0cbf25f4440529213')
options=(!strip)
pkgver() {
@@ -24,17 +32,24 @@ pkgver() {
}
package() {
- install -Dm755 "${srcdir}/rpi-eeprom/rpi-eeprom-config" \
+ # Create and install the binaries in /usr/bin
+ install -d -m 755 "${pkgdir}/usr/bin"
+ install -D -m 755 rpi-eeprom/rpi-eeprom-config \
"${pkgdir}/usr/bin/rpi-eeprom-config"
- install -Dm755 "${srcdir}/rpi-eeprom/rpi-eeprom-update" \
- "${pkgdir}/usr/bin/rpi-eeprom-update"
- sed -i "s/#!\/bin\/sh/#!\/bin\/sh\nPATH=\"$PATH:\/opt\/vc\/bin\"\n/g" \
+
+ # Patch /opt/vc/bin into PATH in script due to weird install location of raspberrypi-firmware
+ install -D -m 755 rpi-eeprom/rpi-eeprom-update \
"${pkgdir}/usr/bin/rpi-eeprom-update"
- install -dm755 "${pkgdir}/usr/lib/firmware/raspberrypi/bootloader"
+ patch "${pkgdir}/usr/bin/rpi-eeprom-update" \
+ "${srcdir}/rpi-eeprom-update.patch"
+
+ # Copy all the firmware and files to the right place
+ install -d -m 755 "${pkgdir}/usr/lib/firmware/raspberrypi/bootloader"
cp -a rpi-eeprom/firmware/* \
"${pkgdir}/usr/lib/firmware/raspberrypi/bootloader"
- install -dm755 "${pkgdir}/etc/default"
- install -Dm644 "${srcdir}/rpi-eeprom/rpi-eeprom-update-default" \
+ # Copy the override in place
+ install -d -m 755 "${pkgdir}/etc/default"
+ install -D -m 644 rpi-eeprom/rpi-eeprom-update-default \
"${pkgdir}/etc/default/rpi-eeprom-update"
}
diff --git a/rpi-eeprom-update.patch b/rpi-eeprom-update.patch
new file mode 100644
index 000000000000..2eaf7cbc689b
--- /dev/null
+++ b/rpi-eeprom-update.patch
@@ -0,0 +1,8 @@
+--- rpi-eeprom-update.clean 2019-11-23 06:15:37.986151577 +0000
++++ rpi-eeprom-update 2019-11-23 06:15:45.906017778 +0000
+@@ -1,4 +1,5 @@
+ #!/bin/sh
++PATH="$PATH:/opt/vc/bin"
+
+ # Raspberry Pi4 boot EEPROM updater.
+