summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPi-Yueh Chuang2022-07-19 13:05:23 -0400
committerPi-Yueh Chuang2022-07-19 13:05:23 -0400
commit956b4ec2f58fe12716cd70be026bf695028236f0 (patch)
tree590ef71f4ac07cbcb077379e2fda1b3eeeb6af86
parentcce924ef54f36147804cd128fb7e4aa38ddaff27 (diff)
downloadaur-956b4ec2f58fe12716cd70be026bf695028236f0.tar.gz
upgpkg: fwupd-git 1.8.2.r46.g6e69d8fb8-1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9911c9a57f16..46d03eff2690 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
pkgbase = fwupd-git
pkgdesc = Simple daemon to allow session software to update firmware
- pkgver = 1.7.6.r62.g4074150d2
+ pkgver = 1.8.2.r46.g6e69d8fb8
pkgrel = 1
url = https://github.com/fwupd/fwupd
- arch = i686
arch = x86_64
- arch = armv6h
- arch = armv7h
- arch = aarch64
license = LGPL
checkdepends = umockdev
makedepends = meson
makedepends = valgrind
makedepends = gobject-introspection
- makedepends = gtk-doc
+ makedepends = gi-docgen
makedepends = python-cairo
makedepends = noto-fonts
makedepends = noto-fonts-cjk
@@ -36,13 +32,17 @@ pkgbase = fwupd-git
depends = libjcat
depends = fwupd-efi
depends = gcab
+ depends = hicolor-icon-theme
+ depends = bluez
+ depends = gnutls
depends = libarchive.so
+ depends = libcurl.so
+ depends = libcbor.so
depends = libjson-glib-1.0.so
depends = libgudev-1.0.so
depends = libmm-glib.so
depends = libqmi-glib.so
depends = libprotobuf-c.so
- depends = libcbor
optdepends = udisks2: UEFI firmware upgrade support
provides = libfwupd.so
provides = libfwupdplugin.so
diff --git a/PKGBUILD b/PKGBUILD
index 74c52c8cf23d..914c8a89938e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,25 @@
# Contributor: Kenneth Endfinger <kaendfinger@gmail.com>
pkgname=fwupd-git
-pkgver=1.7.6.r62.g4074150d2
+pkgver=1.8.2.r46.g6e69d8fb8
pkgrel=1
pkgdesc="Simple daemon to allow session software to update firmware"
-arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+arch=('x86_64')
url="https://github.com/fwupd/fwupd"
license=('LGPL')
depends=(
'libxmlb' 'efivar' 'python' 'libsmbios' 'libgusb'
'polkit' 'shared-mime-info' 'tpm2-tss' 'flashrom'
- 'libjcat' 'fwupd-efi' 'gcab' 'libarchive.so'
+ 'libjcat' 'fwupd-efi' 'gcab' 'hicolor-icon-theme'
+ 'bluez' 'gnutls'
+ 'libarchive.so' 'libcurl.so' 'libcbor.so'
'libjson-glib-1.0.so' 'libgudev-1.0.so' 'libmm-glib.so'
- 'libqmi-glib.so' 'libprotobuf-c.so' 'libcbor')
+ 'libqmi-glib.so' 'libprotobuf-c.so')
optdepends=(
'udisks2: UEFI firmware upgrade support'
)
makedepends=(
- 'meson' 'valgrind' 'gobject-introspection' 'gtk-doc'
+ 'meson' 'valgrind' 'gobject-introspection' 'gi-docgen'
'python-cairo' 'noto-fonts' 'noto-fonts-cjk' 'python-gobject' 'vala'
'bash-completion' 'python-pillow' 'help2man' 'gnu-efi-libs' 'git')
checkdepends=('umockdev')
@@ -49,10 +51,11 @@ build() {
arch-meson "${srcdir}/${pkgname}" "${srcdir}/build" \
-D plugin_flashrom=enabled \
-D plugin_modem_manager=enabled \
- -D plugin_intel_spi=true \
-D b_lto=false \
-D lzma=enabled \
- -D docs=gtkdoc \
+ -D docs=enabled \
+ -D gresource_quirks=disabled \
+ -D plugin_intel_spi=true \
-D supported_build=enabled \
-D efi_binary=false
@@ -76,4 +79,5 @@ package() {
# Remove msr module-load config as it is built-in
rm "${pkgdir}"/usr/lib/modules-load.d/fwupd-msr.conf
+ rmdir "${pkgdir}"/usr/lib/modules-load.d
}