summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVasili Novikov (replace "vvv" with "v" in email)2023-08-07 13:18:57 +0200
committerVasili Novikov (replace "vvv" with "v" in email)2023-08-07 13:18:57 +0200
commit956f08479d28c588d3597b97a55a1613cb5fb513 (patch)
treeb1e4107711719ee0e70d7b9dd5fa9a7278dfedb2
parentd1b9bbe0fc1884a6d87b381147a7e7e4fa07084d (diff)
downloadaur-956f08479d28c588d3597b97a55a1613cb5fb513.tar.gz
Remove pandoc & manual because not in 0.1.5 yet
Remove pandoc & the manual because the relevant files are not included in the 0.1.5 release. The next release should already include those files as they are present in the current `master` branch.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
2 files changed, 2 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 380e0fb4e954..52d30801492e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = diffr
pkgdesc = Word-by-word diff highlighting tool
pkgver = 0.1.5
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/mookid/diffr
arch = i686
arch = x86_64
license = MIT
makedepends = cargo
makedepends = git
- optdepends = pandoc: to generate the manual at build time
conflicts = diffr-git
source = diffr-0.1.5.tar.gz::https://static.crates.io/crates/diffr/diffr-0.1.5.crate
b2sums = 0e4bc406a8eb6f2347c9d760f8d2dacd4a258ecd73ffceb0314f1ab8e146db2acce60363c0eed48c8a28983ce95f695d2775780a987bee7bc4ddd5ebaf4d7ec3
diff --git a/PKGBUILD b/PKGBUILD
index b9d82e0db906..ae80f7076551 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,13 @@
pkgname=diffr
pkgver=0.1.5
-pkgrel=2
+pkgrel=3
pkgdesc='Word-by-word diff highlighting tool'
arch=('i686' 'x86_64') # please write me to add more architectures if you test them and they work
url="https://github.com/mookid/diffr"
license=('MIT')
conflicts=('diffr-git')
makedepends=('cargo' 'git')
-optdepends=(
- # This is subjective, but I don't want to force everyone
- # to install pandoc (+350Mb disk space), just for one manual page.
- 'pandoc: to generate the manual at build time'
-)
source=("$pkgname-$pkgver.tar.gz::https://static.crates.io/crates/$pkgname/$pkgname-$pkgver.crate")
b2sums=('0e4bc406a8eb6f2347c9d760f8d2dacd4a258ecd73ffceb0314f1ab8e146db2acce60363c0eed48c8a28983ce95f695d2775780a987bee7bc4ddd5ebaf4d7ec3')
@@ -29,9 +24,6 @@ build() {
export RUSTUP_TOOLCHAIN=stable
export CARGO_TARGET_DIR=target
cargo build --frozen --release --all-features
- if command -v pandoc &> /dev/null; then
- pandoc -s -t man assets/diffr.1.md -o assets/diffr.1
- fi
}
check() {
@@ -46,7 +38,4 @@ package() {
cd "${pkgname}-${pkgver}"
install -Dm755 "target/release/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 "LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
- if test -e "assets/diffr.1"; then
- install -Dm644 "assets/diffr.1" "${pkgdir}/usr/share/man/man1/diffr.1"
- fi
}