summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreugene2024-01-30 03:47:49 +0200
committereugene2024-01-30 03:47:49 +0200
commit95734452eff98f2196d9d95c96f170073d5e1c2a (patch)
tree0f12a4557fa8196c99af64005b7eb8e3b6143b3d
parent6459c24991cbd85f666de1b2b9521de0c86ec4bd (diff)
downloadaur-95734452eff98f2196d9d95c96f170073d5e1c2a.tar.gz
upgrade to 4.25.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD43
2 files changed, 29 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee89985332e5..915045cb5c3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = liquibase
pkgdesc = VCS source control tailored for database management
- pkgver = 4.23.1
+ pkgver = 4.25.1
pkgrel = 1
url = http://www.liquibase.org/
arch = any
- license = Apache
+ license = Apache-2.0
+ depends = bash
depends = java-environment
options = !strip
- source = https://github.com/liquibase/liquibase/releases/download/v4.23.1/liquibase-4.23.1.tar.gz
+ source = https://github.com/liquibase/liquibase/releases/download/v4.25.1/liquibase-4.25.1.tar.gz
source = liquibase.profile
- sha256sums = b9667d97a0ba425547aa9fe66bafeccf4ef3b821e91ae732ec684d0eaf2fd7f5
+ sha256sums = 8b2b7aa8ec755d4ee52fa0210cd2a244fd16ed695fc4a72245562950776d2a56
sha256sums = 7c1939e5b1aee63db199c86989726bbdf81102784512ed69f8595fddf80c30c0
pkgname = liquibase
diff --git a/PKGBUILD b/PKGBUILD
index 0bebb11707e0..c4fff40fc540 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Contributor: Kevin Baxmann <kvbx+aur@kvbx.de>
-# Contributor: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: Chris Severance aur.severach aATt spamgourmet dott com
# Contributor: Andreas Pieber <anpieber@gmail.com>
set -u
pkgname=liquibase
-pkgver=4.23.1
+pkgver=4.25.1
pkgrel=1
pkgdesc='VCS source control tailored for database management'
arch=('any')
url="http://www.liquibase.org/"
-license=('Apache')
-depends=('java-environment')
+license=('Apache-2.0')
+depends=('bash' 'java-environment')
_giturl="https://github.com/liquibase/${pkgname}"
_verwatch=("${_giturl}/releases.atom" '\s\+<link rel="alternate" type="text/html" href="http.*/releases/tag/liquibase-parent-\([^"]\+\)"/>.*' 'f') # RSS
options=('!strip')
source=("https://github.com/liquibase/liquibase/releases/download/v${pkgver}/liquibase-${pkgver}.tar.gz"
"liquibase.profile")
-sha256sums=('b9667d97a0ba425547aa9fe66bafeccf4ef3b821e91ae732ec684d0eaf2fd7f5'
+sha256sums=('8b2b7aa8ec755d4ee52fa0210cd2a244fd16ed695fc4a72245562950776d2a56'
'7c1939e5b1aee63db199c86989726bbdf81102784512ed69f8595fddf80c30c0')
package() {
set -u
@@ -26,27 +26,32 @@ package() {
#install -Dpm644 <(sed -e 's:export :setenv :g' -e 's:=: :g' "${srcdir}/liquibase.profile") "${pkgdir}/etc/profile.d/liquibase.csh"
# This binary link removes the need for the profile files that require a logout to make work
- install -d "${pkgdir}/usr/bin"
- ln -s '/opt/liquibase/liquibase' -t "${pkgdir}/usr/bin/"
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -s "/opt/${pkgname}/liquibase" -t "${pkgdir}/usr/bin/"
- # create folders
- install -d "${pkgdir}/opt/liquibase"
+ # create directories
+ install -dm755 "${pkgdir}/opt/${pkgname}"
# move liquibase tar content to /opt/liquibase
- find "${srcdir}/." -maxdepth 1 -not -type 'l' -not -name '*.' -exec mv '{}' "${pkgdir}/opt/liquibase/" ';'
- #cp -r ${srcdir}/* ${pkgdir}/opt/liquibase
+ find "${srcdir}" -maxdepth 1 -mindepth 1 -not -type l -exec mv -v '{}' "${pkgdir}/opt/${pkgname}/" \;
# make liquibase executable
- chmod 755 "${pkgdir}/opt/liquibase/liquibase"
+ chmod 755 "${pkgdir}/opt/${pkgname}/liquibase"
# remove files for other platforms
- rm -f "${pkgdir}/opt/liquibase"/{liquibase.bat,liquibase.spec}
-
- install -d "${pkgdir}/usr/share/licenses/${pkgbase}/"
- ln -s '/opt/liquibase/LICENSE.txt' -T "${pkgdir}/usr/share/licenses/${pkgbase}/LICENSE"
-
- install -d "${pkgdir}/usr/share/bash-completion/completions/"
- ln -s '/opt/liquibase/lib/liquibase_autocomplete.sh' -T "${pkgdir}/usr/share/bash-completion/completions/${pkgbase}"
+ rm -f "${pkgdir}/opt/${pkgname}/liquibase.bat"
+
+ # install license files
+ install -dm755 "${pkgdir}/usr/share/licenses/${pkgname}/"
+ mv -v "${pkgdir}/opt/${pkgname}/licenses/"{commercial,oss} "${pkgdir}/usr/share/licenses/${pkgname}/"
+ ln -s "/usr/share/licenses/${pkgname}/"{commercial,oss} "${pkgdir}/opt/${pkgname}/licenses/"
+ mv -v "${pkgdir}/opt/${pkgname}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ ln -s "/usr/share/licenses/${pkgname}/LICENSE" "${pkgdir}/opt/${pkgname}/LICENSE.txt"
+
+ # install shell completions
+ install -Dvm644 "${pkgdir}/opt/${pkgname}/lib/liquibase_autocomplete.sh" "${pkgdir}/usr/share/bash-completion/completions/${pkgname}"
+ install -Dvm644 "${pkgdir}/opt/${pkgname}/lib/liquibase_autocomplete.zsh" "${pkgdir}/usr/share/zsh/site-functions/_${pkgname}"
+ rm -fv "${pkgdir}/opt/${pkgname}/lib/"{liquibase_autocomplete_mac.bash,liquibase_autocomplete.sh,liquibase_autocomplete.zsh}
set +u
}