summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlfredo Ramos2017-06-08 17:23:14 -0500
committerAlfredo Ramos2017-06-08 17:23:20 -0500
commit957421bee2e538329abffa1743b4efe3838ddcf5 (patch)
treea0169fe5010acea76ce60001ff01544c918ee596
parentb0cdec5348cd27af79abda15994b0fddb990fb9e (diff)
downloadaur-957421bee2e538329abffa1743b4efe3838ddcf5.tar.gz
PythonQt issue fixed
A modified version from my experimental patch were merged https://gist.github.com/AlfredoRamos/b83046b8686840db656c08f175bd8f10 https://github.com/olav-st/screencloud/issues/281
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
-rw-r--r--fix_pythonqt.patch24
3 files changed, 7 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3eed3211538f..2ffec02e8ecd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = screencloud-git
pkgdesc = An easy to use screenshot sharing tool. Development version.
- pkgver = 1.3.1.3.g74724ca
- pkgrel = 4
+ pkgver = 1.3.1.5.gc9482a7
+ pkgrel = 2
url = https://screencloud.net/
arch = i686
arch = x86_64
@@ -17,12 +17,10 @@ pkgbase = screencloud-git
depends = xdg-utils
depends = hicolor-icon-theme
optdepends = python-crypto: for SFTP support
- provides = screencloud=1.3.1.3.g74724ca
+ provides = screencloud=1.3.1.5.gc9482a7
conflicts = screencloud
source = git+https://github.com/olav-st/screencloud.git
- source = fix_pythonqt.patch
sha512sums = SKIP
- sha512sums = f953f57e21db580c299f48fb1b02452ee7bd612701ead112ad05a42a531fe07e3207569135ec91a8895b57481607ccfd429aa7fa4336b122d7bcf71f1b88f316
pkgname = screencloud-git
diff --git a/PKGBUILD b/PKGBUILD
index 1831f2e265bf..b32bca4150e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_pkgname=screencloud
pkgname=${_pkgname}-git
-pkgver=1.3.1.3.g74724ca
-pkgrel=4
+pkgver=1.3.1.5.gc9482a7
+pkgrel=2
pkgdesc='An easy to use screenshot sharing tool. Development version.'
arch=('i686' 'x86_64')
url='https://screencloud.net/'
@@ -20,14 +20,8 @@ makedepends=('cmake' 'git' 'qt5-tools')
provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
-source=(
- "git+https://github.com/olav-st/${_pkgname}.git"
- 'fix_pythonqt.patch'
-)
-sha512sums=(
- 'SKIP'
- 'f953f57e21db580c299f48fb1b02452ee7bd612701ead112ad05a42a531fe07e3207569135ec91a8895b57481607ccfd429aa7fa4336b122d7bcf71f1b88f316'
-)
+source=("git+https://github.com/olav-st/${_pkgname}.git")
+sha512sums=('SKIP')
pkgver() {
# Updating package version
@@ -38,10 +32,6 @@ pkgver() {
prepare() {
# Create build directory
mkdir -p "${srcdir}"/build
-
- # Fix PythonQt detection
- cd "${srcdir}"/${_pkgname}
- patch -Np1 < ../fix_pythonqt.patch
}
build() {
diff --git a/fix_pythonqt.patch b/fix_pythonqt.patch
deleted file mode 100644
index 3fdc483460cb..000000000000
--- a/fix_pythonqt.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -uprNEBZ --suppress-blank-empty a/cmake/modules/FindPythonQt.cmake b/cmake/modules/FindPythonQt.cmake
---- a/cmake/modules/FindPythonQt.cmake 2017-06-08 10:41:37.661363000 -0500
-+++ b/cmake/modules/FindPythonQt.cmake 2017-06-08 10:43:09.778030233 -0500
-@@ -5,7 +5,7 @@
-
- find_path(PYTHONQT_INSTALL_DIR include/PythonQt/PythonQt.h DOC "Directory where PythonQt was installed.")
- find_path(PYTHONQT_INCLUDE_DIR PythonQt.h "${PYTHONQT_INSTALL_DIR}/include/PythonQt" DOC "Path to the PythonQt include directory")
--find_library(PYTHONQT_LIBRARY NAMES PythonQt QtPython PATHS "${PYTHONQT_INSTALL_DIR}/lib" DOC "The PythonQt library.")
-+find_library(PYTHONQT_LIBRARY NAMES PythonQt QtPython PythonQt-Qt5-Python3 PATHS "${PYTHONQT_INSTALL_DIR}/lib" DOC "The PythonQt library.")
-
- mark_as_advanced(PYTHONQT_INSTALL_DIR)
- mark_as_advanced(PYTHONQT_INCLUDE_DIR)
-diff -uprNEBZ --suppress-blank-empty a/cmake/modules/FindPythonQt_QtAll.cmake b/cmake/modules/FindPythonQt_QtAll.cmake
---- a/cmake/modules/FindPythonQt_QtAll.cmake 2017-06-08 10:41:37.661363000 -0500
-+++ b/cmake/modules/FindPythonQt_QtAll.cmake 2017-06-08 10:44:16.514697198 -0500
-@@ -6,7 +6,7 @@
-
- find_path(PYTHONQT_QTALL_INSTALL_DIR NAMES include/PythonQt/PythonQt_QtAll.h include/PythonQt/extensions/PythonQt_QtAll/PythonQt_QtAll.h DOC "Directory where PythonQt_QtAll.h was installed.")
- find_path(PYTHONQT_QTALL_INCLUDE_DIR PythonQt_QtAll.h PATHS "${PYTHONQT_QTALL_INSTALL_DIR}/include/PythonQt" "${PYTHONQT_QTALL_INSTALL_DIR}/include/PythonQt/extensions/PythonQt_QtAll" ${CMAKE_INCLUDE_PATH} ${CMAKE_INSTALL_PREFIX}/include ${CMAKE_INSTALL_PREFIX}/include/PythonQt ${CMAKE_INSTALL_PREFIX}/include/PythonQt/extensions/PythonQt_QtAll DOC "Path to the PythonQt_QtAll include directory")
--find_library(PYTHONQT_QTALL_LIBRARY NAMES PythonQt_QtAll QtPython_QtAll PATHS "${PYTHONQT_QTALL_INSTALL_DIR}/extensions/PythonQt_QtAll" DOC "The PythonQt_QtAll library.")
-+find_library(PYTHONQT_QTALL_LIBRARY NAMES PythonQt_QtAll QtPython_QtAll PythonQt_QtAll-Qt5-Python3 PATHS "${PYTHONQT_QTALL_INSTALL_DIR}/extensions/PythonQt_QtAll" DOC "The PythonQt_QtAll library.")
-
- mark_as_advanced(PYTHONQT_QTALL_INSTALL_DIR)
- mark_as_advanced(PYTHONQT_QTALL_INCLUDE_DIR)