summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreyenx2022-04-22 18:23:23 +0200
committereyenx2022-04-22 18:23:23 +0200
commit9574f4f740ac54604ff6b5903edbcf93675a5ceb (patch)
tree73184d8482cf71bb97fbbb2dc2e7c3c72f1c930b
parentd5eb6d4743cd348a1d7c313017a68951d4dd74a8 (diff)
downloadaur-9574f4f740ac54604ff6b5903edbcf93675a5ceb.tar.gz
chore(update): v22
Signed-off-by: eyenx <eye@eyenx.ch>
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b979030a3e84..9c705014b7a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = gnome-shell-extension-taskwhisperer
pkgdesc = Gnome Shell TaskWarrior integration
- pkgver = 20
+ pkgver = 22
pkgrel = 1
url = https://github.com/cinatic/taskwhisperer
arch = any
license = GPL3
depends = gnome-shell
- source = https://github.com/cinatic/taskwhisperer/archive/v20.tar.gz
- sha256sums = 663d3d4d6997e517ab24b29ca75584d9ead69d36799e7c8aa91a95925bd4905e
+ source = v22.tar.gz::https://github.com/cinatic/taskwhisperer/releases/download/v22/taskwhisperer-extension.zip
+ sha256sums = 2ce8ab02d53f97a525697dff8d952b119fa5123dc3a5abfef4d0a9b42ec9e293
pkgname = gnome-shell-extension-taskwhisperer
-
diff --git a/PKGBUILD b/PKGBUILD
index 31fcd2211093..75a414063d9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,17 @@
pkgname=gnome-shell-extension-taskwhisperer
_pkgname=taskwhisperer
-pkgver=20
+pkgver=22
pkgrel=1
pkgdesc="Gnome Shell TaskWarrior integration"
arch=('any')
url="https://github.com/cinatic/taskwhisperer"
license=('GPL3')
depends=('gnome-shell')
-source=("https://github.com/cinatic/taskwhisperer/archive/v${pkgver}.tar.gz")
-sha256sums=('663d3d4d6997e517ab24b29ca75584d9ead69d36799e7c8aa91a95925bd4905e')
+source=("v${pkgver}.tar.gz::https://github.com/cinatic/taskwhisperer/releases/download/v${pkgver}/taskwhisperer-extension.zip")
+sha256sums=('2ce8ab02d53f97a525697dff8d952b119fa5123dc3a5abfef4d0a9b42ec9e293')
package() {
- _extid='taskwhisperer-extension@infinicode.de'
- install -dm755 "$pkgdir/usr/share/gnome-shell/extensions"
- cp -r "${_pkgname}-${pkgver}/${_extid}" "${pkgdir}/usr/share/gnome-shell/extensions"
+ install -dm755 "$pkgdir/usr/share/gnome-shell/extensions/taskwhisperer"
+ cp -r . "${pkgdir}/usr/share/gnome-shell/extensions/taskwhisperer"
}