summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-06-13 00:16:22 -0400
committerKyle Keen2015-06-13 00:16:22 -0400
commit957868350fdf4ec658edd0bba98d465dfdf2332a (patch)
tree820356170c81b9328b96ae5422d2643d5b79dda7
downloadaur-957868350fdf4ec658edd0bba98d465dfdf2332a.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD55
-rw-r--r--structuresynth.install13
4 files changed, 99 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..a73ede14280c
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = structuresynth
+ pkgdesc = Graphics tool to make 3D structures from sets of rules, similar to Context Free.
+ pkgver = 1.5.0
+ pkgrel = 4
+ url = http://structuresynth.sourceforge.net
+ install = structuresynth.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = qt5-script
+ depends = qt5-base
+ source = http://downloads.sourceforge.net/structuresynth/StructureSynth-Source-v1.5.0.zip
+
+pkgname = structuresynth
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47fa71ee80ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = structuresynth
+ pkgdesc = Graphics tool to make 3D structures from sets of rules, similar to Context Free.
+ pkgver = 1.5.0
+ pkgrel = 4
+ url = http://structuresynth.sourceforge.net
+ install = structuresynth.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = qt5-script
+ depends = qt5-base
+ source = http://downloads.sourceforge.net/structuresynth/StructureSynth-Source-v1.5.0.zip
+ md5sums = 862705c5bc9e778094046399f44d6c26
+
+pkgname = structuresynth
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63b45a82b8e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+# Contributor: Adrian Carpenter <adriatic.c@gmail.com>
+pkgname=structuresynth
+pkgver=1.5.0
+pkgrel=4
+pkgdesc="Graphics tool to make 3D structures from sets of rules, similar to Context Free."
+arch=('i686' 'x86_64')
+url="http://structuresynth.sourceforge.net"
+license=('GPL')
+depends=('qt5-base')
+makedepends=('qt5-script')
+source=("http://downloads.sourceforge.net/structuresynth/StructureSynth-Source-v${pkgver}.zip")
+md5sums=('862705c5bc9e778094046399f44d6c26')
+install=${pkgname}.install
+
+build() {
+ cd "$srcdir/Structure Synth Source Code/"
+
+ _patches=("s|loose|lose|"
+ "s|\.\./\.\./Misc|/usr/share/$pkgname/Misc|"
+ "s|\.\./\.\./Examples|/usr/share/$pkgname/Examples|")
+ for _i in "${_patches[@]}"; do
+ sed -ie "$_i" StructureSynth/GUI/MainWindow.cpp
+ done
+ _patches_2=("s|QtGui/||" "s|\, QApplication::UnicodeUTF8||" )
+ for _i in "${_patches_2[@]}"; do
+ sed -ie "$_i" StructureSynth/GUI/TemplateExportDialog.h
+ sed -ie "$_i" StructureSynth/GUI/TemplateExportDialog.cpp
+ done
+ sed -i "2i #include <GL/glu.h>" SyntopiaCore/GLEngine/{Sphere.h,Raytracer/RayTracer.cpp}
+
+ qmake -project -after "CONFIG+=opengl" -after "QT+=xml opengl script" -after "unix:LIBS+=-lGLU -L/usr/lib64"
+ qmake
+ make
+}
+
+package() {
+ cd "$srcdir/Structure Synth Source Code/"
+ mkdir -p "$pkgdir/usr/share/applications"
+ cp structure-synth.desktop "$pkgdir/usr/share/applications"
+ mkdir -p "$pkgdir/usr/share/icons"
+ cp images/fileicons/StructureSynth-256.png "$pkgdir/usr/share/icons/structure-synth.png"
+
+ mkdir -p "$pkgdir/usr/share/$pkgname"
+ cp -rv Examples Misc "$pkgdir/usr/share/$pkgname"
+ #rm -r "${pkgdir}/usr/share/${pkgname}/Examples/DontDeploy"
+ chmod -R 0644 "$pkgdir/usr/share/$pkgname"
+ chmod 0755 "$pkgdir/usr/share/$pkgname"
+ chmod 0755 "$pkgdir/usr/share/$pkgname/Examples"
+ chmod 0755 "$pkgdir/usr/share/$pkgname/Examples/Tutorials"
+ chmod 0755 "$pkgdir/usr/share/$pkgname/Misc"
+ install -Dm0755 "Structure Synth Source Code" "$pkgdir/usr/bin/structure-synth"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/structuresynth.install b/structuresynth.install
new file mode 100644
index 000000000000..205aedb1c65f
--- /dev/null
+++ b/structuresynth.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo -n "Updating desktop database... "
+ update-desktop-database -q
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}