summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Schanz2023-10-21 22:49:16 +0200
committerMarkus Schanz2023-10-21 22:58:54 +0200
commit95925e311ece8cc0e9ab09e57ed9487e0fe38b9d (patch)
treef7b86ac3d3e47258bc353ec8126881eec00c94b9
parent3ed63adb6dec8b4500ee75834bc4b07c6867950f (diff)
downloadaur-95925e311ece8cc0e9ab09e57ed9487e0fe38b9d.tar.gz
Hooks now trigger for all kernels in /boot that match vmlinuz-*
-rw-r--r--.SRCINFO10
-rw-r--r--50_bootbackup.hook5
-rw-r--r--CHANGELOG1
-rw-r--r--PKGBUILD10
-rw-r--r--uu_bootbackup.hook5
5 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6decdf0aba9..a44db8c941c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,10 +11,10 @@ pkgbase = pacman-boot-backup-hook
source = 50_bootbackup.hook
source = uu_bootbackup.hook
source = pacman-boot-backup.conf
- md5sums = ac9ac34b11dd5a53d096a734ab677479
- md5sums = b9dcf01f081c8a2aa10b53e46b2add06
- md5sums = a38b6feb83944ea401e871b2c2fa704d
- md5sums = 41d1095e8e4ee71e1ef6fa11a0c0180e
- md5sums = 24b9fcd221dce61036831f9a6e2b49bb
+ sha256sums = c70e605b0f57a2e4a20f76ff77935cb3bfce4adcf8b654aba4ef4e5103b431f2
+ sha256sums = 2445f388b4bc94382d25e01175babc804821090706d9ac69b5fadfbf5c60d5a9
+ sha256sums = bfdb5d9f83f1cd9d9a427cb302883b4ddfa53e4e39e45c3006066baf5b84ce81
+ sha256sums = a4b17a1dddaa6516258431fa67ecf236a128d3c7d640598423e13b2404e14e31
+ sha256sums = 1cefb346964c3aa4db829bffa788c39839f7a0959f294c91cdb43ae591c8472d
pkgname = pacman-boot-backup-hook
diff --git a/50_bootbackup.hook b/50_bootbackup.hook
index 97ddabc5bdde..6f435499b023 100644
--- a/50_bootbackup.hook
+++ b/50_bootbackup.hook
@@ -6,10 +6,11 @@ Operation = Remove
Target = systemd
[Trigger]
-Type = File
+Type = Path
Operation = Install
Operation = Upgrade
-Target = boot/vmlinuz-linux
+Target = boot/vmlinuz-*
+Target = usr/lib/modules/*/vmlinuz
Target = usr/lib/initcpio/*
[Action]
diff --git a/CHANGELOG b/CHANGELOG
index bbda70d895f4..13f7b95631d1 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,4 +1,5 @@
v1.7 (2023/10/21):
+- Introduce compatibility for users that have installed kernels other than the default linux kernel
- Removed install script which was merely used to notify users about a breaking change that was introduced 5 years ago in v1.4
- removed ncurses dependency alongside with it
diff --git a/PKGBUILD b/PKGBUILD
index 1101597bf604..8c8bc18bd158 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,11 +13,11 @@ source=('LICENSE'
'50_bootbackup.hook'
'uu_bootbackup.hook'
'pacman-boot-backup.conf')
-md5sums=('ac9ac34b11dd5a53d096a734ab677479'
- 'b9dcf01f081c8a2aa10b53e46b2add06'
- 'a38b6feb83944ea401e871b2c2fa704d'
- '41d1095e8e4ee71e1ef6fa11a0c0180e'
- '24b9fcd221dce61036831f9a6e2b49bb')
+sha256sums=('c70e605b0f57a2e4a20f76ff77935cb3bfce4adcf8b654aba4ef4e5103b431f2'
+ '2445f388b4bc94382d25e01175babc804821090706d9ac69b5fadfbf5c60d5a9'
+ 'bfdb5d9f83f1cd9d9a427cb302883b4ddfa53e4e39e45c3006066baf5b84ce81'
+ 'a4b17a1dddaa6516258431fa67ecf236a128d3c7d640598423e13b2404e14e31'
+ '1cefb346964c3aa4db829bffa788c39839f7a0959f294c91cdb43ae591c8472d')
package() {
install -m 0755 -d $pkgdir/usr/share/licenses/$pkgname
diff --git a/uu_bootbackup.hook b/uu_bootbackup.hook
index c2895de23b20..292f0bea7762 100644
--- a/uu_bootbackup.hook
+++ b/uu_bootbackup.hook
@@ -6,10 +6,11 @@ Operation = Remove
Target = systemd
[Trigger]
-Type = File
+Type = Path
Operation = Install
Operation = Upgrade
-Target = boot/vmlinuz-linux
+Target = boot/vmlinuz-*
+Target = usr/lib/modules/*/vmlinuz
Target = usr/lib/initcpio/*
[Action]