summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2021-06-27 20:54:38 +0200
committerAlphaJack2021-06-27 20:57:28 +0200
commit9599a629452c00b828daa46876347ace88de687d (patch)
tree98435e688279cfe7c64d8834036c02d5c1161754
downloadaur-9599a629452c00b828daa46876347ace88de687d.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD55
-rw-r--r--motioneye.install10
-rw-r--r--motioneye.service11
-rw-r--r--motioneye.tmpfiles4
5 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d3c654b9203c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = motioneye-git
+ pkgdesc = A web frontend for the motion daemon, Python 3 development branch
+ pkgver = 0.42.r38.g25ee819
+ pkgrel = 1
+ url = https://github.com/ccrisan/motioneye.git
+ install = motioneye.install
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = motion
+ depends = python-jinja
+ depends = python-pillow
+ depends = python-pycurl
+ depends = python-tornado5
+ depends = python-six
+ provides = motioneye
+ conflicts = motioneye
+ backup = etc/motioneye/motioneye.conf
+ source = git+https://github.com/ccrisan/motioneye.git#branch=python3
+ source = motioneye.tmpfiles
+ source = motioneye.service
+ sha256sums = SKIP
+ sha256sums = e7447bf9ab023326e7c396ecad8933eaa3399b16d844a34f288cf55b8c917bfa
+ sha256sums = 68880de868b98c5017e2ab6b87122c241873daf393c084710d81b19c9d0663da
+
+pkgname = motioneye-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2caaed6507ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+# Contributor: Jeremy MJ <jskier@gmail.com>
+# Contributor: Niklas Hedlund <nojan1989@gmail.com>
+
+pkgname="motioneye-git"
+pkgver=0.42.r38.g25ee819
+pkgrel=1
+pkgdesc="A web frontend for the motion daemon, Python 3 development branch"
+url="https://github.com/ccrisan/motioneye.git"
+license=("GPL3")
+arch=("any")
+provides=("motioneye")
+conflicts=("motioneye")
+depends=("motion"
+ "python-jinja"
+ "python-pillow"
+ "python-pycurl"
+ "python-tornado5" # required for @asynchronous handler, deprecated in python-tornaod 5.1 and removed in 6.0
+ "python-six")
+makedepends=("python-setuptools")
+backup=("etc/motioneye/motioneye.conf")
+source=("git+$url#branch=python3"
+ "motioneye.tmpfiles"
+ "motioneye.service")
+sha256sums=("SKIP"
+ "e7447bf9ab023326e7c396ecad8933eaa3399b16d844a34f288cf55b8c917bfa"
+ "68880de868b98c5017e2ab6b87122c241873daf393c084710d81b19c9d0663da")
+backup=("etc/motioneye/motioneye.conf")
+install="motioneye.install"
+
+pkgver(){
+ cd "motioneye"
+ git describe --long --tags | sed "s/\([^-]*-g\)/r\1/;s/-/./g;s/^v//"
+}
+
+prepare(){
+ cd "motioneye"
+ sed -i "extra/motioneye.conf.sample" \
+ -e 's|^run_path /var/run$|run_path /var/lib/motioneye|'
+}
+
+build(){
+ cd "motioneye"
+ python setup.py build
+}
+
+package(){
+ cd "motioneye"
+ python setup.py install --root="$pkgdir" --optimize=1
+ # configuration folder must be writable by motioneye
+ install -D -m 660 "extra/motioneye.conf.sample" "$pkgdir/etc/motioneye/motioneye.conf"
+ install -D -m 644 "$srcdir/motioneye.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/motioneye.conf"
+ install -D -m 644 "$srcdir/motioneye.service" "$pkgdir/usr/lib/systemd/system/motioneye.service"
+}
+
diff --git a/motioneye.install b/motioneye.install
new file mode 100644
index 000000000000..87c10345490d
--- /dev/null
+++ b/motioneye.install
@@ -0,0 +1,10 @@
+post_install(){
+ cat <<INFO
+
+ The default login credentials for the web interface are:
+
+ username: admin
+ password: (no password)
+
+INFO
+}
diff --git a/motioneye.service b/motioneye.service
new file mode 100644
index 000000000000..e785478e0450
--- /dev/null
+++ b/motioneye.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=motionEye server
+After=local-fs.target network.target
+
+[Service]
+User=motion
+ExecStart=/usr/bin/meyectl startserver -c /etc/motioneye/motioneye.conf
+Type=simple
+
+[Install]
+WantedBy=multi-user.target
diff --git a/motioneye.tmpfiles b/motioneye.tmpfiles
new file mode 100644
index 000000000000..02aa9bf5384d
--- /dev/null
+++ b/motioneye.tmpfiles
@@ -0,0 +1,4 @@
+d /etc/motioneye 0770 root motion
+f /etc/motioneye/motioneye.conf 0660 root motion
+d /var/lib/motioneye 0750 motion motion
+Z /var/lib/motioneye - motion motion