summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Devaev2022-07-26 19:08:55 +0300
committerMaxim Devaev2022-07-26 19:08:55 +0300
commit95a8847994a9e3f46e25b83773fc5afd30187e7b (patch)
tree344da79513d1f9a8d558291a323cee64bb8cf4b6
parent69566c12d90182920af1c038015e3613f97652f3 (diff)
downloadaur-95a8847994a9e3f46e25b83773fc5afd30187e7b.tar.gz
5.17
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b917dcbc3e6b..11feef58fd34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ustreamer
- pkgdesc = Lightweight and fast MJPG-HTTP streamer
- pkgver = 4.6
+ pkgdesc = Lightweight and fast MJPEG-HTTP streamer
+ pkgver = 5.17
pkgrel = 1
url = https://github.com/pikvm/ustreamer
arch = i686
@@ -11,13 +11,21 @@ pkgbase = ustreamer
license = GPL
makedepends = gcc
makedepends = make
+ makedepends = systemd
makedepends = python-setuptools
+ makedepends = janus-gateway-pikvm
+ makedepends = alsa-lib
+ makedepends = opus
depends = libjpeg
depends = libevent
depends = libbsd
depends = libgpiod
+ depends = systemd
depends = python
- source = ustreamer::git+https://github.com/pikvm/ustreamer#commit=v4.6
+ depends = janus-gateway-pikvm
+ depends = alsa-lib
+ depends = opus
+ source = ustreamer::git+https://github.com/pikvm/ustreamer#commit=v5.17
md5sums = SKIP
pkgname = ustreamer
diff --git a/PKGBUILD b/PKGBUILD
index 327906cf82f4..4a6888ce04cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,32 +3,27 @@
pkgname=ustreamer
-pkgver=4.6
+pkgver=5.17
pkgrel=1
-pkgdesc="Lightweight and fast MJPG-HTTP streamer"
+pkgdesc="Lightweight and fast MJPEG-HTTP streamer"
url="https://github.com/pikvm/ustreamer"
license=(GPL)
arch=(i686 x86_64 armv6h armv7h aarch64)
-depends=(libjpeg libevent libbsd libgpiod)
-makedepends=(gcc make)
+depends=(libjpeg libevent libbsd libgpiod systemd)
+makedepends=(gcc make systemd)
source=(${pkgname}::"git+https://github.com/pikvm/ustreamer#commit=v${pkgver}")
md5sums=(SKIP)
-_options="WITH_GPIO=1"
+_options="WITH_GPIO=1 WITH_SYSTEMD=1"
if [ -e /usr/bin/python3 ]; then
_options="$_options WITH_PYTHON=1"
depends+=(python)
makedepends+=(python-setuptools)
fi
-if [ -e /opt/vc/include/IL/OMX_Core.h ]; then
- depends+=(raspberrypi-firmware)
- makedepends+=(raspberrypi-firmware)
- _options="$_options WITH_OMX=1"
-fi
if [ -e /usr/include/janus/plugins/plugin.h ];then
- depends+=(janus-gateway-pikvm)
- makedepends+=(janus-gateway-pikvm)
+ depends+=(janus-gateway-pikvm alsa-lib opus)
+ makedepends+=(janus-gateway-pikvm alsa-lib opus)
_options="$_options WITH_JANUS=1"
fi