summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHui Yiqun2017-12-07 16:17:54 +0800
committerHui Yiqun2017-12-07 16:17:54 +0800
commit95b6ab0bf02a185bf626c0f218fe979ad7035de3 (patch)
tree2cfa8ae13a9ab6be529485bd88bbce4b6b333f79
parent1b7f83f2e889a6318d665065fb6d5f7e5a6d4f9b (diff)
downloadaur-95b6ab0bf02a185bf626c0f218fe979ad7035de3.tar.gz
come up with the change of nginx package
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD59
2 files changed, 54 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3175ead06225..ed0feaa0beec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,35 +1,45 @@
pkgbase = nginx-rtmp
- pkgdesc = Lightweight HTTP server and IMAP/POP3 proxy server, with nginx-rtmp-module
- pkgver = 1.12.1
+ pkgdesc = NGINX-based Media Streaming Server
+ pkgver = 1.12.2
pkgrel = 1
- url = https://nginx.org
+ url = https://nginx-rtmp.blogspot.com/
install = nginx.install
- arch = i686
arch = x86_64
license = custom
+ checkdepends = perl
+ checkdepends = perl-gd
+ checkdepends = perl-io-socket-ssl
+ checkdepends = perl-fcgi
+ checkdepends = perl-cache-memcached
+ checkdepends = memcached
+ checkdepends = ffmpeg
+ checkdepends = inetutils
+ makedepends = mercurial
depends = pcre
depends = zlib
depends = openssl
depends = geoip
+ depends = mailcap
provides = nginx
conflicts = nginx
backup = etc/nginx/fastcgi.conf
backup = etc/nginx/fastcgi_params
backup = etc/nginx/koi-win
backup = etc/nginx/koi-utf
- backup = etc/nginx/mime.types
backup = etc/nginx/nginx.conf
backup = etc/nginx/scgi_params
backup = etc/nginx/uwsgi_params
backup = etc/nginx/win-utf
backup = etc/logrotate.d/nginx
- source = https://nginx.org/download/nginx-1.12.1.tar.gz
- source = https://github.com/arut/nginx-rtmp-module/archive/v1.2.0.tar.gz
+ source = https://nginx-rtmp.blogspot.com//download/nginx-1.12.2.tar.gz
+ source = https://github.com/arut/nginx-rtmp-module/archive/v1.2.1.tar.gz
+ source = hg+http://hg.nginx.org/nginx-tests#revision=cbda704b3093
source = service
source = logrotate
- md5sums = a307e74aca95403e5ee00f153807ce58
- md5sums = 1a47951b64f3f726a9d4620774643759
- md5sums = 09862c34cd9593bc40da81f88c5fc4b2
+ md5sums = 4d2fc76211435f029271f1cf6d7eeae3
+ md5sums = 639ac2b78103adaccbcfe484a92acf44
+ md5sums = SKIP
+ md5sums = ef491e760e7c1ffec9ca25441a150c83
md5sums = 6a01fb17af86f03707c8ae60f98a2dc2
pkgname = nginx-rtmp
diff --git a/PKGBUILD b/PKGBUILD
index 2f8f4fed1f4e..d8e2ad9b62b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,44 @@
# Maintainer: Hui Yiqun <huiyiqun@gmail.com>
-pkgname=nginx-rtmp
+
_pkgname=nginx
-pkgver=1.12.1
-_rtmpver=1.2.0
+pkgname=$_pkgname-rtmp
+pkgver=1.12.2
+_rtmpver=1.2.1
pkgrel=1
-pkgdesc='Lightweight HTTP server and IMAP/POP3 proxy server, with nginx-rtmp-module'
-arch=('i686' 'x86_64')
-url='https://nginx.org'
-license=('custom')
-depends=('pcre' 'zlib' 'openssl' 'geoip')
-provides=('nginx')
-conflicts=('nginx')
-backup=('etc/nginx/fastcgi.conf'
- 'etc/nginx/fastcgi_params'
- 'etc/nginx/koi-win'
- 'etc/nginx/koi-utf'
- 'etc/nginx/mime.types'
- 'etc/nginx/nginx.conf'
- 'etc/nginx/scgi_params'
- 'etc/nginx/uwsgi_params'
- 'etc/nginx/win-utf'
- 'etc/logrotate.d/nginx')
+pkgdesc='NGINX-based Media Streaming Server'
+arch=(x86_64)
+url='https://nginx-rtmp.blogspot.com/'
+license=(custom)
+depends=(pcre zlib openssl geoip mailcap)
+makedepends=(mercurial)
+checkdepends=(perl perl-gd perl-io-socket-ssl perl-fcgi perl-cache-memcached
+ memcached ffmpeg inetutils)
+backup=(etc/nginx/fastcgi.conf
+ etc/nginx/fastcgi_params
+ etc/nginx/koi-win
+ etc/nginx/koi-utf
+ etc/nginx/nginx.conf
+ etc/nginx/scgi_params
+ etc/nginx/uwsgi_params
+ etc/nginx/win-utf
+ etc/logrotate.d/nginx)
install=nginx.install
source=($url/download/nginx-$pkgver.tar.gz
https://github.com/arut/nginx-rtmp-module/archive/v$_rtmpver.tar.gz
+ hg+http://hg.nginx.org/nginx-tests#revision=cbda704b3093
service
logrotate)
-md5sums=('a307e74aca95403e5ee00f153807ce58'
- '1a47951b64f3f726a9d4620774643759'
+provides=('nginx')
+conflicts=('nginx')
+md5sums=('4d2fc76211435f029271f1cf6d7eeae3'
+ '639ac2b78103adaccbcfe484a92acf44'
+ 'SKIP'
'ef491e760e7c1ffec9ca25441a150c83'
'6a01fb17af86f03707c8ae60f98a2dc2')
_common_flags=(
--with-compat
+ --with-debug
--with-file-aio
--with-http_addition_module
--with-http_auth_request_module
@@ -86,10 +92,14 @@ build() {
${_common_flags[@]} \
${_stable_flags[@]}
-
make
}
+check() {
+ cd nginx-tests
+ TEST_NGINX_BINARY="$srcdir/$_pkgname-$pkgver/objs/nginx" prove .
+}
+
package() {
cd $_pkgname-$pkgver
make DESTDIR="$pkgdir" install
@@ -100,6 +110,7 @@ package() {
-i "$pkgdir"/etc/nginx/nginx.conf
rm "$pkgdir"/etc/nginx/*.default
+ rm "$pkgdir"/etc/nginx/mime.types # in mailcap
install -d "$pkgdir"/var/lib/nginx
install -dm700 "$pkgdir"/var/lib/nginx/proxy
@@ -125,5 +136,3 @@ package() {
"$pkgdir/usr/share/vim/vimfiles/$i/nginx.vim"
done
}
-
-# vim:set ts=2 sw=2 et: