summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVaporeon2022-05-27 22:42:59 +1200
committerVaporeon2022-05-27 22:42:59 +1200
commit95be568d2723c90697ab359c9568d2053052bce0 (patch)
treec2c2a9dba52d432a2ed821e5a51595ab9ec52d21
parent7a77e8dd8ec273a169fb86d68969c77046d2345a (diff)
downloadaur-95be568d2723c90697ab359c9568d2053052bce0.tar.gz
3.6.1
-rw-r--r--.SRCINFO8
-rw-r--r--0001-libarchive-3.3.3-bcrypt-fix.patch63
-rw-r--r--PKGBUILD48
3 files changed, 24 insertions, 95 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21d47fcf7e4f..a338c1e090c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-libarchive
pkgdesc = library that can create and read several streaming archive formats (mingw-w64)
- pkgver = 3.6.0
+ pkgver = 3.6.1
pkgrel = 1
url = http://www.libarchive.org/
arch = any
@@ -20,9 +20,7 @@ pkgbase = mingw-w64-libarchive
options = !buildflags
options = staticlibs
options = !strip
- source = libarchive-3.6.0.tar.gz::https://github.com/libarchive/libarchive/archive/v3.6.0.tar.gz
- source = 0001-libarchive-3.3.3-bcrypt-fix.patch
- sha256sums = 9f9c1a21e570242c0d2854964d5e9ce00bb87144c19feac282b027146a86d0e3
- sha256sums = 2c318a025029998a9389eb99ab80f733c0fcf3b4888421879f2f6b4530d7f522
+ source = https://github.com/libarchive/libarchive/releases/download/v3.6.1/libarchive-3.6.1.tar.xz
+ sha256sums = 5a411aceb978f43e626f0c2d1812ddd8807b645ed892453acabd532376c148e6
pkgname = mingw-w64-libarchive
diff --git a/0001-libarchive-3.3.3-bcrypt-fix.patch b/0001-libarchive-3.3.3-bcrypt-fix.patch
deleted file mode 100644
index 1bc3a760184a..000000000000
--- a/0001-libarchive-3.3.3-bcrypt-fix.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-diff -Naur libarchive-3.3.3.orig/libarchive/archive_cryptor.c libarchive-3.3.3/libarchive/archive_cryptor.c
---- libarchive-3.3.3.orig/libarchive/archive_cryptor.c 2018-09-04 15:36:21.010905600 -0400
-+++ libarchive-3.3.3/libarchive/archive_cryptor.c 2018-09-04 15:39:13.953139100 -0400
-@@ -57,7 +57,7 @@
- return 0;
- }
-
--#elif defined(_WIN32) && !defined(__CYGWIN__) && defined(HAVE_BCRYPT_H)
-+#elif defined(_WIN32) || defined(__CYGWIN__) && defined(HAVE_BCRYPT_H) && defined(HAVE_WINDOWS_H)
- #ifdef _MSC_VER
- #pragma comment(lib, "Bcrypt.lib")
- #endif
-@@ -168,7 +168,7 @@
- return 0;
- }
-
--#elif defined(_WIN32) && !defined(__CYGWIN__) && defined(HAVE_BCRYPT_H)
-+#elif defined(_WIN32) || defined(__CYGWIN__) && defined(HAVE_BCRYPT_H) && defined(HAVE_WINDOWS_H)
-
- static int
- aes_ctr_init(archive_crypto_ctx *ctx, const uint8_t *key, size_t key_len)
-diff -Naur libarchive-3.3.3.orig/libarchive/archive_cryptor_private.h libarchive-3.3.3/libarchive/archive_cryptor_private.h
---- libarchive-3.3.3.orig/libarchive/archive_cryptor_private.h 2018-09-04 15:36:21.079906500 -0400
-+++ libarchive-3.3.3/libarchive/archive_cryptor_private.h 2018-09-04 15:39:58.077520000 -0400
-@@ -63,7 +63,10 @@
- unsigned encr_pos;
- } archive_crypto_ctx;
-
--#elif defined(_WIN32) && !defined(__CYGWIN__) && defined(HAVE_BCRYPT_H)
-+#elif defined(_WIN32) || defined(__CYGWIN__) && defined(HAVE_BCRYPT_H) && defined(HAVE_WINDOWS_H)
-+#if defined(__CYGWIN__)
-+ # include <windows.h>
-+#endif
- #include <bcrypt.h>
-
- /* Common in other bcrypt implementations, but missing from VS2008. */
-diff -Naur libarchive-3.3.3.orig/libarchive/archive_hmac.c libarchive-3.3.3/libarchive/archive_hmac.c
---- libarchive-3.3.3.orig/libarchive/archive_hmac.c 2018-09-04 15:36:20.986905600 -0400
-+++ libarchive-3.3.3/libarchive/archive_hmac.c 2018-09-04 15:41:06.218433900 -0400
-@@ -74,7 +74,7 @@
- memset(ctx, 0, sizeof(*ctx));
- }
-
--#elif defined(_WIN32) && !defined(__CYGWIN__) && defined(HAVE_BCRYPT_H)
-+#elif defined(_WIN32) || defined(__CYGWIN__) && defined(HAVE_BCRYPT_H) && defined(HAVE_WINDOWS_H)
-
- #ifndef BCRYPT_HASH_REUSABLE_FLAG
- # define BCRYPT_HASH_REUSABLE_FLAG 0x00000020
-diff -Naur libarchive-3.3.3.orig/libarchive/archive_hmac_private.h libarchive-3.3.3/libarchive/archive_hmac_private.h
---- libarchive-3.3.3.orig/libarchive/archive_hmac_private.h 2018-09-04 15:36:21.006904800 -0400
-+++ libarchive-3.3.3/libarchive/archive_hmac_private.h 2018-09-04 15:42:32.374554800 -0400
-@@ -53,7 +53,10 @@
-
- typedef CCHmacContext archive_hmac_sha1_ctx;
-
--#elif defined(_WIN32) && !defined(__CYGWIN__) && defined(HAVE_BCRYPT_H)
-+#elif defined(_WIN32) || defined(__CYGWIN__) && defined(HAVE_BCRYPT_H) && defined(HAVE_WINDOWS_H)
-+#if defined(__CYGWIN__)
-+ # include <windows.h>
-+#endif
- #include <bcrypt.h>
-
- typedef struct {
diff --git a/PKGBUILD b/PKGBUILD
index 2f2ee01cd993..c3f920cf271a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,10 @@
+# Maintainer: Vaporeon <vaporeon@vaporeon.io>
# Contributor: Andrew Gunnerson <andrewgunnerson@gmail.com>
# Contributor: Dan McGee <dan@archlinux.org>
pkgname=mingw-w64-libarchive
-pkgver=3.6.0
+_pkgname=libarchive
+pkgver=3.6.1
pkgrel=1
pkgdesc="library that can create and read several streaming archive formats (mingw-w64)"
arch=(any)
@@ -11,37 +13,29 @@ license=('BSD')
depends=(mingw-w64-crt mingw-w64-bzip2 mingw-w64-expat mingw-w64-lz4 mingw-w64-lzo mingw-w64-regex mingw-w64-nettle mingw-w64-openssl mingw-w64-xz mingw-w64-zlib mingw-w64-zstd)
makedepends=('mingw-w64-configure')
options=('!buildflags' 'staticlibs' '!strip')
-source=("libarchive-${pkgver}.tar.gz::https://github.com/libarchive/libarchive/archive/v${pkgver}.tar.gz"
- "0001-libarchive-3.3.3-bcrypt-fix.patch")
-sha256sums=('9f9c1a21e570242c0d2854964d5e9ce00bb87144c19feac282b027146a86d0e3'
- '2c318a025029998a9389eb99ab80f733c0fcf3b4888421879f2f6b4530d7f522')
-
-prepare() {
- cd "${srcdir}/libarchive-${pkgver}"
- patch -p1 -i ${srcdir}/0001-libarchive-3.3.3-bcrypt-fix.patch
- autoreconf -fiv
-}
+source=("https://github.com/${_pkgname}/${_pkgname}/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tar.xz")
+sha256sums=('5a411aceb978f43e626f0c2d1812ddd8807b645ed892453acabd532376c148e6')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- cd "${srcdir}/libarchive-${pkgver}"
- for _arch in ${_architectures}; do
- mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-configure \
- --without-xml2 \
- ..
- make
- popd
- done
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-configure \
+ --without-xml2 \
+ ..
+ make
+ popd
+ done
}
package() {
- for _arch in ${_architectures}; do
- cd "${srcdir}/libarchive-${pkgver}/build-${_arch}"
- make install DESTDIR="${pkgdir}"
- ${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.exe
- ${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
- ${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a
- done
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/${_pkgname}-${pkgver}/build-${_arch}"
+ make install DESTDIR="${pkgdir}"
+ ${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.exe
+ ${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a
+ done
}