summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSosthène Guédon2020-02-14 17:03:35 +0100
committerSosthène Guédon2020-02-15 22:52:51 +0100
commit95c983472fa9c8cbd6506236cd9a9f0f04a401d3 (patch)
tree51665656eba4d94e5a3c70d494d896018d21b3ce
downloadaur-95c983472fa9c8cbd6506236cd9a9f0f04a401d3.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rwxr-xr-xPKGBUILD28
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f34c8bf1acee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = arm-linux-gnueabi-gcc75-linaro-bin
+ pkgdesc = The GNU Compiler Collection - cross compiler fo 32-bit Armv7 Cortex-A
+ pkgver = 7.5
+ pkgrel = 1
+ url = https://www.linaro.org/downloads/
+ arch = x86_64
+ license = GPL
+ source = arm-linux-gnueabi-gcc75-linaro-bin-v7.5::https://releases.linaro.org/components/toolchain/binaries/latest-7/arm-linux-gnueabihf/gcc-linaro-7.5.0-2019.12-x86_64_arm-linux-gnueabihf.tar.xz
+ md5sums = 7e5a330aed9dfbe69c79589911db29d9
+
+pkgname = arm-linux-gnueabi-gcc75-linaro-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..97ad32b1585f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Sosthène Guédon <sosthene.gued@gmail.com>
+pkgname=arm-linux-gnueabi-gcc75-linaro-bin
+_name="gcc-linaro-7.5.0-2019.12-x86_64_arm-linux-gnueabihf"
+pkgver=7.5
+pkgrel=1
+pkgdesc="The GNU Compiler Collection - cross compiler fo 32-bit Armv7 Cortex-A"
+arch=('x86_64')
+url="https://www.linaro.org/downloads/"
+license=('GPL')
+depends=()
+makedepends=()
+md5sums=('7e5a330aed9dfbe69c79589911db29d9')
+
+source=("$pkgname-v$pkgver::https://releases.linaro.org/components/toolchain/binaries/latest-7/arm-linux-gnueabihf/gcc-linaro-7.5.0-2019.12-x86_64_arm-linux-gnueabihf.tar.xz")
+
+
+package() {
+ cd $_name
+ mkdir -p "$pkgdir"/usr/lib/gcc
+ mkdir -p "$pkgdir"/usr/share
+ cp -r bin/ "$pkgdir"/usr/bin
+ cp -r libexec/ "$pkgdir"/usr/libexec
+ cp -r arm-linux-gnueabihf "$pkgdir"/usr/arm-linux-gnueabihf
+ cp -r lib/gcc/arm-linux-gnueabihf "$pkgdir"/usr/lib/gcc/arm-linux-gnueabihf
+ cp -r share/man/man1 "$pkgdir"/usr/share/man1
+ cp -r share/man/man5 "$pkgdir"/usr/share/man5
+ chmod -R 755 "$pkgdir"/usr
+}