summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFethbita2023-08-17 14:40:23 +0300
committerFethbita2023-08-17 14:40:23 +0300
commit95f8cfea56dd6ae79fb11bb7a0e469fa71ec7f63 (patch)
tree4b90601e1f9dc066db09380c6e1ff832cd9b5b19
parent32bf883fa478669ab0860e2c38a1fc9c74cfb6da (diff)
downloadaur-95f8cfea56dd6ae79fb11bb7a0e469fa71ec7f63.tar.gz
add manual license file
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b2e258c73fd..1574b5598361 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,8 +5,13 @@ pkgbase = verifpal
url = https://verifpal.com
arch = x86_64
license = GPL3
+ license = custom:cc-by-nc-nd-4.0
makedepends = go
source = https://source.symbolic.software/verifpal/verifpal/-/archive/v0.27.0/verifpal-v0.27.0.tar.bz2
+ source = verifpal-0.27.0-manual.pdf::https://verifpal.com/res/pdf/manual.pdf
+ source = verifpal-0.27.0-manual-license::https://creativecommons.org/licenses/by-nc-nd/4.0/legalcode.txt
sha256sums = a1a024e271c9364f3076278c2fc3fd0da93b9d5cd75468691d86787fbd61e8c0
+ sha256sums = 13154a262636c1dabf8427e282233f9f642681e518a02241152c723a6de657ab
+ sha256sums = 38762e3777f4ec00a6f769062a7c3f704fb78ce08303ecff88558da4c49cf9ea
pkgname = verifpal
diff --git a/PKGBUILD b/PKGBUILD
index c25a844a4808..8be3336077d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,14 @@ pkgrel=2
pkgdesc="Cryptographic protocol analysis for real-world protocols."
arch=('x86_64')
url="https://verifpal.com"
-license=('GPL3')
+license=('GPL3' 'custom:cc-by-nc-nd-4.0')
makedepends=('go')
source=("https://source.symbolic.software/verifpal/verifpal/-/archive/v${pkgver}/verifpal-v${pkgver}.tar.bz2"
- "$pkgname-$pkgver-manual.pdf::https://verifpal.com/res/pdf/manual.pdf")
+ "$pkgname-$pkgver-manual.pdf::https://verifpal.com/res/pdf/manual.pdf"
+ "$pkgname-$pkgver-manual-license::https://creativecommons.org/licenses/by-nc-nd/4.0/legalcode.txt")
sha256sums=('a1a024e271c9364f3076278c2fc3fd0da93b9d5cd75468691d86787fbd61e8c0'
- '13154a262636c1dabf8427e282233f9f642681e518a02241152c723a6de657ab')
+ '13154a262636c1dabf8427e282233f9f642681e518a02241152c723a6de657ab'
+ '38762e3777f4ec00a6f769062a7c3f704fb78ce08303ecff88558da4c49cf9ea')
prepare(){
cd "$pkgname-v$pkgver"
@@ -38,6 +40,7 @@ check() {
package() {
install -Dm644 "$pkgname-$pkgver-manual.pdf" "${pkgdir}/usr/share/doc/${pkgname}/manual.pdf"
+ install -Dm644 "$pkgname-$pkgver-manual-LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/manual-LICENSE"
cd "$pkgname-v$pkgver"
install -Dm755 "build/linux/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"